none
Access web service in VPN : 407 Proxy authentocation required error

    Question

  • Hi

    I want to access a webservice that is exposed at VPN by our client. I have the asmx url.

    First I created the solicit response port with "Use default proxy configuration", i received the following message

    "Send Port. Details:"WebException: The request failed with HTTP status 407: Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied.  )."

    Then I gave the proxy details in the solicit response port, at that i received the error messages

    Error Code: 502 Proxy Error. The host server is unreachable. (10065)

    Please help.

    In the IE (internet explorer), I gave the same asmx url with LAN settings as "Automatically detect settings" then get the same 502 Proxy error.

    When I removed the "Automatically detect settings" and there is no other settings i did in for LAN settings, the methods in asmx got displayed in IE.

    I am able to access the asmx and get the output via simple .net client application.

    Please help

    Tuesday, April 28, 2009 10:24 AM

Answers

  • I deleted my isolated host and recreated it again with tha same user credentials. Now it started working. :) do not know how.but it did :)
    • Marked as answer by vinothanu Thursday, April 30, 2009 9:54 AM
    Thursday, April 30, 2009 9:54 AM

All replies

  • You have a proxy server (ISA) that is unable to resolve/access the web service across the VPN. This could be due to DNS setup or network access restrictions e.g firewalls preventing the proxy server accessing the VPN.
    However, it would appear that you can access the web service without using a proxy - IE connects when you do not specify a proxy.
    Have you tried setting the 'Do not use proxy" option on the send port? 
    Tuesday, April 28, 2009 11:53 AM
  • If you need to use the Proxy, then you are going to have to get one of the proxy admin's to help you.  Only go around the proxy if the network guys say you can.

    Shawn
    Shawn Morgan Blue Arch Solutions, Inc. shawn.morgan@bluearchsolutions.com
    Tuesday, April 28, 2009 10:12 PM
  • I have traied with  'Do not use proxy" option still getting the below error
    The request failed with HTTP status 407: Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied. )

    Wednesday, April 29, 2009 10:12 AM
  • Where did you set the "do not use proxy" setting?
    Wednesday, April 29, 2009 10:32 AM
  • in the solicit response port i.e. send port
    Wednesday, April 29, 2009 10:38 AM
  • That sounds odd. 
    It may be the DNS is returning the proxy address to all queries

    You may have to ask your network security admins to explain the setup and how it will be possible for the Biztalk Server to communicate with the web service on the VPN. I would imagine the proxy server (which will be in your DMZ) will not have access to the VPN for security reasons.
    Wednesday, April 29, 2009 11:13 AM
  • I am able to access it by a .net console application. but not through biztalk. please help
    • Edited by vinothanu Thursday, April 30, 2009 5:26 AM
    Wednesday, April 29, 2009 12:33 PM
  • I deleted my isolated host and recreated it again with tha same user credentials. Now it started working. :) do not know how.but it did :)
    • Marked as answer by vinothanu Thursday, April 30, 2009 9:54 AM
    Thursday, April 30, 2009 9:54 AM
  • That is bizarre, the isolated host is not involved when consuming web services???
    Thursday, April 30, 2009 11:13 AM
  • I've also had this issue, which was related to the account authentication used sending information for the given webservice call.
    Thursday, July 18, 2013 9:06 AM