none
Lightswitch Security Administration - Unable to delete Windows Authenticated User

    Question

  • I'm hoping this will be a pretty easy question but I'm stumped.  Lightswitch web app uses windows auth (specified users only) and I'm not able to delete a previously added User.  Error is

    As the security administration section is lightswitch generated  I'm not sure where I can handle this.  Assuming I can address via the database but I'm very leery as it seems that this should be a pretty standard ability that lightswitch would give the those who have Security Administration role enabled.  Little help?....


    • Edited by rz1224 Wednesday, July 17, 2013 5:54 PM
    Wednesday, July 17, 2013 5:52 PM

Answers

  • I had the same issue.  You need to provide the sql account for the application connection string with read/write access to the newly created membership provider tables.  Once you do that, you will be able to delete users from within the app.  I don't have it in front of me, but I believe the profile tables are the problem.  The others seem to work out of the box.  
    • Marked as answer by rz1224 Thursday, July 18, 2013 3:57 PM
    Thursday, July 18, 2013 1:52 AM

All replies

  • Can I just give the 'LS_User' in the LS_ClientServicePlan database the 'aspnet_Profile_FullAccess' to solve the problem?  It doesn't seem like I should have to do that--need a little guidance...
    Wednesday, July 17, 2013 8:39 PM
  • I had the same issue.  You need to provide the sql account for the application connection string with read/write access to the newly created membership provider tables.  Once you do that, you will be able to delete users from within the app.  I don't have it in front of me, but I believe the profile tables are the problem.  The others seem to work out of the box.  
    • Marked as answer by rz1224 Thursday, July 18, 2013 3:57 PM
    Thursday, July 18, 2013 1:52 AM
  • Thanks Hessc--added lightswitch sql user to role as described above and it works fine now.  Just needed a little validation so Thank you!
    Thursday, July 18, 2013 3:59 PM
  • Glad it is working for you!
    Thursday, July 18, 2013 5:53 PM