locked
TFS 2012 Extensions for SharePoint Products

    Question

  • Hello!

    We installed TFS 2012 Extensions for SharePoint Products on our SharePoint 2010 dev environment and apparently broke all our web applications. 

    Has anyone encountered similar issue?

    Thank you

    YAFE

    Thursday, September 13, 2012 8:24 PM

Answers

  • Hi YAFE,

    Thanks for your feedback!

    Can you go to the IIS, select Sites, under the sites, do you browse the SharePoint Central Administration?

    Please go to the Team Foundation Administration Console, in the SharePoint Web Applications, please make sure the sharepoint web appliations is set correctly.

    Can you see the Extensions for SharePoint Products in the left of the Team Foundation Administration Console? If yes, please make sure the grant access is set correctly.

    For more inforamtion, please refer to http://blogs.msdn.com/b/teams_wit_tools/archive/2009/11/24/tfs-2010-beta2-troubleshooting-sharepoint-configuration-issues-tf249038.aspx

    Hope it helps!

    Best Regards,


    Cathy Kong [MSFT]
    MSDN Community Support | Feedback to us

    Monday, September 17, 2012 8:54 AM
    Moderator
  • Here is one possible solution:

    There are 4 SharePoint servers in the farm. Two of them are web front ends and two of them are application servers. The application servers also had Central Administration on them. We had to install “Extensions for SharePoint Products” on all the 4 machines on the farm. Once installed, the grant access was given to the web application to interact with the Team Foundation Server, on all the 4 machines. We are able to create projects and also access the Team System Web Access.

    Thank you



    • Edited by YAFE Thursday, October 04, 2012 4:25 PM
    • Marked as answer by YAFE Thursday, October 04, 2012 4:26 PM
    Thursday, October 04, 2012 4:25 PM

All replies

  • Hi YAFE,

    Thanks for your post!

    Can you supply more detailed error information about this?  

    What authentication for SharePoint products do you set? NTLM is the recommended authentication for SharePoint. Team Foundation Server Extensions for SharePoint Products does not support Basic authentication or anonymous authentication.

    Hope it helps!

    Best Regards,


    Cathy Kong [MSFT]
    MSDN Community Support | Feedback to us

    Friday, September 14, 2012 9:02 AM
    Moderator
  • Cathy,

    Thank you for reply.

    The authentication for SharePoint is NTLM. The error we are getting when we try to launch http://mysite is the following:

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Thank you

    Friday, September 14, 2012 1:20 PM
  • Hi YAFE,

    Thanks for your feedback!

    Can you go to the IIS, select Sites, under the sites, do you browse the SharePoint Central Administration?

    Please go to the Team Foundation Administration Console, in the SharePoint Web Applications, please make sure the sharepoint web appliations is set correctly.

    Can you see the Extensions for SharePoint Products in the left of the Team Foundation Administration Console? If yes, please make sure the grant access is set correctly.

    For more inforamtion, please refer to http://blogs.msdn.com/b/teams_wit_tools/archive/2009/11/24/tfs-2010-beta2-troubleshooting-sharepoint-configuration-issues-tf249038.aspx

    Hope it helps!

    Best Regards,


    Cathy Kong [MSFT]
    MSDN Community Support | Feedback to us

    Monday, September 17, 2012 8:54 AM
    Moderator
  • I had the exact same thing happen to me, I have completley removed the TFS and removed the 3 solutions items TFS deployed in the Central Admin, We have always used NTLM, all I get is the error page on all 5 servers in the farm on all 4 sites, the only thing that works is the Central Admin site. 

    Scott Kemp, DBA, Halliburton

    Wednesday, October 03, 2012 3:52 AM
  • Here is one possible solution:

    There are 4 SharePoint servers in the farm. Two of them are web front ends and two of them are application servers. The application servers also had Central Administration on them. We had to install “Extensions for SharePoint Products” on all the 4 machines on the farm. Once installed, the grant access was given to the web application to interact with the Team Foundation Server, on all the 4 machines. We are able to create projects and also access the Team System Web Access.

    Thank you



    • Edited by YAFE Thursday, October 04, 2012 4:25 PM
    • Marked as answer by YAFE Thursday, October 04, 2012 4:26 PM
    Thursday, October 04, 2012 4:25 PM
  • For a smoother integration of the TFS Extensions with a SharePoint farm I would:

    1. Ensure your SharePoint farm is healthy before starting

    2. Install the TFS Extensions (.msi) on each SharePoint server that hosts either Central Admin or a content web application. Don't run through the config wizard before you've run the .msi on all relevant servers.

    3. Configure the extensions on each server by running through the configuration wizard in the TFS Management Console. I typically start with the server that runs Central Admin. For the best success I would pause for a few minutes after running the configuration wizard on each server. (The configuration causes SharePoint to push out changes to the web.config file in the farm and this can take a few minutes to be propogated to all servers. SharePoint doesn't like multiple web.config sync jobs being submitted concurrently, so it's usually prudent to wait until the previous one is complete.)

    If you do run through the configuration wizard before you've run the .msi on each server, then your web applications may appear broken on some servers in the farm (and show the error screen mentioned in the thread) because there are references in the web.config file to assemblies that haven't yet been installed on that particular server. Once the .msi has been installed on that server the error message (caused by this scenario) should go away.

    -Phil

    Thursday, October 18, 2012 7:40 AM