none
Authentication Providers button greyed out. Trying to turn on anonymous access

    Question

  • Please can you assist. I am trying to enable anonymous access. Tutorials point me to:

    'Central Admin > Site Actions > Site Settings > Application Management > Manage web applications > Sharepoint - 80'

    I should then click on 'Authentication Providers'. This button is greyed out.

    I am running in dev on windows 7 64bit.

    Thanks.

    Wednesday, September 08, 2010 11:07 AM

Answers

  • Hi Phillsando,

    lets try to troubleshoot in some ways

    • check if the site needs access on the physical folder ( try to use process monitor tool to help you in this issue, also give to the IUSER read access on the pysical folder of the IIS)
    • try to disable loopback on the server http://support.microsoft.com/kb/896861

     

    • Marked as answer by Lily Wu Friday, September 17, 2010 6:38 AM
    Thursday, September 09, 2010 8:19 PM

All replies

  • In both these links. The step required is 'CLICK AUTHENTICATION PROVIDERS' ... This link is GREYED out in my sharepoint and therefore NOT CLICKABLE. I am looking for an answer to my question.
    Wednesday, September 08, 2010 12:14 PM
  • Hi,

    try to take these steps :

    1.  Browse to SharePoint 4.0 Central Administration, Select Security
    2. In Application Security, select Specify Authentication Providers
    3. Select the Web Application
    4. Click the Default Zone
    5. Check Enable Anonymous (* note that this does not immediately enable Anonymous access; it merely makes the option available on the front-end web application *)

     

    Wednesday, September 08, 2010 12:26 PM
  • In Central Administration have you first selected one of the Web Applications? You'll need to click on one of the web applications before the option in the ribbon will enable.
    John Ross
    SharePoint Server MVP | Sr. Consultant SharePoint911: SharePoint Consulting
    Blog: http://www.sharepoint911.com/blogs/john
    Twitter: @JohnRossJr

    Professional SharePoint 2010 Branding and User Interface Design
    Wednesday, September 08, 2010 12:37 PM
  • Hi,

    try to take these steps :

     

    1.  Browse to SharePoint 4.0 Central Administration, Select Security
    2. In Application Security, select Specify Authentication Providers
    3. Select the Web Application
    4. Click the Default Zone
    5. Check Enable Anonymous (* note that this does not immediately enable Anonymous access; it merely makes the option available on the front-end web application *)

     

     

    I have carried out these steps. But on clicking Save I am presented with an exception. On reloading the page the settings seem to have taken effect. I have then enabled anonymous access at the site level. When opening the site I am still prompted to login?

    The authentication providers button is still greyed out.

    Thanks

    • Edited by Philsando Wednesday, September 08, 2010 3:27 PM
    Wednesday, September 08, 2010 1:08 PM
  • In Central Administration have you first selected one of the Web Applications? You'll need to click on one of the web applications before the option in the ribbon will enable.
    John Ross
    SharePoint Server MVP | Sr. Consultant SharePoint911: SharePoint Consulting
    Blog: http://www.sharepoint911.com/blogs/john
    Twitter: @JohnRossJr

    Professional SharePoint 2010 Branding and User Interface Design

    Yes I selected 'Sharepoint - 80'. I've also tried selecting the central admin.
    Wednesday, September 08, 2010 1:11 PM
  • Hi,

    You have to set the anonymous on the web application itself after you did this in the central admin

    1.       navigate to your top level site collection for the web application. Click the Site Actions > Site Settings. Under Users and Permissions click Site permissions.

    2.       Under Permission Tools, click Anonymous Access icon and set the permissions to Entire Web site and click OK

     


    Wednesday, September 08, 2010 1:42 PM
  • Hi,

    Thanks for the help, I did those steps already.

    Still promting for login to view the site.

     

    • Edited by Philsando Thursday, September 09, 2010 9:26 AM
    Wednesday, September 08, 2010 3:26 PM
  • I have since totally removed sharepoint / the sites / the db's / iis and started from a fresh setup in case I had changed any config while trying to get to the bottom of my problem. Here are the steps I have taken:

    1. Standard install (entered the Internet Sites key).
    2. Setup 1 default publishing site
    3. The authentication providers button is still greyed out.
    4. Tried to open the URL given to me by Paul Stubbs (sharepoint evangelist). For the authentication providers page which returned a 404.
    5. I reverted to the steps given to me by Mina Fouad (4th post from the top of this thread).
    6. On saving I am shown an error. I have tried to set customerrors to off in the 2 web.configs but this has had no effect.
    7. On reloading the page I am shown the settings have taken effect.
    8. I then enabled at the site level by clicking 'enable anonymous access, then clicking 'entire web site'.

    I then open the site url... and am still asked to login.

    Am I missing any steps?

    Do I need to create any groups or roles?

    Do I have to enable anonymous for site collection images,  style library, pages seperately?

    Thanks

     

    • Edited by Philsando Thursday, September 09, 2010 9:04 AM adding clarity to point
    Thursday, September 09, 2010 9:00 AM
  • Hi Phillsando,

    lets try to troubleshoot in some ways

    • check if the site needs access on the physical folder ( try to use process monitor tool to help you in this issue, also give to the IUSER read access on the pysical folder of the IIS)
    • try to disable loopback on the server http://support.microsoft.com/kb/896861

     

    • Marked as answer by Lily Wu Friday, September 17, 2010 6:38 AM
    Thursday, September 09, 2010 8:19 PM