locked
Preciso unir varias planilhas em uma apenas.

    Question

  • Eu tenho um arquivo com 834 planilhas que fazem parte de um relatório.  Preciso copiar o conteudo de cada planilha e colar uma logo abaixo da outra dentro de uma mesma planilha.

    O nome das planilhas são: Table 2,Table 3, Table 4... até Table 835. O conteúdo que preciso copiar está nas seguintes células: A1:N25.

    Eu até começei a copiar manualmente mas vi que tenho uns trinta arquivos atuais e vários outros antigos para corrigir.

    Alguem pode me socorrer?

    Tuesday, February 08, 2011 7:52 PM

All replies

  • Pericles tente assim.. http://www.officevb.com/2010/12/inserindo-dados-de-uma-planilha-em.html Teste e qualquer coisa fale. Att
    Bruno Silva Leite
    officevb.com
    Wednesday, February 09, 2011 1:13 AM
  • Crie uma ABA e em A1 digite:

    =SEERRO(INDIRETO("Table"&INT(LIN()/25,000001)+2&"!"&CARACT(64+COLS($A1:A1))&ARRED(MOD(LIN();25,000001);1));"")

    Arraste até N1; depois arraste a linha 1 (A1:N1) até a linha 20850.

    Depois de rodar (demora) copie e cole como valor onde vc necessitar... Evita o recálculo toda hora.

    Abs,


    Obs.: Estou assumindo que vc quer trazer os 14X25 registros de cada table. Se o número de linhas de cada table for variávl tem que ser outra solução.
    Wednesday, February 09, 2011 5:43 AM