none
Sharepoint 2013 Problem - User Personal site never created. Clicking Skydrive/Newsfeed/or Follow

    Question

  • New 2013 setup.  I created 1 test site.   I'm able to load the site, but If the user clicks on 'Follow', 'Skydrive', or 'Newsfeeds', the user is taken to the personal page that reads:

    We're almost ready!

    While we set things up, feel free to changeyour photo, adjustyour personal settings, and fill ininformation about yourself.
    It could take us a while, but once we're done, here's what you'll get:
    Newsfeedis your social hub where you'll see updates from the people, documents, sites, and tags you're following, with quick access to the apps you've added.
    SkyDrive Prois your personal hard drive in the cloud, the place you can store, share, and sync your work files.

    Sitesgives you easy access to the places you'll want to go.

    There seems to be some sort of user init that never completes. 

    In the log files taken from "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions" I found the following related to an attempt 

    12/05/2012 16:02:26.55     w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          User Profiles                     ajxt4    Unexpected    Microsoft.Office.Server.Social.SPSocialFeedManager.GetFeedFor: Microsoft.Office.Server.Microfeed.MicrofeedException: WarningPersonalSiteNotFoundCanCreateError :  : Correlation ID:d4f0e79b-2e8c-9054-08c5-674e84005449 : Date and Time : 12/5/2012 1:02:26 PM     at Microsoft.Office.Server.Microfeed.SPMicrofeedManager.CommonPubFeedGetter(SPMicrofeedRetrievalOptions feedOptions, MicrofeedPublishedFeedType feedType, Boolean publicView)     at Microsoft.Office.Server.Microfeed.SPMicrofeedManager.GetPublishedFeed(String feedOwner, SPMicrofeedRetrievalOptions feedOptions, MicrofeedPublishedFeedType typeOfPubFeed)     at Microsoft.Office.Server.Social.SPSocialFeedManager.Microsoft.Office.Server.Social.ISocialFeedManagerProxy.ProxyGetFeedFor(String actorId, SPSocialFeedOptions options)     at Microsof...    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.55*    w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          User Profiles                     ajxt4    Unexpected    ...t.Office.Server.Social.SPSocialFeedManager.<>c__DisplayClass4b`1.<S2SInvoke>b__4a()     at Microsoft.Office.Server.Social.SPSocialUtil.InvokeWithExceptionTranslation[T](ISocialOperationManager target, String name, Func`1 func)    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.55     w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          User Profiles                     ajxt4    Unexpected    Microsoft.Office.Server.Social.SPSocialFeedManager.GetFeedFor: Microsoft.Office.Server.Social.SPSocialException: No personal site exists for the current user, and a previous attempt to create one failed. Internal type name: Microsoft.Office.Server.Microfeed.MicrofeedException. Internal error code: 80.     at Microsoft.Office.Server.Social.SPSocialUtil.TryTranslateExceptionAndThrow(Exception exception)     at Microsoft.Office.Server.Social.SPSocialUtil.InvokeWithExceptionTranslation[T](ISocialOperationManager target, String name, Func`1 func)     at Microsoft.Office.Server.Social.SPSocialFeedManager.<>c__DisplayClass48`1.<S2SInvoke>b__47()     at Microsoft.Office.Server.Social.SPSocialUtil.InvokeWithExceptionTranslation[T](ISocialOperationManager target, String name, Func`1 func)    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.55     w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          User Profiles                     ajxt4    Unexpected    Microsoft.Office.Server.Social.SPSocialFeedManager.GetFeedFor: Microsoft.Office.Server.Social.SPSocialException: No personal site exists for the current user, and a previous attempt to create one failed. Internal type name: Microsoft.Office.Server.Microfeed.MicrofeedException. Internal error code: 80.     at Microsoft.Office.Server.Social.SPSocialUtil.TryTranslateExceptionAndThrow(Exception exception)     at Microsoft.Office.Server.Social.SPSocialUtil.InvokeWithExceptionTranslation[T](ISocialOperationManager target, String name, Func`1 func)     at Microsoft.Office.Server.Social.SPSocialFeedManager.<>c__DisplayClass48`1.<S2SInvoke>b__47()     at Microsoft.Office.Server.Social.SPSocialUtil.InvokeWithExceptionTranslation[T](ISocialOperationManager target, String name, Func`1 func)     at Mic...    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.55*    w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          User Profiles                     ajxt4    Unexpected    ...rosoft.Office.Server.Social.SPSocialFeedManager.<>c__DisplayClass2f.<GetFeedFor>b__2d()     at Microsoft.Office.Server.Social.SPSocialUtil.InvokeWithExceptionTranslation[T](ISocialOperationManager target, String name, Func`1 func)    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.57     w3wp.exe (0x1AB0)                           0x2324    SharePoint Foundation             Monitoring                        nasq    Medium      Entering monitored scope (Render Ribbon.). Parent SharePointForm Control Render    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.58     w3wp.exe (0x1AB0)                           0x2324    SharePoint Foundation             Monitoring                        b4ly    Medium      Leaving Monitored Scope (Render Ribbon.). Execution Time=3.16897818018771    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.58     w3wp.exe (0x1AB0)                           0x2324    SharePoint Server Search          Query                             dn4s    High        FetchDataFromURL start at(outside if): 1 param: start    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.58     w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          User Profiles                     aiokq    High        User profile property 'EduUserRole' not found from from MySitePersonalSiteUpgradeOnNavigationWebPart::GetUserRoleFromProfile(). This should indicate that the current user is not an edudation user. [SPWeb Url=http://share2/my/Person.aspx?accountname=mycompany\username]    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.58     w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          Personal Site Instantiation       af1lc    High        Skipping creation of personal site from MySitePersonalSiteUpgradeOnNavigationWebPart::CreatePersonalSite() because one or more of the creation criteria has not been met. [SPWeb Url=http://share2/my/Person.aspx?accountname=mycompany\username]  http://share2/my/Person.aspx?accountname=mycompany\username]Self-Service Site Creation == False  Can Create Personal Site == True  Is user licensed == True  Storage&Social UPA Permission == True  Site or Page or Web Part is in design mode == False      d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:26.59     w3wp.exe (0x1AB0)                           0x2324    SharePoint Foundation             Monitoring                        b4ly    Medium      Leaving Monitored Scope (Request (GET:http://share2:80/my/Person.aspx?accountname=mycompany%5Cusername&AjaxDelta=1)). Execution Time=94.5348500996635    d4f0e79b-2e8c-9054-08c5-674e84005449
    12/05/2012 16:02:27.17     w3wp.exe (0x1AB0)                           0x23A0    SharePoint Foundation             Monitoring                        nasq    Medium      Entering monitored scope (Request (POST:http://share2:80/my/_vti_bin/client.svc/ProcessQuery)). Parent No    
    12/05/2012 16:02:27.17     w3wp.exe (0x1AB0)                           0x23A0    SharePoint Foundation             Logging Correlation Data          xmnv    Medium      Name=Request (POST:http://share2:80/my/_vti_bin/client.svc/ProcessQuery)    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.17     w3wp.exe (0x1AB0)                           0x23A0    SharePoint Foundation             Authentication Authorization      agb9s    Medium      Non-OAuth request. IsAuthenticated=True, UserIdentityName=0#.w|mycompany\username, ClaimsCount=57    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.17     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Foundation             CSOM                              agw10    Medium      Begin CSOM Request ManagedThreadId=54, NativeThreadId=2504    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.18     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Foundation             Logging Correlation Data          xmnv    Medium      Site=/my    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.18     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          Microfeeds                        aizmk    High        serviceHost_RequestExecuting    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.20     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          User Profiles                     ajk39    Medium      UserProfileDBCache_WCFLogging::Begin ProfileDBCacheServiceClient.GetUserData.ExecuteOnChannel    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.20     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          User Profiles                     ajk35    Medium      MossClientBase_WCFLogging::Begin MossClientBase.ExecuteOnChannel    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.20     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          User Profiles                     ajk36    Medium      MossClientBase_WCFLogging:: MossClientBase.ExecuteOnChannel -  Executing codeblock on channel    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.21     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Foundation             Topology                          e5mc    Medium      WcfSendRequest: RemoteAddress: 'http://share2:32843/1c9a1642f4d9456c94ae0dbbd9b25a41/ProfileDBCacheService.svc' Channel: 'Microsoft.Office.Server.UserProfiles.IProfileDBCacheService' Action: 'http://Microsoft.Office.Server.UserProfiles/GetUserData' MessageId: 'urn:uuid:24af6007-0615-428e-ad0a-1265f47f0b33'    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.22     w3wp.exe (0x1B78)                           0x1BA0    SharePoint Foundation             Monitoring                        nasq    Medium      Entering monitored scope (ExecuteWcfServerOperation). Parent No    
    12/05/2012 16:02:27.22     w3wp.exe (0x1B78)                           0x1BA0    SharePoint Foundation             Topology                          e5mb    Medium      WcfReceiveRequest: LocalAddress: 'http://share2.mycompany.com:32843/1c9a1642f4d9456c94ae0dbbd9b25a41/ProfileDBCacheService.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://Microsoft.Office.Server.UserProfiles/GetUserData' MessageId: 'urn:uuid:24af6007-0615-428e-ad0a-1265f47f0b33'    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.22     w3wp.exe (0x1B78)                           0x1BA0    SharePoint Foundation             Monitoring                        b4ly    Medium      Leaving Monitored Scope (ExecuteWcfServerOperation). Execution Time=0.647079447248184    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.22     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          User Profiles                     ajk37    Medium      MossClientBase_WCFLogging:: MossClientBase.ExecuteOnChannel -  Executed codeblock on channel    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.22     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          User Profiles                     ajk4a    Medium      UserProfileDBCache_WCFLogging::End ProfileDBCacheServiceClient.GetUserData.ExecuteOnChannel    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.22     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          User Profiles                     ajp2i    Medium      GetMySiteLinks: user has a profile but no personal site; not returning personal site links    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.23     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Portal Server          Microfeeds                        aizmj    High        serviceHost_RequestExecuted    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.23     w3wp.exe (0x1AB0)                           0x09C8    SharePoint Foundation             CSOM                              agw11    Medium      End CSOM Request. Duration=53 milliseconds.    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.23     w3wp.exe (0x1AB0)                           0x1604    SharePoint Foundation             Monitoring                        b4ly    Medium      Leaving Monitored Scope (Request (POST:http://share2:80/my/_vti_bin/client.svc/ProcessQuery)). Execution Time=62.5798809625246    d4f0e79b-3eb6-9054-08c5-61e70b316688
    12/05/2012 16:02:27.44     w3wp.exe (0x1B78)                           0x1178    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformOngoingRequestDepartures    6b6b4445-152d-0002-8ef6-85991723bb2d
    12/05/2012 16:02:27.51     w3wp.exe (0x1B78)                           0x1934    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: Disk Manager.PerformCleanup    11c5f189-7512-0002-bee0-df766138e919
    12/05/2012 16:02:27.51     w3wp.exe (0x1B78)                           0x1934    Excel Services Application        Excel Calculation Services        8jg2    Medium      ResourceManager.PerformCleanup: Disk Manager: CurrentSize=57369.    11c5f189-7512-0002-bee0-df766138e919
    12/05/2012 16:02:28.45     w3wp.exe (0x1B78)                           0x1178    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformOngoingRequestDepartures    6b6b4445-152d-0002-8ef6-85991723bb2d
    12/05/2012 16:02:28.92     w3wp.exe (0x1B78)                           0x18C8    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformSessionTimeouts    8854a25e-6740-0002-b513-28f8778da25e
    12/05/2012 16:02:28.92     w3wp.exe (0x1B78)                           0x23E0    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: Memory Manager.PerformCleanup    53fed7f1-2e29-0002-a910-5150db6281e2
    12/05/2012 16:02:28.92     w3wp.exe (0x1B78)                           0x23E0    Excel Services Application        Excel Calculation Services        8jg2    Medium      ResourceManager.PerformCleanup: Memory Manager: CurrentSize=730533888.    53fed7f1-2e29-0002-a910-5150db6281e2
    12/05/2012 16:02:29.40     w3wp.exe (0x1B78)                           0x19B4    SharePoint Portal Server          User Profiles                     ahqt1    Medium      UserProfileDBCache.GetChangedDBItemsPrimaryKeys: m_AllPropertyIDs = 1;3;9;2;5009;7;23;13;14;22;5065;5061;5062;5040;5042;5091;5092;5093;    19a3e79b-2ee3-9054-08c5-6a281115d989
    12/05/2012 16:02:29.45     w3wp.exe (0x1B78)                           0x1178    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformOngoingRequestDepartures    6b6b4445-152d-0002-8ef6-85991723bb2d
    12/05/2012 16:02:29.54     OWSTIMER.EXE (0x26C4)                       0x1964    SharePoint Foundation             Monitoring                        aeh57    Medium      Sql Ring buffer status eventsPerSec = 0,processingTime=0,totalEventsProcessed=0,eventCount=0,droppedCount=0,memoryUsed=0    
    12/05/2012 16:02:30.10     w3wp.exe (0x1B78)                           0x0FAC    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: HealthPerfCounter    633d7a5d-1310-0002-8342-391ed51888b4
    12/05/2012 16:02:30.45     w3wp.exe (0x1B78)                           0x1178    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformOngoingRequestDepartures    6b6b4445-152d-0002-8ef6-85991723bb2d
    12/05/2012 16:02:30.61     w3wp.exe (0x1B78)                           0x19A4    SharePoint Server Search          Query                             ac3iq    High        Ims::EndPoints: old: net.tcp://share2/C5A0AC/QueryProcessingComponent1/ImsQueryInternal;, new: net.tcp://share2/C5A0AC/QueryProcessingComponent1/ImsQueryInternal;    19a3e79b-2ee3-9054-08c5-6a281115d989
    12/05/2012 16:02:30.67     w3wp.exe (0x1B78)                           0x1EE4    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: RequestManager.RequestTimeoutCleanup    5baea2ed-01b0-0002-9183-bc6ae11d23eb
    12/05/2012 16:02:30.67     w3wp.exe (0x1B78)                           0x1EE4    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: ExcelServerThreadPool.QueueConsiderate    5baea2ed-01b0-0002-9183-bc6ae11d23eb
    12/05/2012 16:02:30.67     w3wp.exe (0x1B78)                           0x1EE4    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformAutoSave    5baea2ed-01b0-0002-9183-bc6ae11d23eb
    12/05/2012 16:02:31.45     w3wp.exe (0x1B78)                           0x1178    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformOngoingRequestDepartures    6b6b4445-152d-0002-8ef6-85991723bb2d
    12/05/2012 16:02:32.45     w3wp.exe (0x1B78)                           0x1178    SharePoint Server                 Logging Correlation Data          xmnv    Medium      Name=Task: SessionManager.PerformOngoingRequestDepartures    6b6b4445-152d-0002-8ef6-85991723bb2d
    12/05/2012 16:02:32.65     OWSTIMER.EXE (0x26C4)                       0x197C    SharePoint Foundation             Monitoring                        nasq    Medium      Entering monitored scope (Timer Job EducationBulkOperationJob). Parent No    9d183f64-33f3-4bb8-83b3-f401e3150f7e

    Any thoughts on this?   troubleshooting tips? 

    Wednesday, December 05, 2012 9:30 PM

All replies

  • Hi,

    Please make sure that you

    • configured My site url correctly in user profile service application
    • Created a wild card managed path for My sites
    • Given a permission to user to create self-service site on your my-site web application.

    -Amol Meshe

    Thursday, December 06, 2012 9:46 AM
  • Is your Distributed Cache Service running?  You should check that it shows as running in CA and that it is running in the Service applet.  The micro feed requires DCS in order to fully work properly.

    Chris Givens CEO, Architecting Connected Systems Blog Twitter

    Sunday, December 09, 2012 10:00 PM
  • Having the same issue.  I have mainly followed this guide: http://blog.sharedove.com/adisjugo/index.php/2012/07/25/visual-guide-setting-up-my-sites-in-sharepoint-2013/

    Checked all these:

    • configured My site url correctly in user profile service application
    • Created a wild card managed path for My sites
    • Given a permission to user to create self-service site on your my-site web application.

    ..and DistributedCache IS running.

    Still i have the same problem. The "Newsfeed", "SkyDrive", "Sites" and "Follow" links all bring me to the "About 'you'"-page.

    Has anyone been able to resolve this?

    Wednesday, April 17, 2013 12:28 PM
  • You need to create your MySite site collection by clicking on "Sites".  This is default behavior.  Once you create your MySite Site Collection you will be able to get to the rest of "MySites" 

    (Give it a few minutes to create the site in the background)

    Disregard, I just read the log after posting, sorry.  Have you customized any of the aspx pages for MySites?  Self-Service site creation is on?


    Hope This Helps!




    Wednesday, April 17, 2013 12:40 PM
  • I've been fighting this for the last 3 weeks.  I have gone to exteme measures and I still have the same problem.  I'd love to know how to make this work.

    Wednesday, April 17, 2013 5:29 PM
  • Only thing i have customized with the MySite is adding the Newsfeed app. That's what's showing the "Almost ready". I have set up a MySite collection like all the guides i have found show. All the guides have basicly the same steps, so I'm guessing there is something wrong with my SharePoint configuration that is not configured in those guides. Self-Service site creation is on, and users have permission to create subsites and use the self-service site creation on the web-app. Managed-paths is configured. And the Setup MySite under User Profile Service Application is configured aswell.

    User Profile Syncronization is not working, this is however not a requirement for MySites to work if I am not mistaking(?)

    There are two SharePoint servers in the farm. One for CA and one for the other Web App I am using.

    Thursday, April 18, 2013 8:01 AM
  • Doing this as part of my bachelors thesis. It is due in about a month. Really hope i can get this to work soon.
    Thursday, April 18, 2013 8:03 AM
  • I've been fighting this for the last 3 weeks.  I have gone to exteme measures and I still have the same problem.  I'd love to know how to make this work.


    I've got a ticket opened with Microsoft at this time.
    Thursday, April 18, 2013 1:07 PM
  • Any progress?
    Monday, April 22, 2013 10:47 AM
  • Any progress?

    Not Yet.  I've spent three days on the phone with high-level support and so far no dice.  We've essentially redone the environment all over.  I've got another marathon phone session with them today.
    Monday, April 22, 2013 1:26 PM
  • MArk

    How did you get on with support? I am investigating this exact problem my self and would love to know if you made progress.

    Regards

    Ben

    Wednesday, April 24, 2013 2:18 PM
  • MArk

    How did you get on with support? I am investigating this exact problem my self and would love to know if you made progress.

    Regards

    Ben

    Still working on it with them. There is no clear path to resolution at this time. 
    Wednesday, April 24, 2013 3:29 PM
  • Mark

    Out of curiosity... If you run Internet Explorer as your Farm Service account does the MySite page work correctly?

    Mine does, so this leads me to believe it’s now a permissions issue within the system. Just got to find where.

    Let me know your findings.

    Thanks

    Ben

    Thursday, April 25, 2013 5:17 PM
  • i am facing the same issue.

    ULS has

    EnsureMySiteUrl: PersonalSiteUrl of page        is null!

    any ideas

    Friday, April 26, 2013 10:07 AM
  • So, I've had a breakthrough finally with one of the MS Support people.  MySites has worked now for 10 minutes and so far it looks like this is fixed.  Exhaustive testing will commence.

    Here is what the problem was for me.  I'd like to know if this helps others.

    Open Central Admin Website

    Go To "Application Management" select "Manage Web Applications"

    Highlight the Web Application that hosts your MySites.

    Select "Self-Service Site Creation" from the ribbon.

    Under "Start a Site" select the top choice of "be hidden from users"

    It began working immediately. 

    Mark Ringo

    • Proposed as answer by TSI Group Thursday, May 02, 2013 4:00 PM
    Thursday, May 02, 2013 3:59 PM
  • So, unfortunately this didn't end up resolving the issue.  It worked great for a while then failed again, continuously.  Nothing that I could do would revive MySites.  I continue to have the ticket open with Microsoft for MySites problems but am discouraged as their senior people don't see anything wrong with the configuration yet it still doesn't work.

    I'll keep you posted.

    Mark Ringo

    Sunday, May 05, 2013 2:24 PM
  • I seem to be having the exact same problem. I hope you find resolution soon!
    Tuesday, May 07, 2013 12:37 AM
  • Still working on it but making progress very slowly.  I wonder if there is something else common to our environments that is contributing to this.

    Here's my basic setup

    SQL 2008R2 Enterprise, fully updated

    Windows Server 2012 Standard, Fully Updated

    SharePoint 2013 Enterprise, Fully updated with ALL of the latest updates March and April 2013 included

    Symantec Endpoint Protection 12.1.2

    Running as a VM on Hyper-V on a Server 2012 Datacenter edition server

    Dynamic Memory up to 32GB of RAM

    Multiple SSL certificates and bindings to limited IP address using "Server Name Indication" or SNI

    In addition, I am running the latest version of MetaLogix StoragePoint 4.1 for SharePoint 2013

    Mark Ringo

    Tuesday, May 07, 2013 1:02 AM
  • Hello Everyone.

    Please go through below link

    http://www.c-sharpcorner.com/UploadFile/Roji.Joy/how-to-configure-sharepoint-2013-my-site/


    Rajesh Kumar "Changing the Face" can change nothing.But "Facing the Change" can change everything.

    Tuesday, May 07, 2013 9:06 AM
  • Any word on this yet? I'm having the same issue.
    Monday, June 03, 2013 7:51 PM
  • Hi, we also have the same problem. Any news?
    Friday, June 07, 2013 8:25 PM
  • This is resolved for us. After several hours of troubleshoot it turned out to be something I missed. If you navigate to Manage User Profile Service, in the people section select Manage User Permissions. Make sure the permissions are set correctly.

    Monday, June 10, 2013 12:06 PM
  • I have checked all these things and still get the same results ... no personal site created.  Everything seems to be configured correctly.  Any other ideas?

    Tuesday, June 11, 2013 3:36 PM
  • Hello

    Something that worked for us after struggling all day long (check the whole article here: http://technet.microsoft.com/en-us/library/ee624362.aspx)

    1. In the Policy group, click Permission Policy.

    2. On Manage Permission Policy Levels dialog box, click Add Permission Policy Level.

    3. Type a name for the permission policy.

    4. Under Permissions, in Site Permissions, select the Grant option for Create Subsites - Create subsites such as team sites, Meeting Workspace sites, and Document Workspace sites.

    5. Click Save.


    Wednesday, June 12, 2013 4:52 PM
  • Hi

    I am  getting “We’re almost Ready” message for any of the navigation links like Newsfeed, SkyDrive etc. in My Site.

    When I reviewed the application event log we found below error for SharePoint Portal Server.

    Error : My Site creation failure for user 'DomainName\UserName' for site url

    'https://ServerName/my/personal/UserName'. The exception was:

    Microsoft.Office.Server.UserProfiles.PersonalSiteNamingConflictException: Username conflicts with another user..

    I have followed all the necessary steps for my site configuration as discussed above and per below url:

    http://blog.sharedove.com/adisjugo/index.php/2012/07/25/visual-guide-setting-up-my-sites-in-sharepoint-2013/

    Still getting the same issue "We’re almost Ready" and On sever we  have installed April CU 2013 updates.

    Is this issue related to April CU 2013 Updates for SharePoint 2013 ? Beacuse in my local VM I have successfully

    configured my Site without any issue and in my VM no Cumulative updates of SharePoint 2013.

    Any Ideas ?

     

    Regards

    Akhil

    • Proposed as answer by DanTheManXX Monday, September 30, 2013 3:31 PM
    • Unproposed as answer by DanTheManXX Monday, September 30, 2013 3:32 PM
    Thursday, June 20, 2013 12:42 PM
  • H

    Major  Minor  Build  Revision
    -----  -----  -----  --------
    15     0      4505   1005   I am using the April build version and guess what I have the exact same issue. i
    Monday, September 30, 2013 3:35 PM
  • H

    Major  Minor  Build  Revision
    -----  -----  -----  --------
    15     0      4505   1005   I am using the April build version and guess what I have the exact same issue. i
    Has anyone raised this issue with Microsoft
    Monday, September 30, 2013 3:41 PM
  • Please forget applying June or August CU for this issue unless you intend to this anyway. I think the April CU may have made the lic level stricter. Anyway the issue when you inspect the USL log is

    Skipping creation of personal site from MySitePersonalSiteUpgradeOnNavigationWebPart::CreatePersonalSite() because one or more of the creation criteria has not been met. [SPWeb Url=http://my.doamin.com/Person.aspx?accountname=WSLDEV\Danielw]  http://mydomain.com/Person.aspx?accountname=WSLDEV\Danielw]Self-Service Site Creation == True  Can Create Personal Site == False  Is user licensed == False  Storage&Social UPA Permission == True  Site or Page or Web Part is in design mode == False

    Add to ent lic to security group and then all is well

    http://technet.microsoft.com/en-us/library/jj219627.aspx

     
    Wednesday, October 02, 2013 12:40 PM
  • Hi,

    This is problem with managed paths :

    "Setup My Sites" is:

    My Site Host: http://SHAREPOINTSERVER:80/sites/my/

    Personal Site Location: personal

    And in Managed Paths:

    managed paths

    and that is all, change managed path for your setting. 

    I hope I helped.

    Sunday, November 03, 2013 3:07 PM
  • In my case, here is what happened and how I fixed it.

    Situation:

    Mysite is a new web application. We have two one-way trusts in place since the domain of the farm is different than the two other domains where users reside. So I ran the 

    STSADM.exe -o setproperty -pn peoplepicker-searchadforests -pv "Forest1,Domain1\account,password; Forest2,Domain2\account,password" -url https://mysitesURL

    This allowed the user policy of the new Mysites web application to search through the two domains where AD users reside. Once I added them I was good, no more errors. 

    One thing to note, I have two web apps using the same wildcard cert and running off port 443 SSL. 

    I wanted to make the user picture come from AD so I changed that user property (Picture) in User Profile Service options, and this seems to have broken initial MySite creation, but once the user adds a picture to their profile settings, the site starts working. I need to remove the property I added for "Picture" in user profile properties.

    This is the process I took that caused my problem:

    http://richardstk.wordpress.com/2013/04/12/import-user-photos-from-active-directory-into-sharepoint-2013/

    Tuesday, November 05, 2013 8:43 PM
  • Hello

    Something that worked for us after struggling all day long (check the whole article here: http://technet.microsoft.com/en-us/library/ee624362.aspx)

    1. In the Policy group, click Permission Policy.

    2. On Manage Permission Policy Levels dialog box, click Add Permission Policy Level.

    3. Type a name for the permission policy.

    4. Under Permissions, in Site Permissions, select the Grant option for Create Subsites - Create subsites such as team sites, Meeting Workspace sites, and Document Workspace sites.

    5. Click Save.


    But don't add any more rights here than the minimum (create subsites, view pages, browse user information and open); I added some I thought would be necessary and ended up with failing mysite creation - once I removed those it worked again.
    Monday, December 30, 2013 9:16 AM
  • Did anybody happen to have found another solution that worked? I've been trying to solve this for days, tried all the things I've seen here, searched everywhere I could, no luck. It's so annoying that I'm almost giving up.

    Friday, January 03, 2014 6:26 PM
  • Tatiane

    I have looked through this thread and all the contributors ( including me ) have covered all the things you need to resolve this .  The ULS log is the thing you will need to look through for clues..  Look for an entry similar to this. 

    user. [SPWeb Url=http://share2/my/Person.aspx?accountname=mycompany\username]    d4f0e79b-2e8c-9054-08c5-674e84005449
     12/05/2012 16:02:26.58     w3wp.exe (0x1AB0)                           0x2324    SharePoint Portal Server          Personal Site Instantiation       af1lc    High        Skipping creation of personal site from MySitePersonalSiteUpgradeOnNavigationWebPart::CreatePersonalSite() because one or more of the creation criteria has not been met. [SPWeb Url=http://share2/my/Person.aspx?accountname=mycompany\username]  http://share2/my/Person.aspx?accountname=mycompany\username]Self-Service Site Creation == False  Can Create Personal Site == True  Is user licensed == True  Storage&Social UPA Permission == True  Site or Page or Web Part is in design mode == False      d4f0e79b-2e8c-9054-08c5-674e84005449

    Check to see you haven't accidentally turned on user license management  I did this once and my Enterprise install became Foundation level ( so not Enterprise or Standard as shown below).... not good.

    Don't let SharePoint grind you down!

    Daniel

    Friday, January 03, 2014 8:13 PM