none
SERIOUS ISSUES - CAN ANYONE GUIDE ME PLEASE??? USER PROFILE RELATED

    Question

  • Last night the AD team moved 120 users from one OU to another OU. I did not know about the change. No biggie. So I reconfigured the AD connection and made sure those users are added back in.

    I ran full sync and full crawl. Those people are now showing up. so that a good news. BUT everyone is having a COW about not showing their picture. I have no idea why for these users picture links to http://home.intranet.com/_layouts/images/o14_person_placeholder_96.png instead of referencing to same location. I ran following powershell script to see if its gonna get fixed. But none of them did the trick. I AM UNDER SUPER PRESSURE FROM UPPER UPPER MANAGEMENT. Can anyone please guide me to right direction?

    powershell 1 that i ran:

    Update-SPProfilePhotoStore –MySiteHostLocation http://mysite.intranet.com:7400

    I verified that all the pictures are still here

    http://mysite.intranet.com:7400/User%20Photos/Forms/AllItems.aspx

    Thursday, October 31, 2013 1:10 AM

All replies

  • Does a picture appear attached to their user profile in Manage User Profiles?  Where are the pictures sourced from (e.g. AD)?

    Trevor Seward, MCC

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, October 31, 2013 1:21 AM
  • No sir. 

    I get following errors when I ran the above code

    Update-SPProfilePhotoStore : Error processing the photo URL 
    http://mysite.intranet.com:7400/personalsites/User Photos/Profile Pictures/contoso_mmcmarsh.jpg for  user contoso\mmcmarsh: The file http://mysite.intranet.com:7400/personalsites/User Photos/Profile Pictures/contoso_mmcmarsh.jpg does not exist.

    I few days ago I made a change in the mysite config in Central Admin thru user profile (http://centraladmin:20000/_layouts/PersonalSites.aspx?ApplicationID=xxxxxx). I took out the personalsites from the my site host location.

    This is old link http://mysite.intranet.com:7400/personalsites/User Photos/Profile Pictures/contoso_mmcmarsh.jpg

    new link is http://mysite.intranet.com:7400/User Photos/Profile Pictures/contoso_mmcmarsh.jpg

    Thursday, October 31, 2013 1:35 AM
  • I confirmed that user pictures exists in the user photo library. for example, i right click on the of user that got migrated to another OU in AD 

    http://mysite.intranet.com:7400/User%20Photos/_t/mci_mgordon_jpg.jpg

    Thursday, October 31, 2013 1:55 AM