none
The form cannot be opened because it requires the domain permission level. Log ID 5566 Error.

    Question

  • Hi,

    I have InfoPath form with SharePoint list data connection, which dynamically pulls data from a list, for a dropdown. As you know, InfoPath has issue with alphabetizing the values in its controls. So, I changed the data connection to a dynamic XML, like this one.

    "http://portal/_vti_bin/owssvr.dll?Cmd=Display&List={ListGuid}&View={ViewGuid}&XMLDATA=TRUE&SortField=Names&SortDir=Asc"

    It works fine when I run it in Preview. But, when I publish it and try to open from the browser, I get "An error occurred accessing a data source." error, with Log ID 5566. I know it is a general error, so I tried to force it open with InfoPath, and I got this more detailed error:

    "The form cannot be opened because it requires the domain permission level and it currently has restricted permission. To fix this problem, open the form from the location it was published to. Forms that require the domain permission level contain features that access information on a network, such as data connections, linked images, and code."

    I tried to publish it as admin-approved form with full-trust and self-signed certificate (I know self-signed certificate works for me, as I have other admin-approved forms using it), and without luck! It opens the form with 5566 error with empty dropdown where this data connection is bound to. I know there is nothing wrong with library permissions, as I was using SharePoint list data connection, which is pulling values fine. And, I'm using admin account too. I tried several solutions in the net, but nothing worked(maybe I'm not doing it right way).

    I know there is something tricky I'm missing here, but I'm lost. I can't figure out myself and need some help. I would appreciate much if someone could give me some idea.

    Thank you!


    Regards, R.D.M.
    Monday, October 26, 2009 3:17 PM

All replies

  • Your form needs full trust permission level only if you are using code behind. In all other cases unsigned domain permission level form is just what you want.


    http://alecpojidaev.wordpress.com
    Monday, October 26, 2009 3:50 PM
  • Hi,

    5566 mostly appear when you have permission issues with your data source, i would strongly recommend you to have a look at the permissions to execute owssvr.dll  from the user you are trying to connect to,  what authentication provider you have configured your MOSS with  ?



    Ashraf ul Islam
    Sharepoint Consultant
    Monday, October 26, 2009 4:25 PM
  • Alec, thanks for your reply.

    Yes, I don't use managed code and that is why I don't make it full trust. It is set to Domain.
    Regards, R.D.M.
    Monday, October 26, 2009 6:08 PM
  • Ashraf, thanks for your advice.

    I have Windows type, NTLM security for authentication provider. I feel like you are right about permission on owssvr.dll, because SharePoint list DC works fine for the library. But I have no idea how to check permission on this file. Do you mean I should check permissions on the file itself? BTW, I use admin account when I open the form.


    Regards, R.D.M.
    Monday, October 26, 2009 6:13 PM
  • In Manage Data connections dialog try to convert your data source. It will be stored as udx file in a data access library. On administration site mark that data library as trusted place.
    http://alecpojidaev.wordpress.com
    Monday, October 26, 2009 6:23 PM
  • I'm not familiar with creating UDCX, UDX file, so I will be more detailed here, please let me know if I'm not doing it in right way.

    I didn't have a Data Connection Library, so I created one. I converted my XML DC to UDCX file and saved in that library. In the CentralAdmin site I added the library to trusted locations. Now, when I double click my DC in Manage Data Connections, I have different flow in Data Connection Wizard. It shows my DC as blue (I think it is selected by default) and there is 'Manage Sites...' button, which is disabled and there is 'Connection Options' button, where I can choose Local data connection library or Centrally managed connection library (first one is selected and I don't change it). Other settings, after clicking Next, remain the same.

    Now, when I open the form in Preview, I get this warning. But it opens the form and dropdown displays values in alphabetical order.

    "One or more data connections in your form are specified with a server-relative link, but no publish location has been defined for the form. ..." (I didn't type whole message, hoping that you are familiar with it.)

    And, when I publish the form, I get the same Log ID 5566 error and no values in dropdown, as before.

    Am I doing anything wrong?



    Regards, R.D.M.
    Monday, October 26, 2009 7:28 PM
  • I always using Centrally managed connection library. It's the place easily accessed by Form Services.
    http://alecpojidaev.wordpress.com
    Monday, October 26, 2009 7:38 PM
  • Well, I made it Centrally managed connection library. When I published the form, it gave me only option to publish it through admin-approved way. So, I publsihed it that way. Also, I uploaded the UDCX file to Manage data connection files under InfoPath Form Services in CentralAdmin site. No luck! I still have the same error :(


    Regards, R.D.M.
    Monday, October 26, 2009 7:59 PM
  • Could you please post your resulting udcx? I have no problem to connect to owssvr with .udcx. The only difference is I'm reusing preexisting files created by Sharepoint Designer not by InfoPath. To create one in SD go to Data Source Library -> Server Side Scripts.

    Here is mine:


    <?xml version="1.0" encoding="UTF-8"?>
    <?MicrosoftWindowsSharePointServices ContentTypeID="0x010100B4CBD48E029A4ad8B62CB0E41868F2B0"?>
    <udc:DataSource MajorVersion="2" MinorVersion="0" xmlns:udc="http://schemas.microsoft.com/office/infopath/2006/udc">
    	<udc:Name>owssvr</udc:Name>
    	<udc:Description>Format: UDC V2; Connection Type: XmlQuery; Purpose: ReadOnly; Generated by Microsoft Office InfoPath 2007 on 2009-03-10 at 17:02:55 by DW\PojidaevAB.</udc:Description>
    	<udc:Type MajorVersion="2" MinorVersion="0" Type="XmlQuery">
    		<udc:SubType MajorVersion="0" MinorVersion="0" Type=""/>
    	</udc:Type>
    	<udc:ConnectionInfo Purpose="ReadOnly" AltDataSource="">
    		<udc:WsdlUrl/>
    		<udc:SelectCommand>
    			<udc:ListId/>
    			<udc:WebUrl/>
    			<udc:ConnectionString/>
    			<udc:ServiceUrl UseFormsServiceProxy="false"/>
    			<udc:SoapAction/>
    			<udc:Query>http://myServer/_vti_bin/owssvr.dll?Cmd=Display&amp;List={5B8F5886-FE3A-4008-86AE-4615E1264F47}&amp;FilterField1=Announcement_x0020_Type&amp;FilterValue1=Audit%20Request&amp;XMLDATA=TRUE</udc:Query>
    		</udc:SelectCommand>
    		<udc:UpdateCommand>
    			<udc:ServiceUrl UseFormsServiceProxy="false"/>
    			<udc:SoapAction/>
    			<udc:Submit/>
    			<udc:FileName>Specify a filename or formula</udc:FileName>
    			<udc:FolderName AllowOverwrite=""/>
    		</udc:UpdateCommand>
    		<!--udc:Authentication><udc:SSO AppId='' CredentialType='' /></udc:Authentication-->
    	</udc:ConnectionInfo>
    </udc:DataSource>
    

    http://alecpojidaev.wordpress.com
    Monday, October 26, 2009 9:12 PM
  • My UDCX looks the same. The only difference I see is that I use List View to pull data, and you use Filter.

    **************
    <?xml version="1.0" encoding="UTF-8"?>
    <?MicrosoftWindowsSharePointServices ContentTypeID="XXXXXXXXXX"?>
    <udc:DataSource MajorVersion="2" MinorVersion="0" xmlns:udc="http://schemas.microsoft.com/office/infopath/2006/udc">
     <udc:Name>owssvr</udc:Name>
     <udc:Description> Format: UDC V2; Connection Type: XmlQuery; Purpose: ReadOnly; Generated by Microsoft Office InfoPath 2007 by DOMAIN\ACCOUNT.</udc:Description>
     <udc:Type MajorVersion="2" MinorVersion="0" Type="XmlQuery">
      <udc:SubType MajorVersion="0" MinorVersion="0" Type=""/>
     </udc:Type>
     <udc:ConnectionInfo Purpose="ReadOnly" AltDataSource="">
      <udc:WsdlUrl/>
      <udc:SelectCommand>
       <udc:ListId/>
       <udc:WebUrl/>
       <udc:ConnectionString/>
       <udc:ServiceUrl UseFormsServiceProxy="false"/>
       <udc:SoapAction/>
       <udc:Query>http://portal/_vti_bin/owssvr.dll?Cmd=Display&List={ListGuid}&View={ViewGuid}&XMLDATA=TRUE&SortField=Names&SortDir=Asc</udc:Query>

      </udc:SelectCommand>
      <udc:UpdateCommand>
       <udc:ServiceUrl UseFormsServiceProxy="false"/>
       <udc:SoapAction/>
       <udc:Submit/>
       <udc:FileName>Specify a filename or formula</udc:FileName>
       <udc:FolderName AllowOverwrite=""/>
      </udc:UpdateCommand>
      <!--udc:Authentication><udc:SSO AppId='' CredentialType='' /></udc:Authentication-->
     </udc:ConnectionInfo>
    </udc:DataSource>
    **************


    Regards, R.D.M.
    Monday, October 26, 2009 9:28 PM
  • Hi,

    Go to IIS and locate _vti_bin site, go to properties and make sure anonymous access is configured.


    Try to open your link in browser directly to see if it returns valid data ?



    Ashraf ul Islam
    Sharepoint Consultant
    Tuesday, October 27, 2009 12:11 AM
  • Hi Ashraf,

    I tried to set anonymous access, but it didn't help. Even if it worked, I'm not allowed to leave it configured as anonymous access.

    And yes, if I open the link from the browser, it return valid data. Any idea what else can be done?
    Regards, R.D.M.
    Tuesday, October 27, 2009 2:38 AM
  • Follow the below steps:

    Go to Design Checker > Change Compatibility Settings. Then under Security and Trust Category select option Full Trust & click on Sign this Form Template and click on Create Certificate button.

    Thanks
    • Proposed as answer by Ashwin Bhagwat. _ Wednesday, October 28, 2009 8:52 AM
    • Unproposed as answer by R.D.M Wednesday, October 28, 2009 4:15 PM
    Wednesday, October 28, 2009 8:52 AM
  • Thanks Ashwin.

    Already tried Full Trust with certificate, if you read above. There is no compatibility issue. Do you have any other ideas?
    Regards, R.D.M.
    Wednesday, October 28, 2009 4:18 PM
  • Have you tried by "Right Click on the form" and select "Design" ?

    http://naimishpandya.wordpress.com/2013/04/08/forms-that-require-the-domain-permission-level-contain-features-that-access-information-on-a-network-such-as-data-connections-linked-images-and-code/


    Hiren Patel | Please click "Propose As Answer" if this post solves your problem or "Vote As Helpful" if this post has been useful to you.

    Friday, April 04, 2014 12:51 PM