locked
Cannot view XML input using XSL style sheet

    Question

  • I am a new .Net developer.

    i was given an existing DB, and modified it for my department.

    I intalled Visual Studio on my PC, and I think I have IIS going correctly (I can create a virtual server). But when I go to launch my homepage I get:

    The XML page cannot be displayed

    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


    A name was started with an invalid character. Error processing resource 'http://localhost/Publishtest/Home.aspx'. Line 1, ...

    <%@ Reference Page="~/Search.aspx" %>
    -^

    I see this error all over these forums but i haven't been able to figure it out yet. Is there a bad path somewhere? Any help is appreciated, I'm so new.

    Thanks!

     

    Monday, January 23, 2006 8:15 PM

Answers

  • try to run

    %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    or see

    How to repair IIS mapping after you remove and reinstall IIS
    http://support.microsoft.com/default.aspx?kbid=306005&product=aspnet

    Tuesday, January 24, 2006 5:27 PM
  • danaco, are you having a problem? If so, then see my reply from November 2007:

     

    Please start a new thread. This thread has been answered, and you are more likely to get help from a thread which has not been answered.

     

    When you start the new thread, please supply some information. You have not supplied any information which anyone reading your post could use to help you. It would help greatly if you were to show the start of the XML file that you're trying to view. Do not include the entire XML file if it is large.

     

    Wednesday, May 14, 2008 1:16 PM
    Moderator

All replies

  • Looks like your Publishtest Web application doesn't work correctly. It returns you source of aspx file, while it should process it first.
    Tuesday, January 24, 2006 9:49 AM
    Moderator
  • try to run

    %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    or see

    How to repair IIS mapping after you remove and reinstall IIS
    http://support.microsoft.com/default.aspx?kbid=306005&product=aspnet

    Tuesday, January 24, 2006 5:27 PM
  • I have ran into this senerio too. However, I located a potential problem with my installation of the same material.

    I found the problem being:

    1. I installed IIS and VWD2006EE to support .vb scripting.

    2. The template contains C# scripting.

    This may not be a problem(?), and I'm in the middle of reinstalling/reconfiguring to support the C# scripts.

    B.T.W I already executed 'ASPNET_regiis.exe -i' and that failed to correct the inability of the browser to execute the script.

    I hope this is helpful or perhaps gives someone with a greater knowledge of the products involved a starting place to help us beginners resolve this simple configuration error.

     

    Wednesday, February 15, 2006 2:33 AM
  • Hi,

    Hope someone can help. I am just a normal XP Pro user. I get the same error message when I try to access stored conversations in MSN Messenger 7.5. (build 7.5.0322)

    I am using Internet Explorer 7 preview beta 2. Is this the cause of the problem?

    Tuesday, February 21, 2006 5:26 PM
  • same problem here using IE7B2 and MSN7 or MSN Beta 8.

    I've found the only way to view the .xml files easily in a readble format

    is using Firefox, so IE7 seems to be the issue.

     

    Regards,

    Dean.

    Friday, February 24, 2006 10:32 AM
  • Hi Tory,

    You can check the IIS log to see whether the request is correctly processed at serverside. If the page is not correctly processed and responding, we do not need to care about browser first.

    Regards,

    Steven Cheng

    Saturday, February 25, 2006 7:53 AM
    Moderator
  • Well, everyone knows how microsoft sucks on every issue, the reason behind which huge masses converge to linux operating systems which have proved to be lots more stable and reliable. One know when Microsoft will provide a stable OS for its users. Anyway, we cannot blamed IE7 because it is a BETA version. the so-called preview indeed is a garbage bag full of bugs which makes windows what we commonly call 'woes'. I wont go into great stories criticising microsoft for its bugful product, lets come to the point.

    To curb the "Cannot view XML input using XSL style sheet:" problem, i have come towards a tweak into bypassing certain codes. I tried this one after having problems post-intalling the woes IE 7 beta preview. I recommend using the tweak until woes engineers find a solution to the deep seated codes of the software itself.

    Try this:

    Copy the folder where messenger usually stores its logs, which is usually :
    drive:\My Documents\My Received Files\*account*\History

    Move the folder in a way so that it's now only...

    drive:\History
    for example
    c:\history

    Now, on messenger of course, on Tools>Options>Messages>> (Message History), point the new directory to drive:\History. Here you are, the problem should be solved in most cases. If the problem persists, microsoft still sucks-Use linux :) If the above does not work, you can still read ur logs in a readable format, unlike notepad would open it, using mozilla firefox, which thanks God, is not a product of microsoft. Well, i hope that helps.

    Any querries, email on:
    nuker_blazed@hotmail.com [plz ask interesting questions]

    Sunday, February 26, 2006 7:19 PM
  • Any further info on this? Same problem and resolution as Dean. I would like to read my history from messenger.
    Thursday, March 30, 2006 4:49 PM
  • Great input, thunderbird.

    I tried to move the folder to other than drive:\,  (subfolder), didn´t work.

    Only drive:\historyfolder will work.

    Tuesday, May 09, 2006 2:54 AM
  • I had the same problem when I was moving my existing site to a new PC.  I found my History folder in the following location: "C:\WINDOWS\Temp\History\History.IE5".  I copied it to "C:\History" folder and updated the windows messenger to point to the new location.  It worked and I don't have this error anymore.

    Thank you thunderbird,

    HamidTheProgrammer

    Wednesday, March 21, 2007 4:33 PM
  • Thanks for the fantastic help !
    Thursday, April 26, 2007 12:29 PM
  • I moved my History folder to c:\History.  NOw how do I start Messenger and change location to point to c:\History.

     

    Thanks for any Help,

    .netNewbieMDS

    Sunday, July 29, 2007 5:28 PM
  • I ran this from the command line.  Worked like a charm.  Thanks...

     

    %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    Saturday, August 25, 2007 2:26 PM
  • Can you PLEASE help me??? I am getting this message when I try to open my message log from msn.

    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

    The system cannot locate the resource specified

     

    I really need the information in these msg logs and I have no idea how to fix it. Please help me!!!

    Sunday, November 04, 2007 10:00 PM
  • Please start a new thread. This thread has been answered, and you are more likely to get help from a thread which has not been answered.

     

    When you start the new thread, please supply some information. You have not supplied any information which anyone reading your post could use to help you. It would help greatly if you were to show the start of the XML file that you're trying to view. Do not include the entire XML file if it is large.

     

     

    Monday, November 05, 2007 1:30 AM
    Moderator
  •  

    %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

     

    It worked for me....Smile

    Monday, December 17, 2007 7:57 AM
  • I was having this issue also, so what i did was deleted the current conversation.  For example you are having a conversation with your friend xxxJohn, in your history the conversation is saved as xxxJohn.xml (or something to that effect), when u click on it and it gives you the connot view XML error, just delete the conversation, write something to that friend even if he is offline, close the conversation window and a new conversation will be created, once this is done the new conversation xml sheet should be viewable.

     

    Hope that helps :-)

     

    Friday, January 11, 2008 1:28 AM
  •  

    I was also gettingthe same error,

    I just ran %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i and everything worked fine.

    thanks a lot.

    Tuesday, April 08, 2008 8:59 AM
  • RE: 

    try to run

    %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

     

    THIS WORKED FOR ME! Nothing like a 20 second fix. Rare these days, but welcome all the same Smile

    Thursday, May 01, 2008 12:27 PM
  • Please give us the solution, not the cause. We need to solve the problem.

    Tuesday, May 13, 2008 12:06 AM
  • danaco, are you having a problem? If so, then see my reply from November 2007:

     

    Please start a new thread. This thread has been answered, and you are more likely to get help from a thread which has not been answered.

     

    When you start the new thread, please supply some information. You have not supplied any information which anyone reading your post could use to help you. It would help greatly if you were to show the start of the XML file that you're trying to view. Do not include the entire XML file if it is large.

     

    Wednesday, May 14, 2008 1:16 PM
    Moderator
  • %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    worked for me as well.
    Wednesday, August 13, 2008 6:38 PM
  • goto iis > default website > delete your local directory and add it again > create  

    Thursday, May 14, 2009 11:44 PM
  • I try to run
    %windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

    and I am getting Server Application Unavailable
    Thursday, June 11, 2009 5:06 PM