locked
Performance issues after migrating TFS to virtual server

    Question

  • Hi all,

    We recently upgraded our TFS from 2008 to 2010, we moved from an old machine to a virtual machine installed on a new server. The new server runs Widows 2008 R2 (standard), with only the Hyper-V role. It has plenty hardware (Intel Xeon CPU E5606, 16 GM RAM).

    The VM is running  Widows 2008 R2 (enterprise). It has TFS 2010 and SQL server 2008 R2 installed and 4GB allocated for it.

    The performance of the TFS has dramatically decreased after the upgrade. Running a WI query or checking out an item might take up to several minutes.

    Anyone with an idea?

    Thanks,

    Asher

     

    Monday, December 05, 2011 1:50 PM

All replies

  • Do you by any chance have 2 nics in the machine? I recall one time a customer had a second nic and that was throwing TFS in a crazy loop that would cause it to eventually time out and / or take very long to respond. If I remember it was because the 2 nics were in different subnets, or something like that. If you do have 2 nics, try disabling one of them.

    When you perform the queries, are you doing so using Team Explorer on the same server VM or from another client?


    Leo Vildosola - InCycle Software
    Monday, December 05, 2011 6:53 PM
  • Hi Leo,

    Thanks for replying. I am embarrassed to say I have no idea where to start checking for nics (I know it has something to do with my network cards...). I think this machine does have a second network card.

    We normally query from another client. It seems that on the server things move in a speedy manner.

    Is there a way of disabling this issue? Is there one that requires no hardware interference? 

    Thanks,

    Asher

     


    • Edited by Asher_barak Monday, December 05, 2011 7:20 PM
    Monday, December 05, 2011 7:20 PM
  • No second nic, then ignore my first comment. From what you said, the local queries are moving fast but remotely they are slow. Could it be a trace / route issue in your network? Can you try registering the TFS IP address instead of the DNS name? What I mean is, when you connect the client to TFS use the IP address instead. Does that make things go faster?
    Leo Vildosola - InCycle Software
    Monday, December 05, 2011 7:25 PM
  • Hi Leo,

    We have two network cards does not that mean two nic's?

    Asher

    Monday, December 05, 2011 7:31 PM
  • My apologies, I thought I read you did not have 2 nics. So, what you want to do is find out which nic is the one that TFS uses. To do this, go to your TFS server and open a command prompt. Run the command 'ping <serverName>' and see which IP address is returned. Run the command 'ipconfig /all' to find the LAN configuration with the matching IP address. Disable the other nic temporarily, the one TFS is not supposed to use. Test connectivity locally first to make sure that it is still as fast as before. Then connect to TFS remotely and test connectivity again. Any difference compared to before? If this improves performance, bring it to the attention of your network administrator and tell them about the problem so they can fix it.
    Leo Vildosola - InCycle Software
    Monday, December 05, 2011 7:39 PM
  • Hi Leo,

    I disabled the network adapter for the other network adapters on the Hyper-V machine (from device manager) . I now have only the card I use and the Virtual network LAN.

    This did not solve the problem.

    • Maybe I need to restart the Hyper-V machine for the changes to take effect?
    • Is disabling the network adapter equal to disabling the nic?
    • Is it possible the virtual network LAN has a nic and causes the problem?

     

    Asher


    • Edited by Asher_barak Tuesday, December 06, 2011 12:50 PM
    Tuesday, December 06, 2011 7:48 AM
  • Restarting may help, but I doubt it. Really, just disabling the LAN adapter in the VM should suffice. You don't have to touch the host server. Keep in mind this may not be the root of your problem at all. So, after you do this last test by disabling the LAN configuration in the VM for the appropriate adapter we should consider other avenues.

    For example, can you try turning off task offloading? See this reference - http://technet.microsoft.com/en-us/library/cc959732.aspx. It will require you to reboot your VM.


    Leo Vildosola - InCycle Software

    Tuesday, December 06, 2011 1:33 PM
  • I forgot to ask you. Did you ever try to remotely connect to your TFS by using the IP address instead of its name? We need to rule out any routing issues.
    Leo Vildosola - InCycle Software
    Tuesday, December 06, 2011 1:48 PM
  • Leo hi,

    Thanks again for the interest and the help. I think I may have mis-explained the machines layout:

    We have a physical server with 2 nics. This server does nothing but run Virtual Servers

    This server has 4 items under Device Manager->Network adapters:

    1. nic 1
    2. nic 2
    3. IBM USB Remote NDIS Network device
    4. Local Area connection 3 - virtual network

    I know no. 4 was created by the Hyper-V and it is used by the virtual machines. I have so far disabled No1 and No 3, to be on the safe side.

    The TFS server is a virtual machine. It resides on the physical server and has only one entry under Device Manager->Network adapters: Microsoft virtual machine bus network adapter.

     

    Asher

     

    Tuesday, December 06, 2011 6:25 PM
  • Hi Leo,

    Did that. No difference.

    Asher

    Tuesday, December 06, 2011 6:25 PM