none
Win7 (Ultimate) x64, XP-Mode, Netzwerk

    Question

  • Hallo,
    ich suche nach einer Möglichkeit vom Host (also Windows 7) über die Netzwerkverbindung auf Freigaben des im XP-Mode vorhandenen XP zuzugreifen. Umgekehrt ist es problemlos möglich?
    Weiß jemand wie das geschehen kann?

    Vielen Dank für entsprechende Hinweise ..

    Monday, May 24, 2010 11:00 AM

Answers

  • Am 26.05.2010 11:51, schrieb Waldkauz:
    > Wie kann ich nun Bridge beim XP-Mode einstellen?

    In dem du in deinem BEnutzerprofiin den Ordner
    "C:\Users\%username%\Virtual Machines" öffnest, dort findest du "Windows
    XP Mode.vmcx"
    und in der Menüleiste (wenn sie eingeblendet ist),bzw. auf der rechten
    Maustast die Einstellungen der Maschine.

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    • Marked as answer by Waldkauz Thursday, May 27, 2010 10:57 AM
    Wednesday, May 26, 2010 8:03 PM

All replies

  • Hi,
     
    Am 24.05.2010 13:00, schrieb Waldkauz:
    > ich suche nach einer Möglichkeit vom Host (also Windows 7) über die
    > Netzwerkverbindung auf Freigaben des im XP-Mode vorhandenen XP
    > zuzugreifen. Umgekehrt ist es problemlos möglich?
     
    Dann ist die Firewall in der XP Maschine aktiviert.
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
     
    Monday, May 24, 2010 6:41 PM
  • Danke für die Info .. Was soll man denn da tun? Das Ausschalten ist ja wohl nicht sinnvoll, da ja auch auf das Internet zugegriffen wird; oder sehe ich das falsch? Vielleicht hat es ja auch damit etwas zu tun, dass die Netzwerkverbindung vom XP-Client über "Microsoft-Terminaldienste" (\\tsclient) und nicht über "Microsoft Windows-Netzwerk" erfolgt? Im Windows7-Host habe ich aber kein solches Netzwerk gefunden ;-(
    Tuesday, May 25, 2010 12:38 PM
  • Am 25.05.2010 12:38, schrieb Waldkauz:
    > Danke für die Info .. Was soll man denn da tun?

    Auschalten?

    > Das Ausschalten ist ja wohl nicht sinnvoll,

    konfigurieren?

    Du binst hinter einem DSL Router, du brauchst die Firewall
    sicherlich nicht, da jeder Zugriff auf dein System selbstinitiiert ist
    und nicht von aussen direkt erfolgen kann.

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Tuesday, May 25, 2010 12:52 PM
  • Danke .. Ich habe den Firewall ausgeschaltet: no luck Nun habe ich den Netzwerkinstallations-Assistenten ausgeführt, danach existiert dann im XP auch das "Microsoft Windows-Netzwerk", kann aber nicht benutzt werden. Ich vermute un, dass es daran liegt, dass die IPs von Host + Client nicht "harmonisieren". Der Host (Win7) hat die IP 192.168.178.37, der Client (XP-Mode) hat die IP 192.168.131.65 (wurde automatisch festgelegt); nun habe ich wohl das Problem: kann ich diese IP so verändern, damit beide Umgebungen problemlos miteinander kommunizieren können? Bisher ist in beiden Umgebungen allein der Name der Workgroup identisch? Mein LAN und die Verbindung zum Internet wird über eine Fritz!Box 7270 gesteuert. Evtl. brauche ich im XP-Client noch einen euen User mit Password, um den Zugriff zu ermöglichen?
    Tuesday, May 25, 2010 2:58 PM
  • Hi,

    Am 25.05.2010 14:58, schrieb Waldkauz:
    > Der Host (Win7) hat die IP 192.168.178.37, der Client (XP-Mode) hat
    > die IP 192.168.131.65 (wurde automatisch festgelegt); nun habe ich
    > wohl das Problem: kann ich diese IP so verändern, damit beide
    > Umgebungen problemlos miteinander kommunizieren können?

    Natürlich geht das.

    > Bisher ist in beiden Umgebungen allein der Name der Workgroup
    > identisch? Mein LAN und die Verbindung zum Internet wird über eine
    > Fritz!Box 7270 gesteuert. Evtl. brauche ich im XP-Client noch einen euen
    > User mit Password, um den Zugriff zu ermöglichen?

    Den hast du ja schon.
    Der Virtuelle PC ist nichts anderes als der physikalische.
    Es gelten dieselben Regeln beim Aufbau einer Workgroup

    TSchö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Tuesday, May 25, 2010 3:11 PM
  • Danke ..

    Neben dem virtuellen Computer vom MS benutze ich auch die VMware Workstation 7.
    Durch diese Software werden auf dem Host virtuelle Netzwerkkarten erzeugt,
    aus deren IPs dann die IPs in den Clients entstehen.
    Beispiel:
       Ein "Öffentliches Netzwerk für VMware8", gekennzeichnet als "Nicht identifiziertes Netzwerk",
       mit der Angabe "Kein Netwerkzugriff"; das Netzwerk für VMware1 ist deaktiviert.
       -- IP 192.168.57.1 (wurde automatisch festgelegt)
       Für die zugehörigen VMs habe ich NAT als Netwerk-Connection eingestellt;
       die VMs haben als IP 192.168.57.nnn.
    Aus den VMs komme ich problemlos ins Internet und auf den Host
    sowie vom Host auf die VMs --- jedoch NICHT von anderen Computern im LAN auf die VMs auf dem Host.

    Ich stelle mir nun vor, dass auch für die MS-VM eine zusätzliche virtuelle Netzwerkkarte das Problem lösen könnte, doch MS erzeugt ja so etwas nicht (zumindest ist mir nichts entsprechendes bekannt).
    Ich könnte mir jedoch vorstellen, dass die Fritz!Box dabei "helfen" könnte,
    ohne dass ich eine IP zu ändern habe?

    Mir ist klar, dass eine VM als "normaler" Computer zu betrachten ist,
    aber - bei diesem XP gibt's für mich doch so einige Unklarheiten ..
    (bei VMware klappt's ja ..)

    Meines Wissens ist der Standarduser des XP ein Admin, hat aber kein Password,
    und - zum Zugriff wird vom XP-Client \\tsclient verwendet.

    Ich habe unterdessen in dem XP einen kennwortgeschützten User angelegt (aber noch kein Login zu ihm vollzogen), das Ergebnis ist:
    - das AutoLogin ins XP funktioniert weiterhin (ohne Anzeige eines Auswahlfensters)
    - der korrekte Zugriff über das "Microsoft Windows-Netzwerk" ist aber immer noch nicht möglich;
      im Explorer des XP wird allein die Workgroup angezeigt.
      Fehler: Systemfehler 53. Der Netzwerkpfad wurde nicht gefunden. (ERROR_BAD_NETPATH)

     

    Tuesday, May 25, 2010 4:04 PM
  • Waldkauz:
     
    > Meines Wissens ist der Standarduser des XP ein Admin, hat aber kein Password,
    > und - zum Zugriff wird vom XP-Client \\tsclient verwendet.
     
    Er heißt "XPMUser" und hat das Passwort, das du ihm gegeben hast. Du wurdest
    bei der Installation aufgefordert, ein Passwort zu vergeben, also wirst du
    auch eines vergeben haben. Wenn du das nicht mehr kennst, ist es wohl
    besser, beim automatischen Logon zu bleiben. ;-)
    > Ich habe unterdessen in dem XP einen kennwortgeschützten User angelegt (aber noch kein Login zu ihm
    > vollzogen), das Ergebnis ist:
    > - das AutoLogin ins XP funktioniert weiterhin (ohne Anzeige eines Auswahlfensters)
     
    Du kannst auch testweise mal die Integrationsfeatures abschalten - und schon
    wirst du beim Start der VM aufgefordert, das Passwort von XPMUser
    einzugeben.
     
    > - der korrekte Zugriff über das "Microsoft Windows-Netzwerk" ist aber immer noch nicht möglich;
    > im Explorer des XP wird allein die Workgroup angezeigt.
     
    Wenn du ein normales Arbeitsplatznetzwerk mit beiderseitigem Zugriff
    einrichten willst, gelten die üblichen Regeln zur Einrichtung eines solchen.
     
    hpm
     
    Tuesday, May 25, 2010 4:54 PM
  • Vielen Dank, aber ..

    > Wenn du ein normales Arbeitsplatznetzwerk mit beiderseitigem Zugriff
    > einrichten willst, gelten die üblichen Regeln zur Einrichtung eines solchen.

    Was verstehst Du unter diesen Regeln?
    Ich nehme an, dass die IPs sich im selben Netzwerk (also 192.168.178.nnn) befinden, oder?


    Ich habe auch mal die Integrationsfeatures abgeschaltet, das ist schon OK so,
    (mir fiel auch das Password wieder ein);
    die Frage ist aber: gibt es so etwas Ähnliches auch auf der Host-Seite,
    damit auch von dort ein direkter Zugriff (á la \\tsclient) , nunmehr jedoch auf den XP-Client, möglich ist?

    Bei VMware funktioniert dies ja dadurch, dass virtuelle Netzwerkkarten auf dem Host existieren.

    Tuesday, May 25, 2010 7:08 PM
  • Hi,

    Am 25.05.2010 16:54, schrieb Hans-Peter Matthess:
    > Er heißt "XPMUser" und hat das Passwort, das du ihm gegeben hast. Du wurdest
    > bei der Installation aufgefordert, ein Passwort zu vergeben, also wirst du
    > auch eines vergeben haben.

    Ich habe gestern mit dem XPMode etwas völlig anderes ausprobiert und bin
    über folgendes gestolpert:
    Installierst du diesen direkt mit dem "x64.msi" das in dem gepackten
    Paket enthalten ist, dann erfolgt diese Aufforderung nicht

    Soviel zum Thema Unattended Deploymnet ...

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Wednesday, May 26, 2010 7:49 AM
  • Hi,

    Am 25.05.2010 16:04, schrieb Waldkauz:
    > Durch diese Software werden auf dem Host virtuelle Netzwerkkarten erzeugt,

    .... die aber auch keiner braucht, da du die Netzwerkkarte der VM
    auch direkt auf den physikalischen Adaptern bridgen und natten kannst.
    Ich verwende seit Jahren kein VM* Netzwerkkarten.
    Mir reichen die echten und der MS eigene LoopbackAdapter, letzterer
    für die "Host-only" Konfiguration und einen permanenten TCPIP Stack
    auch ohne Netzwerkkabel.

    > Ich stelle mir nun vor, dass auch für die MS-VM eine zusätzliche
    > virtuelle Netzwerkkarte das Problem lösen könnte,

    Brauchst du nicht. Bridge ist das Zauberwort.

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Wednesday, May 26, 2010 7:50 AM
  • Danke Mark, > Brauchst du nicht. Bridge ist das Zauberwort. Bei VMware verwende ich meist NAT (Bridge geht aber auch), komme zum Host und ins Internet, außerdem kann ich die VMs vom Host aus über's Netzwerk erreichen ;-) VMware8 ist vorhanden, VMware1 habe ich disabled. Nun werde ich auch noch versuchen, ob meine momentanen Verbindungen (insbesondere die Verbindung Host => Client) weiterhin funktionieren, wenn ich auch VMware8 disable (ich erwarte, dass ich die IPs ändern muss). Beim XP-Mode komme ich zum Host (\\tsclient) und ins Internet; das ging aber sofort nach der Installation des XP-Mode-VM. Meine nachfolgenden Versuche (wie in den Beiträgen beschrieben) änderten nichts .. Ich kann bisher die XP-Mode-VM leider immer noch nicht vom Host aus erreichen ;-( .. und das war ja eigentlich mein Ausgangspunkt .. Wie kann ich nun Bridge beim XP-Mode einstellen?
    • Edited by Waldkauz Wednesday, May 26, 2010 12:50 PM Strukturierung
    Wednesday, May 26, 2010 11:51 AM
  • Waldkauz:

    >> Wenn du ein normales Arbeitsplatznetzwerk mit beiderseitigem Zugriff
    >> einrichten willst, gelten die üblichen Regeln zur Einrichtung eines solchen.
     
    > Was verstehst Du unter diesen Regeln?

    Siehe:
    http://windows.microsoft.com/de-DE/windows7/Networking-home-computers-running-different-versions-of-Windows
    http://windows.microsoft.com/de-DE/windows7/help/top-solutions
    http://support.microsoft.com/kb/935530/DE/
    http://support.microsoft.com/default.aspx?scid=kb;DE;813936&product=winxpGer
    http://windows.microsoft.com/de-DE/windows-vista/Setting-up-a-home-network
    http://www.pc-adviser.de/netzwerk_aufbau.htm
    http://www.different-thinking.de/

    > Ich nehme an, dass die IPs sich im selben Netzwerk (also 192.168.178.nnn) befinden, oder?

    Ja, wenn der Host 192.168.0.1 hat, nimmt man für den anderen Rechner z.B.
    192.168.0.2 usw...
     
    > Ich habe auch mal die Integrationsfeatures abgeschaltet, das ist schon OK so,
    > (mir fiel auch das Password wieder ein);
    > die Frage ist aber: gibt es so etwas Ähnliches auch auf der Host-Seite,
    > damit auch von dort ein direkter Zugriff (á la \\tsclient) , nunmehr jedoch auf den XP-Client, möglich ist?

    Die virtuelle Maschine hat ja einen Namen. Ein Zugriff vom Host auf die VM
    erfolgt also mit \\VMName\Freigabe, siehe oben. Wenn du das als ganz
    normales Netzwerk einrichtest, kann der Zugriff von der VM auf den Host dann
    auch nicht mehr \\tsclient\Freigabe sondern \\Hostname\Freigabe sein.
    Kann man machen wie man lustig ist und wie's einem gerade passt.

    hpm

    Wednesday, May 26, 2010 2:27 PM
  • Mark Heitbrink [MVP]:
     
    > > Er heißt "XPMUser" und hat das Passwort, das du ihm gegeben hast. Du wurdest
    > > bei der Installation aufgefordert, ein Passwort zu vergeben, also wirst du
    > > auch eines vergeben haben.
     
    > Ich habe gestern mit dem XPMode etwas völlig anderes ausprobiert und bin
    > über folgendes gestolpert:
    > Installierst du diesen direkt mit dem "x64.msi" das in dem gepackten
    > Paket enthalten ist, dann erfolgt diese Aufforderung nicht
    > Soviel zum Thema Unattended Deploymnet ...
     
    Aha, hatte ich noch nicht versucht.
     
    hpm
     
    Wednesday, May 26, 2010 3:54 PM
  • Am 26.05.2010 11:51, schrieb Waldkauz:
    > Wie kann ich nun Bridge beim XP-Mode einstellen?

    In dem du in deinem BEnutzerprofiin den Ordner
    "C:\Users\%username%\Virtual Machines" öffnest, dort findest du "Windows
    XP Mode.vmcx"
    und in der Menüleiste (wenn sie eingeblendet ist),bzw. auf der rechten
    Maustast die Einstellungen der Maschine.

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    • Marked as answer by Waldkauz Thursday, May 27, 2010 10:57 AM
    Wednesday, May 26, 2010 8:03 PM
  • Danke Mark, ich denke, mit Deinem letzten Hinweis ist das Problem gelöst ;-) Meine Vorgehensweise war: 1. Starten des XP-Modes 2. Auswahl von Extras-Einstellungen 3. Änderung des Einstellungseintrags "Netzwerk" wie folgt Eintrag für Adapter1 hatte den Wert "Gemeinsam genutztes Netzwerk (NAT)" Eintrag für Adapter1 hat nunmehr den Wert "NVIDIA nForce-Netzwerkcontroller" (gemäß meines Hosts) Im Anschluß daran kann ich nunmehr sowohl die Microsoft-Terminaldienste (also \\tsclient\..) als auch das Microsoft Windows-Netzwerk nutzen; letzteres sowohl vom Host als auch vom XP-Mode-Client. Damit ist das Problem für mich gelöst! Vielen Dank an alle die dazu beigetragen haben, das Problem einzugrenzen und letztendlich eine Lösung zu erarbeiten. SX
    Thursday, May 27, 2010 10:57 AM
  • Noch eine Bemerkung:

    das Netzwerk sieht jetzt folgendermaßen aus:

                                                  vorher                               nunmehr
    DhcpDefaultGateway          192.168.131.254              
    192.168.178.1
    DhcpIPAddress                    192.168.131.65                 192.168.178.29
    DhcpNameServer                192.168.178.1                    192.168.178.1
    DhcpServer                          192.168.131.254               192.168.178.1

    Jetzt hoffe ich nur noch, dass die Formatierung mir keine Probleme bereitet .. SX

    Thursday, May 27, 2010 11:15 AM
  • Ach ja, und vergessen hatte ich nun noch, auf die Antwort zu meinem anderen (zugehörigen) Problem zu verweisen:

     

    http://social.msdn.microsoft.com/Forums/de-DE/w7itproappcompatde/thread/5970f601-e657-4038-87d7-cca5ff9778d1?prof=required

     

     

    Thursday, May 27, 2010 11:19 AM