locked
Issue with Logitech Setpoint Software

    Question

  • I am trying the Developer Preview and noticed an issue with the Setpoint software.

    The software installs just fine and works for a time but upon restart both the mouse and keyboard tabs under Setpoint disappear. This means I cannot bind any of the extra functions of my mouse.

    If I uninstall the software and remove all references to it from the program files, common apps and user app data folders I can then re-install the software to restore this functionality. Although the last time I tried this the system display shut down and couldn't be recovered ( I'm not sure if this is a related issue) and on restart the functionality was lost again.

    Thanks

    Friday, September 16, 2011 12:23 PM

Answers

  • Hello Jac70,

     

    I've encountered the same issue you have mentioned with my MK700 keyboard and mouse combo and this is what I managed to do to get it to work better with Windows Developer Preview.

    • Open Windows Task Manager
    • End Task "Logitech SetPoint Event Manager (UNICODE)"
    • Navigate to "C:\Program Files\Logitech\SetPointP\"
    • Right click "Mouse and Keyboard Settings" and click 'Run as administrator'

     

    It is annoying, I admit. Especially if you restart frequently. Although I do hope this helps you and anyone else.


    • Edited by Steven Downer Saturday, September 17, 2011 6:54 AM
    • Marked as answer by Jac70 Saturday, September 17, 2011 7:43 AM
    Saturday, September 17, 2011 6:37 AM

All replies

  • Hello Jac70,

    I suggest you uninstall your Setpoint software and reinstall using compatibility mode.

    From the Start Screen:

    Type Compatibility and select Settings
    Next click ‘Run programs made for previous versions of Windows

    Assuming you have the setup file saved local, run the Troubleshooter and select the option for not listed and browse to the setup file and follow the prompts to run under
    compatibility mode.

    Thanks

    Friday, September 16, 2011 10:33 PM
    Moderator
  • Wich mouse are you using? I've got G9x and don't have an issue with the drivers.

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Friday, September 16, 2011 10:35 PM
  • I am using an MX Revolution and a Logitech Illuminated keyboard. There should be 3 tabs on my Setpoint software, one each for mouse and keyboard and another one labelled 'tools'. I'm only getting tools at the moment but I will try Marilyn's compatibility suggestion.

     

    Cheers.

    Saturday, September 17, 2011 6:00 AM
  • Hello Jac70,

     

    I've encountered the same issue you have mentioned with my MK700 keyboard and mouse combo and this is what I managed to do to get it to work better with Windows Developer Preview.

    • Open Windows Task Manager
    • End Task "Logitech SetPoint Event Manager (UNICODE)"
    • Navigate to "C:\Program Files\Logitech\SetPointP\"
    • Right click "Mouse and Keyboard Settings" and click 'Run as administrator'

     

    It is annoying, I admit. Especially if you restart frequently. Although I do hope this helps you and anyone else.


    • Edited by Steven Downer Saturday, September 17, 2011 6:54 AM
    • Marked as answer by Jac70 Saturday, September 17, 2011 7:43 AM
    Saturday, September 17, 2011 6:37 AM
  • Thanks Steven - this worked for me too.

     

    Also, if you set the 'Run as Administrator' check box under the compatability tab I would assume it should still work after a reboot.

     

    Thanks again.

    Saturday, September 17, 2011 7:46 AM