locked
Remote test - Cannot connect to a test controller on a virtual machine

    Question

  • I have Test controller and Test agent installed on a virtual machine VM1. Test agent is shown is Online. I'm trying to run CodedUI tests remotely from my machine. But every time I go to Test -> Manage Test Controllers... in VS2010 it hangs. The same effect when I try to run any test remotely.

    Both machines are in the same domain, on my machine i'm using domain admin user, on VM local admin.

    I've got these 2 errors in Event Viewer:

    1. The description for Event ID 0 from source VSTTExecution cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    (devenv.exe, PID 7732, Thread 1) IdleProcessorManager.DoWork - Job threw:
    Item has already been added. Key in dictionary: '7c58e17b-57a5-e486-31cc-aca08ec38d23'  Key being added: '7c58e17b-57a5-e486-31cc-aca08ec38d23' at
       at Microsoft.VisualStudio.TestTools.Common.Xml.XmlPersistence.LoadHashtable[K,V](XmlElement element, String location, String keyLocation, String valueLocation, XmlTestStoreParameters parameters)
       at Microsoft.VisualStudio.TestTools.Common.TestListCategory.Load(XmlElement element, XmlTestStoreParameters parameters)
       at Microsoft.VisualStudio.TestTools.Common.Xml.XmlFilePersistence.LoadTestList(String fileName)
       at Microsoft.VisualStudio.TestTools.TestManagement.Tmi.LoadCategories(String location, TestListCategoryConflictHandler idVetoingHandler, TestListCategoryConflictHandler nameVetoingHandler)
       at Microsoft.VisualStudio.TestTools.TestManagement.Tmi.LoadCategories(String location)
       at Microsoft.VisualStudio.TestTools.TestCaseManagement.SolutionIntegrationManager.LoadCategoriesIntoTmi(String filename)
       at Microsoft.VisualStudio.TestTools.TestCaseManagement.SolutionIntegrationManager.<InternalLoadMasterCategoryFileIntoSolution>d__83.MoveNext()
       at Microsoft.VisualStudio.TestTools.TestCaseManagement.IdleProcessorManager.DoWork()

    2. The description for Event ID 0 from source VSTTExecution cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    (devenv.exe, PID 7732, Thread 65) Timed out waiting for controller connect



    Tuesday, June 26, 2012 9:44 AM

Answers

  • Hi Anton,

    Glad to receive your reply.

    Since it works well in another pc, so we could make sure that it is not related to the Controller and Agent configuration.

    If you could make sure that it is not the Permissions/ Firewall issues. I doubt it is related the VS or system Environment. Maybe you could try the following options:

    You could locate to the IDE folder then run these commands, or you can set path to the system environment.

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    Then create a new coded UI test or load test and run it remotely. Check the result.

    If it still has this issue. How about repairing your VS?

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, June 29, 2012 2:44 AM

All replies

  • Hi Anton,

    Thank you for posting in the MSDN forum.

    If we want to run the test remotely, we would make sure that the Agent is ready in the Manage Test Controllers, you could check your local.testsetings file, and check whether you could select the Controler in the “Role” option.

    1. Make sure that you install the VS2010 SP1 in you VS PC.
    2. Run your VS as the administrator and check it.
    3. Like Tim’s suggestion in this thread “Manage Test Controllers hangs in VS 2010”, remove/unload any add-ins and check it.

    If still no help, I suggest you try to configure your Test Controller/Agent manually, click “Apply Setting”, and then check whether you could get any messages.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us


    Wednesday, June 27, 2012 8:22 AM
  • Hi Jack. Thank you for reply.

    In my initial post I've mentioned that when I enter my controller name in Manage Test Controller - it hangs. So I cannot see any agents there.

    1. I have SP1

    2. It's running as Administrator

    3. All add-ins were removed

    It seems like something else is blocking VS from to be able to connect to Test Controller. Do you have other suggestions?

    Wednesday, June 27, 2012 9:23 AM
  • Hi Anton,

    Glad to receive your reply.

    1. Check your Task Manager, make sure that it isn’t busy, close other apps and firewall and the anti-virus software.
    2. As my previous reply, if you open your Test Controller and Agent, then try to configure them manually. Did you get any error messages or warnings? See “Troubleshooting Guide for Visual Studio Test Controller and Agent”. Note: You must set up your agent to run as a process. See here.
    3. If possible, I suggest you try to use other pc to check it, so we could make sure that whether it is related to your VS or Window Environment.

    Since it is hard to repro this issue, if still no help, I’m afraid that these questions require a more in-depth level of support. I suggest you visit the following link to see the various paid support options that are available to better meet your needs.http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone. Thanks for your understanding.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, June 28, 2012 5:38 AM
  • I went through the Troubleshooting but it didn't help me. I've tried to run it from VS on another machine and it worked, used the same VM1 for Controller/Agent and it's part of the same network and have the same Firewall settings.

    Any other ideas what piece could block me from accessing Controller/Agent?

    Thank you.

    Thursday, June 28, 2012 12:00 PM
  • Hi Anton,

    Glad to receive your reply.

    Since it works well in another pc, so we could make sure that it is not related to the Controller and Agent configuration.

    If you could make sure that it is not the Permissions/ Firewall issues. I doubt it is related the VS or system Environment. Maybe you could try the following options:

    You could locate to the IDE folder then run these commands, or you can set path to the system environment.

    C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE

    Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    Then create a new coded UI test or load test and run it remotely. Check the result.

    If it still has this issue. How about repairing your VS?

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, June 29, 2012 2:44 AM
  • Hey, it finally works! But only in Safe mode. The weird thing is that I have no addins running as far as I know.

    I've tried all the other Reset commands you've suggested but no luck there.
    Friday, June 29, 2012 2:39 PM
  • Hi Anton,

    Glad to receive your reply.

    Hey, it finally works! But only in Safe mode. The weird thing is that I have no addins running as far as I know. I've tried all the other Reset commands you've suggested but no luck there.

    As you said that it worked in Safe mode, but it didn’t help with the other commands. So I suggest you try to repair or reinstall your VS and check it. Since start Visual Studio in safe mode, loading only the default environment and services. So I doubt that it is related to your VS installing or your system Environment.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, July 02, 2012 1:52 AM