none
Reportviewer HTTP handler error when HTTP handler is specified in web.config

    Question

  • Hi,

    I got VS 2005 and reportviewer web control to work on my local box.  However when I deployed the web appl to the company web server(which has only .NET 2.0 installed and no VS2005), I had to build a bin directory to keep the 3 reportviewer DLLs and now I got stuck with the HTTP handler error( even though my web.config has that Http Handler).  Any light you can throw in will be much appreciated.

    -------------------------------------------------------------------------------------

    Error message: The Report Viewer Web Control HTTP Handler has not been registered in the application's web.config file.  Add <add verb="*" path="Reserved.ReportViewerWebControl.axd" type = "Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" /> to the system.web/httpHandlers section of the web.config file.

    ---------------------------------------------------------------------------------------

    Attached web.config

    <?xml version="1.0"?>
    <configuration>
        <appSettings/>
        <connectionStrings>
            <add name="NorthwindConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\Northwind.mdb;Persist Security Info=True"
                providerName="System.Data.OleDb" />
        </connectionStrings>
        <system.web>
            
            <httpHandlers>
                <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
                    validate="false" />
            </httpHandlers>
            <compilation debug="false" strict="false" explicit="true">
                <buildProviders>
                    <add extension=".rdlc" type="Microsoft.Reporting.RdlBuildProvider, Microsoft.ReportViewer.Common, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                </buildProviders>
            </compilation>
            
        </system.web>
    </configuration>

    Friday, January 20, 2006 5:27 PM

All replies

  • did you get this solved?

    i have the same error....

     

    g.

     

    Thursday, June 29, 2006 1:02 PM
  • Ok its like, typical .NET framework does not come with reporting related DLLs. So we have to install 'Microsoft Report Viewer Redistributable 2005' from MS at http://www.microsoft.com/downloads/details.aspx?FamilyID=8a166cac-758d-45c8-b637-dd7726e61367&amp;DisplayLang=en<br>
    Thursday, October 19, 2006 5:27 AM