none
Either your web browser doesn't support JavaScript or JavaScript is disabled

    Question

  • I am trying to get bing maps to display on the account form using code from Dynaimcs CRM 2011 Administration guide pgs - 544 - 547.  Everything was going great until I got the error message documented below.

    My environment is Vista - CRM 2011 w/Outlook 2007 - IE9

    My solution and erros are as follows:

    Onload event

    function BingMap(strStreet, strCity, strState, strZip)

    {

    var IFrame = Xrm.Page.ui.controls.get("IFRAME_Bing_Map");

    strURL = "http://www.bing.com/maps/?v=2&where1=" + strStreet + "%20" + strCity + "%20" + strState + "%20" + strZip + "&encType=1";

    IFrame.setSrc(strURL);

    }

    Handler properties

    Xrm.Page.data.entity.attributes.get("address1_line1").getValue(),  Xrm.Page.data.entity.attributes.get("address1_city").getValue(),  Xrm.Page.data.entity.attributes.get("address1_stateorprovince").getValue(),  Xrm.Page.data.entity.attributes.get("address1_postalcode").getValue()

    1<sup>st</sup> Error message – respond NO

    Do you want to display the web content that was delivered securely?

    Results in Map tab

    Bing Maps provides US, Europe, the Americas, Africa, Asia, and the World with road, street, and satellite maps. Get driving directions and local traffic conditions, and plan routes to nearby businesses. Use apps to find the lowest gas prices near you, search for nearby parking lots and rates, and calculate taxi fares and taxi routes. Bing Maps is the replacement for MSN Maps and Directions, Mapblast.com and Mappoint.msn.com products. Bing Maps uses JavaScript. Either your web browser doesn't support JavaScript or JavaScript is disabled.

    I have checked my IE options and enabled anything that refers to jscript and it has not helped.

    Tuesday, May 24, 2011 8:15 PM

Answers

  • See if you can call bing maps in the url using HTTPS instead of HTTP.  I imagine you are using HTTPS already in either bing or CRM.  

    You get this message when you have a page that is displaying HTTP and HTTPS content at the same time.  

    If the earlier suggestion doesn't help then this should work on the client.  Really any ad or other random thing on the bing maps page can cause this too, so you might have to do it this way anyways.

    Tools --> Internet options --> Security tab --> click Custom level... button --> scroll down to Miscellaneous --> Display mixed content --> click radio button enable.


    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, May 24, 2011 9:21 PM
    Moderator

All replies

  • In your Iframe properties (double click it in th form designer) make sure to uncheck the restrict cross frame scripting box.
    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, May 24, 2011 8:51 PM
    Moderator
  • Jamie,

    Making progress.  The address is now being passed to bing maps.  How do I get rid of the first error message about content being delivered securely?  I have to respond No to get anything.  Users won't like it.

    BTW thanks for the quick response

     

    Tuesday, May 24, 2011 9:04 PM
  • See if you can call bing maps in the url using HTTPS instead of HTTP.  I imagine you are using HTTPS already in either bing or CRM.  

    You get this message when you have a page that is displaying HTTP and HTTPS content at the same time.  

    If the earlier suggestion doesn't help then this should work on the client.  Really any ad or other random thing on the bing maps page can cause this too, so you might have to do it this way anyways.

    Tools --> Internet options --> Security tab --> click Custom level... button --> scroll down to Miscellaneous --> Display mixed content --> click radio button enable.


    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, May 24, 2011 9:21 PM
    Moderator
  • Jamie,

    You are my hero.  I could not use https but I changed the internet option to allow mixed content and it worked great.

     

    Thank you very much

    Tuesday, May 24, 2011 9:52 PM
  • Thanks, now the hard part will be that you will either have to push out that setting somehow via group policy or tell your people how to change that setting in their IE.  :)
    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, May 24, 2011 9:54 PM
    Moderator