locked
Spam mail filtering in Windows Live Mail does not work at all

    Question

  • I have configured Windows Live Mail to filter my incoming mail and move spam mail to the Junk folder.  I moved security level to "High" and marked a number of senders' addresses in the blocked lists and blocked domains.   In spite of all this, not even one single spam mail is being removed or blocked.    To add to my frustration, my McAfee Internet Security software does not work with Windows Live Mail, and so not even McAfee is filtering my spam mail.    Any ideas pleas?
    Thursday, December 02, 2010 5:00 PM

All replies

  • I have exact same problem. The security software I use, ESET, *was* catching about 90% of the junk - until Widows updated me to Live Mail. So far, suggestions from others -i.e., delete Live Mail then reinstall, or, set your security level...- haven't worked. I'm sure we're not the only ones. Microsoft is mum on the issue.
    Tuesday, December 21, 2010 11:40 PM
  • I had the same problem, but found that with some email addresses, Windows Live does not add sender to the Blocked Senders list, so I now add them manually by using the Safety Options menu under the "Junk" icon, then click the "Blocked Senders" tab, then click the "ADD" button, to type the address in myself.

    Hope this helps!


    Saturday, July 02, 2011 9:08 AM