none
Application not available where this person is located

    Question

  • We're developing an application for the UK and everything is proceeding well for users there.

    It will also be available elsewhere in Europe and to that end a user with a Swedish-located Live ID (i.e. they set Sweden to be their location when registering a Live ID) is trying to access the application.

    When they arrive at the HealthVault page on PPE where they can associate the application with their account, they are unable to select the application and get a message that translates as "not available where this person is located".

    Are we missing a setting in the Application Configuration Center? Or is there some setting elsewhere that can be changed to allow them to access the application?

    Friday, October 26, 2012 10:18 AM

All replies

  • Hi Jardee,

    What is your Application ID?

    Thanks,

    Ali

    Friday, October 26, 2012 9:34 PM
  • The application ID is :

    5768c176-fddd-40bf-afd2-d8edd2bdd419

    Monday, November 05, 2012 1:43 PM
  • Hi Jardee,

    Looks like you're using the U.S. instance of HealthVault PPE which is intended for U.S. app development. To develop for Europe, please use the E.U. instance of HealthVault PPE including ACC. Take a look at the E.U. HealthVault instance section of the HealthVault Development Basics article for the specific URL endpoints to use.

    In an upcoming release, we'll have a single global HealthVault service so you won't have to know about these details. See slide 5 of the HealthVault State of the Union presentation from April for more info.

    Ali

    Tuesday, November 06, 2012 5:07 AM
  • Unfortunately that doesn't seem to be the case, although I'm perfectly willing to concede how I might be misreading things completely!

    I've just tried it again.

    I created a Live ID via https://account.healthvault-ppe.co.uk/signup and that all seemed to go okay.

    I then went via our application to try and register/log in which goes to https://account.healthvault-ppe.co.uk/appselectrecord.aspx

    Looking in web.config for the app and there are the following appSettings -

        <add key="ShellUrl" value="https://account.healthvault-ppe.co.uk" />
        <add key="HealthServiceUrl" value="https://platform.healthvault-ppe.co.uk/platform" />

    Is there anything else I'm missing that will be pointing to the U.S. version?

    We are running on Azure, if that makes any difference.

    Apparently we were originally using the U.S. PPE but then subsequently (and supposedly) switched to the Euro version - I'm wondering if that would make any difference?

    But then there is no trouble with Live ID accounts from the U.K. which is just more confusing...


    • Edited by Jardee Friday, November 09, 2012 10:46 AM More info
    Friday, November 09, 2012 10:30 AM
  • What is your app ID on the UK instance? We can take a look at what is going on in terms of the location settings.
    Saturday, November 10, 2012 5:30 PM
  • Is the ID I mentioned above ( 5768c176-fddd-40bf-afd2-d8edd2bdd419 ) definitely a US one? Certainly something odd going on at this end if it is as we're supposed to be using the UK/Euro one.

    Copying the application ID from that shown in config.healthvault-ppe.co.uk gives the above ID, so that's what is being used in our web.config.


    • Edited by Jardee Friday, November 16, 2012 2:36 PM
    Friday, November 16, 2012 2:31 PM