none
How To Run Service in Debug Mode

    Question

  • Hi,

     

    Perhaps this is a silly question, but I never could figure it out. How do I set breakpoints and debug a service? I can't start the service with the "debug" button because it tells me there is no entry point. I assume there is a way to do this, and it'd be very helpful.

     

    Thanks,

    Don

    Tuesday, December 04, 2007 7:24 PM

Answers

  • In Visual Studio select the project properties. Go to the 'Debug' page and specify the

    external program to run (dsshost.exe) and its command line args (/h:50000 /t:50001 /c:<contract of your service>) You should then be able to F5 (run from VS) your service any breakpoints that you set should be hit.

     

    dssnewservcice will create those project settings for you.

     

    Alternatively you can attach the VS debugger to a running dsshost process (Debug -> Attach to process...)

     

    Hope this helps,

     

    Andreas

    Wednesday, December 05, 2007 12:23 AM

All replies

  • In Visual Studio select the project properties. Go to the 'Debug' page and specify the

    external program to run (dsshost.exe) and its command line args (/h:50000 /t:50001 /c:<contract of your service>) You should then be able to F5 (run from VS) your service any breakpoints that you set should be hit.

     

    dssnewservcice will create those project settings for you.

     

    Alternatively you can attach the VS debugger to a running dsshost process (Debug -> Attach to process...)

     

    Hope this helps,

     

    Andreas

    Wednesday, December 05, 2007 12:23 AM
  • Hmm yes, ok that works. Thanks!

     

    Now is it possible to startup multiple Dssnodes in a single debug session using the first option you mentioned, and have different manifests for each node? That'd be super.

     

    -Don

    Wednesday, December 05, 2007 1:28 AM
  • You can do this by starting multiple versions of VS, each starting their node in debug mode.

     

    Henrik
    Wednesday, December 05, 2007 5:17 PM