none
Authentication Exception while running UCMA AudioVideo Call Sample

    Question

  • Hi ,

    I am running a sample application AVCall given in UCMA 3.0 Samples .  I am getting authentication Exception. I have been giving the parameters of FQDN ,2 Users (sip:user@domain.com) ,password and domain but no luck . 

    I have created a Trusted Application Pool on the server and verified my server on which i am running the UCMA sample is added on the servers Trusted Application Pool 

    The error message i see on console is : 

    The log on was denied. Check that the proper credentials are being used and the
    account is active. (Verified this as i am able to login to lync client in same server using the credentials i am giving)

    The stack trace i get is : 

       at Microsoft.Rtc.Signaling.SipAsyncResult`1.ThrowIfFailed()
       at Microsoft.Rtc.Collaboration.LocalEndpoint.EndEstablish(IAsyncResult result)
       at Microsoft.Rtc.Collaboration.Sample.Common.UCMASampleHelper.EndEndpointEstablish(IAsyncResult ar) in C:\Srini\Sample Applications\QuickStarts\Common\UCMASampleHelper.cs:line 760
       at Microsoft.Rtc.Signaling.WorkitemQueue.ProcessItems()
       at Microsoft.Rtc.Signaling.SerializationQueue`1.ResumeProcessing()
       at Microsoft.Rtc.Signaling.SerializationQueue`1.ResumeProcessingCallback(Object state)
       at Microsoft.Rtc.Signaling.QueueWorkItemState.ExecuteWrappedMethod(WaitCallback method, Object state)

    Can anyone please let me know where i am doing a mistake ..


    Regards, SL

    Wednesday, December 25, 2013 10:41 AM

Answers

  • I know you said that you have tried to log on as the user's you have using the Lync client and it works, but I just wanted to dig into that a bit more:

    - When you try to log on using the Lync client, did you change the server name using Manual Configuration? (Tools > Options > Personal > Advanced). You should do this and change it to the FQDN you have, because this is how the application is going to be trying to connect. You should also try signing in from the machine running your application, if possible, to find any certificate or network issues.

    - Assuming you have autodiscovery, you could actually change the sample code - you can call new UserEndpointSettings with just a sip address, you don't have to have the FQDN. Check the overloads.

    - Are you signing in using the Lync 2010 client, not the 2013 client. You should check that's OK, in case your users have been homed to only 2013.

    Hope this helps.


    Tom Morgan Developing Lync

    Friday, March 21, 2014 10:29 AM

All replies

  • I have tried to modify the CollaborationPlatform.AllowedAuthenticationProtocol. to Ntlm ..but still gettting the same issue (This i got to see from one of the forum which i felt was a similar issue )


    Regards, SL

    Wednesday, December 25, 2013 10:43 AM
  • Hi  ,

    Can some one look in to this issue ...I am still not able to resolve this ...

    Thanks in advance.


    Regards, SL

    Thursday, January 02, 2014 5:07 AM
  • Hi,

    Thank you for posting, I am sorry no one has answered you yet - it gets a bit quiet around here at Christmas / New year time. A member of the community will answer your query shortly.

    If you have not already then please use the search feature to check your question has not already be asked, and answered, previously.

    Allen Smith

    Program Manager

    Lync Partner Engagement Team

    Thursday, January 02, 2014 10:12 PM
  • Thankyou Allen .. I am trying to see if i can resolve ..but still no breakthrough yet ..



    Regards, SL

    Monday, January 06, 2014 6:44 AM
  • Hi ,

    Can anyone look in to this issue ..



    Regards, SL

    Wednesday, January 15, 2014 6:26 AM
  • I'll try to draw someone's attention to this. Thanks for the nudge.
    Wednesday, January 15, 2014 3:27 PM
  • Thankyou ...


    Regards, SL


    Wednesday, January 15, 2014 4:38 PM
  • There may be more information (error codes) in the exception or inner exception that may help diagnose this.

    If you can include any additional information in the exception that may help narrow down the issue.

    I assume you have already checked that there is no typing errors in your username/password (with the application) and the account is active.

    This is most likely a configuration problem and its a matter of narrowing down the issue.

    Thanks,

    Niko


    Posting is provided "AS IS" with no warranties, and confers no rights. If you found this post helpful, please click "Vote as Helpful"

    Monday, March 10, 2014 4:37 PM
  • Only make sure that you entered all the following information corrcetly

    < add key=”applicationName” value=”yourApplicationName”/ >
    < add key=”gruu” value=” < your trusted application’s gruu you get it after creating the trusted application on powershell> ”/ >
    < add key=”listeningPort” value=” < your trusted application’s listening port > ”/ >
    < add key=”contactUri” value=” < contact uri for your application which must be a free uri using it when creating the trusted application endpoint > ”/ >
    < add key=”proxyServerFqdn” value=” < CS server FQDN > ”/ >


    Thanks,
    MOHAMED SAKR | Software Architect | Unified Communications | Vytru - EgyptNetwork
    Please remember to click “Mark as Answer” on the post that helps you. This can be beneficial to other community members. Also try to Vote as Helpful

    Tuesday, March 11, 2014 7:40 AM
  • I know you said that you have tried to log on as the user's you have using the Lync client and it works, but I just wanted to dig into that a bit more:

    - When you try to log on using the Lync client, did you change the server name using Manual Configuration? (Tools > Options > Personal > Advanced). You should do this and change it to the FQDN you have, because this is how the application is going to be trying to connect. You should also try signing in from the machine running your application, if possible, to find any certificate or network issues.

    - Assuming you have autodiscovery, you could actually change the sample code - you can call new UserEndpointSettings with just a sip address, you don't have to have the FQDN. Check the overloads.

    - Are you signing in using the Lync 2010 client, not the 2013 client. You should check that's OK, in case your users have been homed to only 2013.

    Hope this helps.


    Tom Morgan Developing Lync

    Friday, March 21, 2014 10:29 AM