none
Send an email to the "E-Mail Sender"

    Question

  • I'm try to just have a workflow provide an automatic email response when someone sends an email to a particular email enabled list.

    It works fine if I email to "User who created current item" (or if I choose a specific listed user to send to (domain\username)).  However that only works if the email came from someone inside the company.  I want to be able to respond to emails outside the company also. 

    However when I have it evaluate to a specific email address, internal or external to the company, it fails (or even if I don't have it "evaluate to" an address, but specifically type my own internal email address.  So it works if I have it email to my account (domain\myusername), but not when I specifically ask it to go to myusername@domain.com

    When it fails, the workflow setting shows Event Type:  Error; User ID: System Account; Description:  The e-mail message cannot be sent. Make sure the outgoing e-mail settings for the server are configured correctly.

    Any idea why this would happen?

    Thanks!

    Friday, March 30, 2012 3:38 PM

Answers

All replies

  • I would suggest you to check dns records on/for that server. Can you send an email from your SharePoint server to outside world?

    Also, when someone from outside sends you an email with a file, what is the account that creates that record? is it system account?

    Cheers

    Thursday, April 05, 2012 11:52 AM
  • Hi Esad, thank you for your reply.

    When an email comes from an address in our domain, then that user is listed as the one that created the record. But YES, it is the "System Account" that is listed as creating the record when it comes from outside.

    I think this is turning into an exchange question if I understand correctly.  I entered my own internal address as the person to send the email to.  Then I sent the list an email from an external email address.  I thought my previous tests of this type failed.  In this case I DID get an email via the workflow.  However when I look at the email, the TO: address shows as "SHAREPOINT\system" which I thought was strange. 

    However when I set the workflow to email a specific external email address and do the same test it fails with the error originally noted.

    In the Sharepoint Central Manager outbound email settings, I specify my Exchange 2010 server.  So I'm expecting that what is really going on here is that I somehow have to provide authorization within Exchange for mail generated from my Sharepoint server to go through.  And this sounds like it should be easy, but this is the hard part about being the master of nothing. 

    Anyone see a quick answer here?

    Thanks!

    Wednesday, April 11, 2012 4:13 PM
  • OK this turned out to be my exchange server not allowing it through because the sharepoint system account was not authenticating.  Probably a number of ways to solve but I just created a receive connector.  Link to the instructions are found in this post:  http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/2067699d-88d3-4d2c-b297-32cb7dfba349/

    I followed these instructions:  http://blogs.technet.com/b/exchange/archive/2006/12/28/3397620.aspx

    • Marked as answer by tmiller112 Wednesday, April 11, 2012 6:15 PM
    Wednesday, April 11, 2012 6:14 PM
  • Glad you solved it.

    Cheers,

    Wednesday, April 11, 2012 6:43 PM