none
caracteres especiais

    Question

  • olá a todos, num webform em que carrego uma dropdown e depois faço o seguinte:

    ListBoxVersao.Items.Insert(0, "Seleccione uma Versão")
    ListBoxVersao.SelectedIndex = 0

    a palavra versão aparece bem escrita.mas num outro projecto a palavra série aparece de maneira esquisita, eu no ficheiro ficheiro aspx em que tenho uma label, coloquei o seguinte: é e desse modo ficou bem, mas a partir do code behind quando coloco as instruções anteriores a "palavra" á nao é reconhecida e aparece tal e qual em vez de aparecer o acento no caracter é.como dar a volta a este problema?e porque é que num projecto nao preciso de colocar estas instruções para aparecer o ~ no a de versão por exemplo e noutro ja tenho de colocar?
    Sunday, April 05, 2009 8:50 PM

All replies

  • Boas,

    Já tentou verificar no web.config da sua aplicação como está a codificação de caracteres no elemento <globalization />?
    http://www.projetando.net
    Monday, April 06, 2009 11:01 AM
    Moderator
  • boas Israel,eu estou a trabalhar num projecto que nao foi desenvolvido na empresa onde trabalho, mas cabe -me a mim desenvolver novas funcionalidades.no web.config verifiquei  que estava o seguinte:
    <globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="en-US" uiCulture="en-US"/>
    e tinha tambem a meta tag:
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">.decidi comentar a meta tag e pronto, as palavras acentuadas já aparecem bem nao sei que impicações tem comentar isso mas para agora fica assim.
    Tuesday, April 07, 2009 7:46 PM