locked
Smooth Sprite Animation (was Smooth Movement)

    General discussion

  • I want to revive some of the discussions originally started on this thread:
    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=691811&SiteID=1

    I too have implemented a simple ball bouncing around the screen. This ball movement was jerky with the default settings (IsFixedStep = true).

    Changing SynchonizeWithVerticalRetrace and IsFullScreen had no affect.

    • I found that setting IsFixedStep = false makes the animation smooth (~350fps). 
    • Setting IsFixedStep = true and changing the refresh rate of my monitor to 60hz makes the animation smooth. 
    • Setting IsFixedStep = false, TargetElapsedTime to 72fps and changing the refresh rate of my monitor to 72hz (the max, it's an old monitor) makes the animation smooth.

    This leads me to believe that there is some weird interaction going on with the fixed step settings and the refresh rate of the monitor. Perhaps this only shows up on older monitors or specific refresh rates?

    Any thoughts here?

    - Stephen Jones

    Wednesday, September 27, 2006 4:13 AM

All replies

  • Can you please file a Connect bug and attach a simple repro?
    Wednesday, September 27, 2006 7:36 AM
  • Well, obviously you are going to get the smoothest motion if your refresh rate is the same as your animation rate. The interaction you are talking about is called temporal aliasing.
    Wednesday, September 27, 2006 10:51 AM