none
blank rows on "sub rows" in an SSRS report

    Question

  • I have a report with three rows in it.  The first row is working fine.  It has a "sub group" within the row group and it all works fine. However, on row two and three, I have two row groupings that are of course included in the entire "major" group of all three rows.  The second row is displaying risks associated with the project (project server) and the third row displays issues.  Here is my problem.  All of this works fine BUT row two and three always have a blank row within the sub group no matter what.  If issues and risks are on the project they display BUT always with a blank row on top.  If no issues or risks are on the project, again, always a blank row displays for both issues and risks.  What am I doing wrong?  I really need these blank rows to not display.

    Cletus51

    Monday, November 11, 2013 6:27 PM

Answers

  • Hi Cletus51,

    From the description, I understand that there should be parent-child group in your report. However, there will be extra blank row shown when previewing the report. Here, I want to confirm whether you have added Group Header or Group Footer. If you check the options of “Add group header” or “Add group footer” when adding parent group, we will see the blank rows. In this case, the report design looks like the screenshot below:


    For the second reply you post, I understand that you want to add a subreport to the tablix, right? For further analysis, please post the report design’s screenshot to the forum.

    Regards,
    Heidi Duan


    Heidi Duan
    TechNet Community Support

    Monday, November 18, 2013 6:45 AM
    Moderator

All replies

  • Unless you show us an indicative file we cant understand whats happening. Check in design view whether you've included header row for any of the subgroupings.
    Monday, November 11, 2013 6:34 PM
  • forgive my "rookiness" on SSRS...  I have looked and do not see anywhere I have added a header.  Now, when I created the rows inside the column on the second and third row, I inserted a table.  I think deleted the header row of that table.  That should not cause blank lines should it?


    Cletus51

    Monday, November 11, 2013 7:17 PM
  • Hi Cletus51,

    From the description, I understand that there should be parent-child group in your report. However, there will be extra blank row shown when previewing the report. Here, I want to confirm whether you have added Group Header or Group Footer. If you check the options of “Add group header” or “Add group footer” when adding parent group, we will see the blank rows. In this case, the report design looks like the screenshot below:


    For the second reply you post, I understand that you want to add a subreport to the tablix, right? For further analysis, please post the report design’s screenshot to the forum.

    Regards,
    Heidi Duan


    Heidi Duan
    TechNet Community Support

    Monday, November 18, 2013 6:45 AM
    Moderator