locked
How to disable the builtin spelling checker? (MsSpellCheckingFacility.exe)

    Question

  • Whenever I type something in Facebook the response is very laggy / sluggish. All my (dutch) words are underlined with red because Windows doesn't recognize them. I think the builtin spelling checker is responsible for this, because this process appears in Task Manager after I start typing > MsSpellCheckingFacility.exe

    How can I disable this behaviour?

    Thursday, September 15, 2011 11:09 AM

Answers

  • Hello Roel,

    I have a 32-bit computer and when I go to the General settings, I do have the Spelling information.
    I think it has more to do with the language settings than with whether your computer is 32bit or 64bit.

    I haven't tested this, but you might try changing your time zone and see of you get the spelling settings back. "
    Then disable it.
    Then change back to the correct Time zone.

    Let us know if this helps.


    Marilyn
    Friday, September 23, 2011 1:53 AM
    Moderator
  • You can try and rename the MsSpellCheckFacility.exe to MsSpellCheckFacilityold.exe and it would not execute.
    However, it would affect all spell check when working with the Operating System.

    Thanks,
    Marilyn
    Sunday, September 25, 2011 6:11 PM
    Moderator
  • Great minds think alike Marilyn ;-)

    That was the only other option I could imagine so I've already renamed the file and now it works! When typing into Facebook my words aren't spell-checked but I don't care, I 'never' make typos.

    Monday, September 26, 2011 6:26 AM

All replies

  • Hello, I'm a Belgian so I share your language. And I've had the same Facebook problem.
    Open up the Metro UI -> Click on your user thing in the right top corner & choose "Change user tile"
    Then go to General and in the spelling options, disable spell checking.

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Thursday, September 15, 2011 4:19 PM
  • What version of Windows 8 are you running, x64 or x86? I don't have that option in x86.

    Friday, September 16, 2011 5:51 AM
  • My windows is 64-bit; are you maybe running a touchscreen keyboard?


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Friday, September 16, 2011 11:01 AM
  • I have just a regular Dell laptop.

    Friday, September 16, 2011 3:01 PM
  • Hello Roel,

    I have a 32-bit computer and when I go to the General settings, I do have the Spelling information.
    I think it has more to do with the language settings than with whether your computer is 32bit or 64bit.

    I haven't tested this, but you might try changing your time zone and see of you get the spelling settings back. "
    Then disable it.
    Then change back to the correct Time zone.

    Let us know if this helps.


    Marilyn
    Friday, September 23, 2011 1:53 AM
    Moderator
  • Nice one Marilyn, after changing all regional and language things to English (United States)  and no other languages and rebooting afterwards the Spell Check option was there!

    I disabled both spell check settings but Internet Explorer keeps on checking my spelling when I type and MsSpellCheckFacility is still visible in Task Manager.

     

    Friday, September 23, 2011 6:45 AM
  • You can try and rename the MsSpellCheckFacility.exe to MsSpellCheckFacilityold.exe and it would not execute.
    However, it would affect all spell check when working with the Operating System.

    Thanks,
    Marilyn
    Sunday, September 25, 2011 6:11 PM
    Moderator
  • Great minds think alike Marilyn ;-)

    That was the only other option I could imagine so I've already renamed the file and now it works! When typing into Facebook my words aren't spell-checked but I don't care, I 'never' make typos.

    Monday, September 26, 2011 6:26 AM