locked
An error has occurred during report processing. (rsProcessingAborted)

    Question

  • Hello,
    I created a team project (TFS beta 3 refresh) and all reports where correctly created. When I try to run them I get the following error message:

    • An error has occurred during report processing. (rsProcessingAborted)
      • Cannot impersonate user for data source 'TfsOlapReportDS'. (rsErrorImpersonatingUser)
        • Logon failed. (rsLogonFailed)
          • For more information about this error navigate to the report server on the local server machine, or enable remote errors

    From datasource setting I am using domain\TFSREPORTS credentials which seems correctly defined into the DB.

    What can I do ?

    Thanks,
    Pierre

    Friday, December 16, 2005 4:07 PM

Answers

  • I've fixed it making the TFSREPORTS account Administrator of the Data Tier Server.
    It's an awfull resolution but it works, could you solved it using another nicer way?
    Tuesday, December 27, 2005 6:13 PM

All replies

  • I've fixed it making the TFSREPORTS account Administrator of the Data Tier Server.
    It's an awfull resolution but it works, could you solved it using another nicer way?
    Tuesday, December 27, 2005 6:13 PM
  • Same issue occured to me and did the same thing to get it to work.
    Friday, December 30, 2005 9:22 PM
  • Has the user who is trying to access the reports been added to the "Content Managers" role on the Report Server? 

    You can add users to this role by doing the following:

    1. Navigate to http://<InsertReportServerHere>/Reports

    2. Click on the "properties" tab

    3. Click on "New Role Assignment"

    4. Add the appropriate group or user, and select "Content Manager"

    5. Click OK

    Monday, January 23, 2006 10:02 PM
  •  

    I also face the same problem .. could u tell me how do i go about to make the TFSREPORTS as the account administrator of Data tier server ..

    I'm new to this ..  

    Wednesday, May 17, 2006 7:34 AM
  •  

    hi alan ..

    the method u told is not working .. even thogh i made the changes as said .. i get the same error again .. what else could be the problem ...

    Wednesday, May 17, 2006 7:36 AM
  • hi, I also met the same problem, I had solved it by granting for account

    which currently report server used has Admin permission.

    please let me know you still not solved it. 

    Friday, May 19, 2006 6:20 AM
  • I have solved it earlier .. but there was a problem in the machine and I had to do a reinstall .. everything. I reinstalled sql server 2005, sharepoint, tfs ... etc. I was able to connect and then create a Team project ... but alas .. the reports was not available. An error has occurred during report processing. (rsProcessingAborted) .. comes on the reports window ...

    I have tried all the possibilities that is mentioned above .. i could not solve it .. I couldnt figure it out .. what the problem is ...

    pls let me know on this .. i'm just going crazy on this ...

    thanx

     

    • An error has occurred during report processing. (rsProcessingAborted)
      • Query execution failed for data set 'dsIterationParam'. (rsErrorExecutingCommand)
        • For more information about this error navigate to the report server on the local server machine, or enable remote errors

     

    Friday, July 14, 2006 2:01 PM
  • If after a day you're still seeing this, it seems likely that the warehouse processing has a problem.  See this related thread.

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=124011&SiteID=1

    Sunday, July 16, 2006 2:59 AM
    Moderator
  • I am seeing the same error but for projects that have been in existence for quite a while. I have been able to run reports in the past without any problems. What could have caused the problem?
    I've tried re-starting the SQL reporting services on the Application tier (we have a 2 server installation of team system). I've tried granting administrator rights to the tfsreports account on the data tier.

    Any thoughts would be much appreciated.

    Wednesday, July 19, 2006 11:11 PM
  • By adding the TFS Reports user account to Content Managers it resolved my issue. I did not have to elevate the privileges for the TFS Reports user account on the local machine. Hope this helps....
    Tuesday, August 08, 2006 11:57 AM
  • The solution worked... but the wierd thing is I had everything working before I did the reinstall of TFS and only then I had this problem
    Wednesday, February 28, 2007 9:02 PM
  • in my case MOM DAS password changed, so i had to change it also from report web site => SCDW and from reporting service configration
    Sunday, May 20, 2007 8:56 AM
  • In our case the error turned out to be a missing permission on the reporting services user account. The reporting services account requires "Log On Locally" on the tier running reporting services. Adding the user to the administrators group also grants this permission, which could explain why that change also resolves the problem. As a side note our install was on Windows 2003 Server RC2.
    Thursday, May 24, 2007 10:11 PM
  •  

    Go to report data source e.g (Project Data Source)

    Select (Credentials stored securely in the report server)
    Put Domain administrative account like domain\user which exist in database as well
    and password
    and check  (Use a windows credentials when connecting to the data source) and apply it

    Sunday, June 22, 2008 9:35 AM
  • Yes, even if the user is assigend to Content Manager role, i am getting the same error??

    An error has occurred during report processing. (rsProcessingAborted)
    Cannot create a connection to data source 'ExchangeTest'. (rsErrorOpeningConnection)
    For more information about this error navigate to the report server on the local server machine, or enable remote errors
    Wednesday, October 21, 2009 7:14 AM
  • Hi Joe,

    Can you please explain how can i achieve this?

    And the account that you are talking about, is it the SQL Reporting Service Windows Service account??

    Please advice!
    Wednesday, October 21, 2009 7:15 AM
  • Hello All,

    for me, this issue was resolved by adding the User Mapping to the database to which the Datasource was referring to.
    • Proposed as answer by RubSay Wednesday, October 21, 2009 9:12 AM
    Wednesday, October 21, 2009 9:12 AM
  • Hi, RubSay!

    Can you give some details please how you added the user Mapping to the database to which the datasource was referring to.

    this is details of my problem 
    http://sql-server-performance.com/Community/forums/p/30816/161192.aspx

    If the datasource and report server are located on the same machine, there is no plroblem at all to run and preview our reports, but if I like to use different server for datasource then I have error message.

    Thanks!
    Thursday, November 12, 2009 7:54 PM
  • hi...

    Adding USer Mapping:
    I Mgt Studio. Add the user as a Login.
    then Click Properties and navigate to User Mappings page
    Put a check mark on the Database that the report is trying to access (apart from ReportServer and ReportServerTempDB)

    Give it a try!
    Sunday, November 15, 2009 7:00 AM
  • Hi!

    Thank you for a reply!

    While I was waiting for a reply, I did it by myself on the last Friday (nov 13). Yes, this works only for the case when the datasourse and ReportServer are on the same server, but doesn't for the case when there 2 servers involved. To solve the problem we need to create an anonymous user, but this is dengereous...  

    http://technet.microsoft.com/en-us/library/bb283249.aspx


    Thanks again!
    • Proposed as answer by jenny2009 Wednesday, January 20, 2010 12:45 AM
    Monday, November 16, 2009 5:39 PM
  • Sunday, December 13, 2009 2:54 PM
  • The solution is:

    1- Open the VS project.
    2- Double Click on the DataSource (TfsOlapReportDS).
    3- Shared Data Source Dialog box will open.
    4- Click on Credintials tab.
    5- Make sure that the User Name and Password are correct, and the user is a Database user with Admin previligies on the database.
    6- Re-Deploy the Data source, by Right click on the Data source and choose Deploy.

    It worked with me.

    Regards,
    Saed Shaar

    • Proposed as answer by saedshaar Sunday, February 20, 2011 4:58 AM
    Sunday, February 20, 2011 4:58 AM