locked
HOW-TO Dual Installation, dual network cards

    Question

  •  

    Hi all,

    I have a problem regarding a Dual Server configuration.

    Both servers have dual network cards and I have connected Interface 2 on both servers to each other directly.
    And the 1: st interface on each server goes to the same "public" network / switch.

    The installation went fine, but I wanted to make sure that the traffic between AT server and DT server went 
    through Interface 2 on the server (which is Gigabit speed). So I disabled Interface 1 on the DT server.
    And then sharepoint and report server (http://servername/  and http://servername/reports/) could not access the Database server.

     

    In AT server's host file I have entered the "private" network ip of the DT server (which should go through Interface 2).
    And I can Ping it and connect to it from Management Studio from AT server.

     

    Now I'm guessing that somewhere in TFS, it's querying the DNS server to get the IP
    and of course it returns the "public" network IP which is the IP of interface 1 on the DT Server.

    Does anyone have any suggestions on how to solve this ?
    I had a thought that when I was installing, I should have used the IP of the DT server instead of machine name.
    But the installation documents said that you should only enter the machine name..

    Any help is greatly appriciated.

    Best regards
    Tobias Johansson

    Monday, October 22, 2007 1:53 PM

Answers

  • You will not be able to disable the NIC on the DT server as it will cause all the DC/AD requests from it to fail.  TCP/IP name resolution order could also be the issue see kb172218.

     

    You could also try using the Microsoft Network Monitor tool to see which adapter is getting the DT traffic, here is a quick how to.

     

    Wes

    Thursday, November 01, 2007 11:58 AM

All replies

  • SharePoint and SQL Server Reporting Services (SSRS) are configured to use the DT name that is specified when running TFS setup on the application tier machine.  I'm not quite sure that I see how TFS itself is not having a problem resolving the public name for the dual-homed DT in your configuration.  In the absence of the hosts file entry, is the only access to the DT over the private gigabit network through the IP?

     

    One option that would probably work for you is to just step in front of the public DT name that you used during the TFS AT install using a SQL client alias.  On the TFS AT, bring up the SQL Server Configuration Manager, open SQL Native Client Configuration and add an Alias with an Alias Name that matches the DNS name of the DT server and specify the private IP address in the Server field. 

    Wednesday, October 24, 2007 5:06 PM
  •  

    Hi Bill,

    Thank you for your reply.


    It's not having a problem resolving the public IP for it since it's in the DNS,
    But if I disable the interface 1 (IF 1) on the DT server, SSRS stops working (Can't connect to report database)

    I don't know if there may be some kind of Active Directory authentication mechanism that needs the IF 1 on the DT server.
    All I want to do is make sure that the Database traffic goes through IF 2 (which is directly connected to the DT server)

     

     

    However i will try you solution with the Alias on saturday.

    Btw. is there a way to attach images to a post in this forum ?
    I have a image that would explain how TFS is set up in our enviroment...

     


    regards
    Tobias

    Friday, October 26, 2007 3:00 PM
  • You will not be able to disable the NIC on the DT server as it will cause all the DC/AD requests from it to fail.  TCP/IP name resolution order could also be the issue see kb172218.

     

    You could also try using the Microsoft Network Monitor tool to see which adapter is getting the DT traffic, here is a quick how to.

     

    Wes

    Thursday, November 01, 2007 11:58 AM
  • Tobias - I don't think there is a way to post images to the forum.  If the suggestions made so far do not help you to resolve the problem, please just contact me directly by clicking on my display name to get my e-mail alias (remove 'nospam').

     

     

    Monday, November 05, 2007 8:09 PM
  • Hi Wes and Bill,

    Thank you for your answers.

    Wes, I tried your tip about the network monitor, and it seems that you were right.
    There is network traffic on interface 2 with destination port 1433 (which is SQL).

    So I guess that confirmed that my setup is the way I want it.

    Thank you both for helping me out !


    Best regards
    Tobias

     

    Tuesday, November 06, 2007 9:45 AM