none
How to Deploy the SSRS project from BIDS? I can't able to connect the URL as well via the browser & sql server management studio. But i can see the report configuration manager under data tools and able to open that and all.

    Question

  • I can't able to deploy the some basic sample ssrs report. while i am deploying i am getting the Remote server cannot find error alone. 

    Dhinesh Kumar,

    Thursday, June 20, 2013 4:07 PM

Answers

  • Hello All,

    Thanks for all your reply. Finally i found one solution to change the config file that worked for me to deploy my solution to the report server and also the report server URL is working fine after that http://localhost/ReportServer . 
    I changed the config file setting
    rsreportserver.config
    the property i changed is
            <Add Key="SecureConnectionLevel" Value="2"/> into
            <Add Key="SecureConnectionLevel" Value="0"/>


    Dhinesh Kumar,

    Wednesday, June 26, 2013 10:16 AM

All replies

  • If you have build your SSRS project the go to project and right click->Properties->click on configuration manager->check on Deploy

    Also before deploying the project need to configure reporting Services

    and also set TargetServerURL - http://servername/ReportServer

    Thursday, June 20, 2013 5:37 PM
  • Are you able to connect to the Report Server URL or the Report Folder where you need to deploy the report, if not you should required permission on that first and after that please follow the instructions below for deploying the reports:

    1. Right click on Report Project under BIDS
    2. Click on Properties
    3. Set OverwriteDatasources to true, if you want to overwrite the datasource everytime when you deploy the project/report
    4. Set TargetServerURL
    5. Set TargetReportFolder and click OK.
    6. Right click on the ReportProject and Click Deploy

    Find some instruction in below link for configuringing the deployment properties

    http://msdn.microsoft.com/en-us/library/ms155802.aspx

    Cheers,


    Amar Deep Singh

    Thursday, June 20, 2013 11:29 PM
  • Hi Dhinesh Kumar,

    Try this link - http://sathyadb.blogspot.in/2013/02/ssrs-report-deployment.html


    sathya --------- Mark as answered if my post solved your problem and Vote as helpful if my post was useful.

    Friday, June 21, 2013 3:30 AM
    Moderator
  • Hi Sathya,

         i am done the same step as what you said upto the deploy step. But the deployment is not successful, the below mentioned error coming, Also i tried to go to the below mentioned URL in my browser it didn't work.

    


    Dhinesh Kumar,

    Friday, June 21, 2013 6:03 AM
  • Hi,

    both the URL is not worked for me. cannot find the page only i am getting in the IE page. As you said if it's permission issues then how come i can avoid that. thanks for your reply.


    Dhinesh Kumar,

    Friday, June 21, 2013 6:08 AM
  • Hi Dhinesh,

    From the screenshot, the report server runs on a remote server. First, make sure the report server is already configured and working properly, the issue occurs due to the factor that the current user doesn’t have sufficient permissions on the report server to browse or deploy a report. If you are the administrator on the server that hosts the report server, please log onto that computer using an administrator account, and then assign both System-level and Item-level permissions to the current user referring to the following document:
    Grant User Access to a Report Server (Report Manager)

    Since the user needs to deploy reports to the report server, you need to assign Publisher or Content Manager Role to the user to perform the deploying operation. Of course, you can create a custom role.

    Regards,


    Mike Yin
    TechNet Community Support

    Saturday, June 22, 2013 8:04 AM
    Moderator
  • Hi Mike,

             Thanks for your reply. But this is my local stand alone SQL server only. How do we can identify that it's remote server. Is that i should re install my SQL 2012?. And one more thing i can't able to connect my reporting servies via this as well. I can only able to connect this Reporting Services Configuration Manager, Also in this my web service URL mentioned as http://Kumarjad1/ReportServer alone but i can't able to connect this as well via IE. I added this as in my trusted site. 

     


    Dhinesh Kumar,


    Saturday, June 22, 2013 4:47 PM
  • Hi Dhinesh,

    Thanks for your posting.

    Is it a default instance or a named instance of SSRS? If it is a named instance, you need to type KUMARJAD1\<InstanceName> in the Server name box when connecting to Reporting Services type through SSMS. If the issue persists, please post the error message thrown by SSMS.
    Besides, please open the Reporting Services Configuration Manager, and check whether the report server is configured properly. For example, click the Database tab, and make sure the SSRS instance has connect to a report server database. For more information about configuring SSRS, please see:
    Create a Native Mode Report Server Database (Reporting Services)

    After that, add http://KUMARJAD1 to the trusted site of Internet Explore. Then, launch the IE as administrator, and browse the report server web service URL again. If any error occurs, please post the error details.

    Regards,


    Mike Yin
    TechNet Community Support

    Sunday, June 23, 2013 1:33 AM
    Moderator
  • Hi Mike,

        It's a default instance alone i didn't create any named instances. Here is the error i am getting through SSMS

    And In the Report server configuration manager has connected to the ReportServer database as in default you can see in the below pic.


    Dhinesh Kumar,

    Sunday, June 23, 2013 2:29 AM
  • Hi Dhinesh,

    Thanks for your posting.

    The error message thrown by SSMS can be caused by various reasons. Please try the following suggestions:

    • If you use a domain account for the Service Account of Reporting Services, please ensure you use the Domain\User format instead of user@domain.com format.
    • If you use proxy of Internet Explorer, please disable the proxy or check the “Bypass proxy server for local address” option. To do this, open IE-> Internet options-> Connections-> Lan settings.
    • If you enable SSL connection for the report server and the HTTPS connection is not configured properly or the certificate doesn’t recognize the server name, the issue may occur. If it is the case, remove the certificate from the Reporting Services Configuration Manager.

    Additionally, from this thread, rebooting the machine might resolve the issue.

    Regards,


    Mike Yin
    TechNet Community Support

    Sunday, June 23, 2013 3:09 AM
    Moderator
  • Are you running Visual Studio as Administrator?

    You may need to set up IE with elevated permissions. If the  target URL of the report server is correct and the report 's folder is entered correctly then you should have no problems. If your data source is shared then you should deploy the data source first. if your report server is a named instance it's url is, http://servername/ReportServer_InstanceName. Also you should verify that you can access the report server from Reporting Services Configuration Manager.


    mysorian

    Wednesday, June 26, 2013 3:27 AM
    Answerer
  • Hi Krishnaswamy,

                 my SQL server is default instance alone. I can see http://kumarjad1/ReportServer in the Report services configuration manager in the web service URL section.  So this itself explains i can able to access the report server via Configuration manager i guess. i am giving the same URL in the visual studio to deploy my .rdl file it throws the above(previous post) mentioned error from VS. i tried to access the URL with admin right in IE as well as VS. nothing worked. also i Restart the services many time no use in that.  Is it i should need to re install the SQL server again, then also what should i do with the installation step to achieve this


    Dhinesh Kumar,

    Wednesday, June 26, 2013 4:53 AM
  • Check your Report server Database Credential in Configuration Manager. 

    Try NT Service\Report Server


    mysorian

    Wednesday, June 26, 2013 9:31 AM
    Answerer
  • Hello All,

    Thanks for all your reply. Finally i found one solution to change the config file that worked for me to deploy my solution to the report server and also the report server URL is working fine after that http://localhost/ReportServer . 
    I changed the config file setting
    rsreportserver.config
    the property i changed is
            <Add Key="SecureConnectionLevel" Value="2"/> into
            <Add Key="SecureConnectionLevel" Value="0"/>


    Dhinesh Kumar,

    Wednesday, June 26, 2013 10:16 AM
  • Hi Dhinesh,

    Glad to hear that you have resolved the issue by yourself. Thanks for your valuable sharing.

    Based on your solution, the issue occurs due to the improper SecureConnectionLevel key setting in the RSreportserverconfig file. The SecureConnectionLevel key specifies the degree of security of the Web service connection: a value of greater than or equal to 1 indicates that SSL is turned on, and value 0 indicates that SSL is turned off. Since the SSL encrypted connection is not enabled in your scenario, the SecureConnectionLevel key should be set to 0.

    Reference:
    http://msdn.microsoft.com/en-us/library/ms160346.aspx

    Regards,


    Mike Yin
    TechNet Community Support

    Thursday, June 27, 2013 1:33 AM
    Moderator