none
Impressão em Argox OS 214

    Question

  • Olá...

    Sei que já tem tópicos semelhante mas não tem solução.

    Estou testando uma impressora Argox OS 214, já instalei vários drivers e imprimo somente pelo windows(pagina de teste), mas quando vou imprimir via comando não faz nada, já tentei com PrintDocument e ela só ejeta a folha em branco, via dos direto na LPT1 não faz nada e já testei a porta lpt1 e imprime na LX300 normal. Alguém tem idéia o pode ser?


    Alexander
    Tuesday, November 30, 2010 4:40 PM

Answers

  • Carlos...

    O problema é que faltava um caracter especial (ALT + 002), deu certo assim:

    (ALT + 002)L
    D11
    125200001000100Teste
    E
    (ALT + 002)r


    Alexander
    Thursday, December 02, 2010 11:39 AM

All replies

  • Alexander,

    A impressora Argox trabalha em dos modos: PPLA e PPLB, veja em qual modo sua impressora está e em qual você está enviando os comandos.

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    Tuesday, November 30, 2010 5:04 PM
  • Carlos instalei o driver da PPLA, mas quando mando pelo codigo c# eu uso PrintDocument e não mando nada em modo PPLA, vc tm outra maneira de fazer?

    Alexander
    Tuesday, November 30, 2010 5:15 PM
  • Alexander,

    Aqui na empresa usando tanto a impressão gráfica quanto a direto na paralela. No modo gráfico usamos o StimulReport e o DevExpress XTraReport como uma impressão windows normal. Mas confira se a impressora está no modo correto PPLA/PPLB.

    Se quiser enviar direto para a impressora por PPLA, aqui tem um manual: http://www.argox.com/content.php?sno=0000033&P_ID=15

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    Tuesday, November 30, 2010 6:27 PM
  • Carlos vc poderia me enviar um exemplo de como vc faz para mandar direto pra impressora?

    Aqui apenas instalei o driver, não sei ver se esta PPLA ou PPLB.


    Alexander
    Tuesday, November 30, 2010 6:35 PM
  • Basicamente é assim:

    D11
    121100000650020ABAJOUR MINI C/D
    121100000550020ESENHOS DIVERSOS
    1F2203000120020
    121100000650160ABAJOUR MINI C/D
    121100000550160ESENHOS DIVERSOS
    1F2203000120160
    121100000650301ABAJOUR MINI C/D
    121100000550301ESENHOS DIVERSOS
    1F2203000120301
    E

    Se você enviar isto direto para a porta da impressora pelo prompt, por exemplo, grava isto em um arquivo texto e depois digita no prompt: type teste.txt >lpt1

    Isto envia a etiqueta para a impressora. Dá uma olhada no manual para você entender o que cada linha significa.

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    Tuesday, November 30, 2010 6:43 PM
  • Carlos fiz o teste e não aconteceu nada, não sei o que se passa por que pagina de teste ela imprime, mas direto pela lpt1 não faz nada. Até tentei imprimir via PrintDocument apontando a impressora e tbem não faz nada.

    Alexander
    Tuesday, November 30, 2010 6:54 PM
  • O comando que te enviei é PPLA, se não imprimiui a impressora pode estar em PPLB e neste caso eu não tenho exemplo, pois só trabalho com PPLA. Dê uma olhada no manual e monte um exempo em PPLB para teste.

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    Tuesday, November 30, 2010 6:58 PM
  • Carlos...

    O problema é que faltava um caracter especial (ALT + 002), deu certo assim:

    (ALT + 002)L
    D11
    125200001000100Teste
    E
    (ALT + 002)r


    Alexander
    Thursday, December 02, 2010 11:39 AM
  • Alexander,

    Verdade, eu acabei esquecendo de incluir a primeira linha do arquivo.

    []s,
    Carlos.


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    Thursday, December 02, 2010 11:47 AM