none
Visual Studio 2008 not responding

    Question

  • Hello,

    I just recently got Visual Studio 2008 and upgraded my application from VS2005.  I have CF 3.5 and WM 6.0 SDK on a Windows XP machine with SP2 installed.  Everytime I try to Debug for the second time, VS2008 stops responding.  I have end task and relaunch my project.  I am wasting a lot of time doing this and it is very fustrating.  I have already installed the VS update but to no avail.  Can someone help please?

    Thanks in advance!
    Tuesday, March 10, 2009 4:33 AM

Answers

  • Hi moldau04,
     
    I am afraid maybe platform verification task cause it, Platform Verification Task (PVT) is a post-build validation step to catch the unsupported PMEs before they can result in a runtime exception. Please refer to following issue to disable it.

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=3135615&SiteID=1

     

    Best regards,

    Guang-Ming Bian - MSFT


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    • Marked as answer by moldau04 Monday, March 16, 2009 6:08 AM
    Thursday, March 12, 2009 3:18 AM

All replies

  • Hi moldau04,
     
    I am afraid maybe platform verification task cause it, Platform Verification Task (PVT) is a post-build validation step to catch the unsupported PMEs before they can result in a runtime exception. Please refer to following issue to disable it.

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=3135615&SiteID=1

     

    Best regards,

    Guang-Ming Bian - MSFT


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    • Marked as answer by moldau04 Monday, March 16, 2009 6:08 AM
    Thursday, March 12, 2009 3:18 AM
  •  Hi Guang-Ming Bian,

    Thank you for your reply.  Before I go through the recommended steps I have some questions below.  I look forward to your reply.

    Thanks!
    1. Find Microsoft.CompactFramework.Common.Targets for editing in C:\WINDOWS\Microsoft.NET\Framework\v3.5.   Go to the line which reads:Name="PlatformVerificationTask">
      and change it to:
      Name="PlatformVerificationTask" Condition="'$(SkipPlatformVerification)' != 'true'"> My computer does not recognize the type of this file.  Do I edit the extension to .txt?
    2.  Add the SkipPlatformVerification environment variable to the system and set it to "true" (To re-enable Platform Verification set the environment variable to "false")  How and where do I add the SkipPlatformVerification environment?
       
    3.      Restart Visual Studio for the changes to take effect (If building from the command line using MSBuild, add /pTongue TiedkipPlatformVerification=true to your command line to turn off the task. You can specify the variable in the project file also, so that this information is persisted across sessions).
    Saturday, March 14, 2009 2:24 PM
  • I went through the above steps and it works!!  Thanks again!! In case someone else needs this information.  Here is how you create an environment variable under Systems:

    On XP you can do this by right click My computer-->Properties-->Advanced -->Environment
    Variables --> add your SkipPlatformVerification variable to the System with: true



    Thanks!

    Monday, March 16, 2009 6:08 AM