locked
Could not load file or assembly … The parameter is incorrect … HRESULT: 0x80070057 (E_INVALIDARG)

    Question

  • I've just had my machine upgraded at work. We can't see anything that's changed, except now when I try to build the website project I'm working on (in Visual Studio 2005), I get an error:

    Could not load file or assembly 'uSwitch.Web.UI.Lego, Version=1.0.2405.17351, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))

    The assembly name is the main assembly I'm working on and the version number is the current version created by Visual Studio's autoincrement. The file has correctly been copied to the web project's bin folder and I can open it up in Lutz Roeder's .Net Reflector and see everything I'd expect to see, including recent changes to the codebase.

    I've deleted the version in the .Net cache, inside C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ and that appears to make no difference. I get the same problem when trying to run a web project in either IIS or Cassini (VS2005's in-built webserver), indeed it doesn't get as far as initialising Cassini.

    Google isn't finding me anything useful; does anyone here have any ideas?

    Please copy all replies to owenblacker at uswitch dot com, in case I miss them here.

    Thanks for your help, everyone!


    Owen

    Wednesday, August 02, 2006 2:37 PM

Answers

  • Reinstall .NET? Nah. I didn't even have to clean up the entire Temp Files directory. I deleted the directory C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\MyWebService and recompiled and it worked fine.

     

    I suspect that there is a conflict between compiled code versions that happens here. The web service I was building worked fine until I went to debug some code that I had added. I changed the web.config debug option to 'true' and immediately got the 'parameter is incorrect' error. I suspect that the compiler doesn't rebuild every file when you change just the web.config like it does when you change the Solution Configurations dropdown (up in the menubar).

     

    Just some guesses.

    Wednesday, November 14, 2007 9:20 PM
  •  

    Okay...I've figured out my issue. I'm not for sure why uninstalling and reinstalling worked for people.  Unless, they somehow messed up the web.config in the C:\windows\Microsoft.NET\Framework\v2.05027\Config\ directory.

     

    Background: The assembly causing me trouble was built in house and I did not have the source code.

    Required: You need the Visual Studio SDK for ildasm.exe

     

    Steps:

     

    1.) Disassemble the .dll with the command ildasm.exe AssemblyName.dll /out:AssemblyName.il  

    2.) Open the newly created AssemblyName.il with a text editor and search for "permissionset"

    3.) Find and delete the following lines:


      .permissionset reqmin
                 = {[mscorlib]System.Security.Permissions.PermissionSetAttribute = {property string 'Name' = string('nobody')},
                    [mscorlib]System.Security.Permissions.SecurityPermissionAttribute = {property bool 'Execution' = bool(true)}}

     

    4.) Save and rebuild the assembly with the following command: ilasm.exe AssemblyName.il /dll

    5.) Throw the new dll in your bin directory or if it's strong named and needed in the GAC you can put it there.

     

    Hope that helps.

    Tuesday, May 15, 2007 1:14 AM

All replies

  • If it's of any help, if I right-click | View in Browser, rather than building or debugging, I get the following stack trace:

    [ArgumentException: Unable to generate permission set; input XML may be malformed.]
       System.Security.PermissionSet.CreateSerialized(Object[] attrs, Boolean serialize, Byte[]& nonCasBlob, PermissionSet& casPset, HostProtectionResource fullTrustOnlyResources) +2747750

    [FileLoadException: Could not load file or assembly 'uSwitch.Web.UI.Lego, Version=1.0.2405.17351, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))]
       System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0
       System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +211
       System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +141
       System.Reflection.Assembly.Load(String assemblyString) +25
       System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +32

    [ConfigurationErrorsException: Could not load file or assembly 'uSwitch.Web.UI.Lego, Version=1.0.2405.17351, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))]
       System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +580
       System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +203
       System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +45
       System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +178
       System.Web.Compilation.WebDirectoryBatchCompiler..ctor(VirtualDirectory vdir) +199
       System.Web.Compilation.BuildManager.BatchCompileWebDirectoryInternal(VirtualDirectory vdir, Boolean ignoreErrors) +37
       System.Web.Compilation.BuildManager.BatchCompileWebDirectory(VirtualDirectory vdir, VirtualPath virtualDir, Boolean ignoreErrors) +445
       System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) +77
       System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +596
       System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +76
       System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +86
       System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +42
       System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +32
       System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +62
       System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) +294
       System.Web.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +139
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +146

    Wednesday, August 02, 2006 4:35 PM
  • Uninstall, reboot, then install all parts of the .net framework - I had the same problem after my laptop's battery unexpectedly gave-up. The only thing that helped was full reinstall of .net.

    Hope this works for you too,

    Miroslav B.

    • Unmarked as answer by Owen Blacker Monday, July 28, 2008 5:03 PM
    Monday, February 19, 2007 3:12 AM
  • A colleague found (this afternoon) that that worked for him too. I was pretty sure we’d tried that already, but evidently not.

    Thanks, Miroslav. I’m glad it fixed the problem for you and hopefully it won’t be a problem for anyone again  :o)
    Monday, March 12, 2007 5:09 PM
  • I'm sure that works great, but I wouldn't call it a solution.  What is causing this error? I'm digging a little further.  I'll post what I find.
    Wednesday, May 09, 2007 3:32 PM
  •  

    Okay...I've figured out my issue. I'm not for sure why uninstalling and reinstalling worked for people.  Unless, they somehow messed up the web.config in the C:\windows\Microsoft.NET\Framework\v2.05027\Config\ directory.

     

    Background: The assembly causing me trouble was built in house and I did not have the source code.

    Required: You need the Visual Studio SDK for ildasm.exe

     

    Steps:

     

    1.) Disassemble the .dll with the command ildasm.exe AssemblyName.dll /out:AssemblyName.il  

    2.) Open the newly created AssemblyName.il with a text editor and search for "permissionset"

    3.) Find and delete the following lines:


      .permissionset reqmin
                 = {[mscorlib]System.Security.Permissions.PermissionSetAttribute = {property string 'Name' = string('nobody')},
                    [mscorlib]System.Security.Permissions.SecurityPermissionAttribute = {property bool 'Execution' = bool(true)}}

     

    4.) Save and rebuild the assembly with the following command: ilasm.exe AssemblyName.il /dll

    5.) Throw the new dll in your bin directory or if it's strong named and needed in the GAC you can put it there.

     

    Hope that helps.

    Tuesday, May 15, 2007 1:14 AM
  • One of my colleagues found something similar a few months back; I asked him to post it here, but hadn't realised he'd not done so:

    • Uninstall .NET (Runtime and SDK)
    • Uninstall IIS
    • Install .NET (Runtime and SDK)
    • Install IIS

    This seemed to fix the problem for him, without the rather-more-drastic course of a full machine rebuild.

     

    I hope this helps people!

    • Unmarked as answer by Owen Blacker Monday, July 28, 2008 5:01 PM
    • Unmarked as answer by Owen Blacker Monday, July 28, 2008 5:01 PM
    • Unmarked as answer by Owen Blacker Monday, July 28, 2008 5:01 PM
    • Unmarked as answer by Owen Blacker Monday, July 28, 2008 5:01 PM
    • Unmarked as answer by Owen Blacker Monday, July 28, 2008 5:02 PM
    Tuesday, August 07, 2007 8:57 AM
  • http://forums.asp.net/p/1125637/1769670.aspx

    worked for me too, cleaned up C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files and shazzaam
    • Unmarked as answer by Owen Blacker Monday, July 28, 2008 5:02 PM
    • Proposed as answer by Rajesh Goel Saturday, February 05, 2011 12:33 PM
    Tuesday, September 11, 2007 10:41 PM
  • It worked for me too. I cleaned up the C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files and I was happy again .

    Wednesday, October 17, 2007 4:02 PM
  • Hello ppl.

    Ok, that's not working for me.

    I recently made a Conversion from VS2003 to VS2005.

    I was using a reference to a DLL working very well in VS2003. In VS2005 it gives-me this message:

     

    Error 122 Não foi possível carregar o ficheiro ou assemblagem 'CAPICOM, Version=2.1.0.0, Culture=neutral, PublicKeyToken=112d456261246b54' ou uma das respectivas dependências. O parâmetro é incorrecto. (Excepção de HRESULT: 0x80070057 (E_INVALIDARG))  

    (sorry for the portuguese message) it basically says:
    Error 122 It was not possible to load the file or assembly 'CAPICOM ...' or one of its dependencies. The parameter is incorrect. (exception HRESULT .... )

     

     

    Thata DLL is external and protected. i cannot access it.

    any ideas?

     

     

    thanks...

    Friday, November 02, 2007 11:15 AM
  • Reinstall .NET? Nah. I didn't even have to clean up the entire Temp Files directory. I deleted the directory C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\MyWebService and recompiled and it worked fine.

     

    I suspect that there is a conflict between compiled code versions that happens here. The web service I was building worked fine until I went to debug some code that I had added. I changed the web.config debug option to 'true' and immediately got the 'parameter is incorrect' error. I suspect that the compiler doesn't rebuild every file when you change just the web.config like it does when you change the Solution Configurations dropdown (up in the menubar).

     

    Just some guesses.

    Wednesday, November 14, 2007 9:20 PM
  • I got this exact same error as well.

     

    Some people have suggested to unistall .NET Framework and install .NET Framework. Does that .NET FRamework comes  from VB 2005? IF so does that mean I have to reinstall VB 2005?

     

    I am working w/VB 2005 and I ran into the error.

     

    Any suggestions? And does anyone know what this error means and why I am getting it?

     

    ~M~

    Wednesday, January 16, 2008 12:59 AM
  • Hi LatinaCWU21,

     

    you can first try http://forums.asp.net/p/1125637/1769670.aspx - clean up C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files

    If this doesn't help, try reinstalling .NET Framework. VB 2005 is based on .NET Framework 2.0, but you can reinstall .NET without uninstalling VB. You can find the .NET 2.0 setup file (called dotnetfx.exe) and it will allow you to reinstall .NET.

     

    Hope this helps,

    Kirill

    Wednesday, January 16, 2008 7:38 PM
  •  

    Another thumb UP;

    I deleted the entire folder of Temporary Internet Files and it worked for me.

     

    Yes, Really, re-installing .NET is not the solution. Glad that this worked

    Wednesday, January 16, 2008 9:00 PM
  • Kirill,

     

    I tried repairing .NET FRAMEWORK 2.0, but i still got the error message:

     

    The parameter is incorrect … HRESULT: 0x80070057 (E_INVALIDARG)

     

    I found out that it goes away when I comment out :

     

    '<Assembly: PermissionSetAttribute(SecurityAction.RequestMinimum, Name:="Local Intranet")>

    '<Assembly: PermissionSetAttribute(SecurityAction.RequestOptional, Unrestricted:=True)>

     

    Does anyone know why?

     

    BUT now I get a different error when I comment out the Assemblies:

     

    Current error now:

    A first chance exception of type 'System.Security.SecurityException' occurred in mscorlib.dll

    (There was an error: Request for the permission of type "System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture= neutral, PublickKeyToken=b77a5c561934e089 failed.)

     

    Help, does anyone know what to do? And why I get it when I comment out the 2 assemblies listed?

    Wednesday, January 16, 2008 9:12 PM
  • Have you tried clearing the temporary files as described above?

     

    I also recommend re-reading this thread as it contains a lot of useful information.

     

    Wednesday, January 16, 2008 9:49 PM
  • Note that on 64-bit Windows, the path you need to clear is:

    %windir%\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files
    • Proposed as answer by Mubashar Ahmad Monday, January 25, 2010 12:27 PM
    Friday, January 18, 2008 4:09 AM
  • For the purpose of easier and quicker debugging and rebuilding, VS always caches the assemblies and compiled files in it's temporary asp.net files. you can find a folder for each and every project you run.

    As far I have noticed, this problem normally occurs when there was an unexpected crash of VS or the application. whenever your run an application, VS checks whether the binaries are up to date by checking it's signature, attributes etc (if auto update is enabled). There are chances when the application might crash writing down the signature and attributes of a binary the correct one but the contents would not be perfect. At this point we get this error.

    Mostly we developers goto the temporary files and find the particular project and delete it; which would be the simple solution without digging much Smile
    Monday, January 21, 2008 11:18 PM
  •  

    To delete temporary files worked for us.

     

    Regards!

    Friday, April 04, 2008 10:39 PM
  • Excellent Solution, thanks a lot guys!!!! It worked very good for me!!

     

    Wednesday, April 23, 2008 9:11 PM
  • Visit at http://www.ginkostyle.blogspot.com/ for the answer its work
    Thursday, July 10, 2008 11:21 AM
  • I have had this issue many times.  The key is to follow these steps strictly...

    Delete the contents of C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\
    Delete the dll from the bin directory.
    Recompile and get a "FileNotFoundException" on execution to confirm the dll is gone.
    Copy the dll back to the bin directory.
    Recompile
    All is now well

    I feel as if I am giving a recipe for a witches brew to a 12th century alchemist instead of a rational set of operations to a rational man, but, there it is.

    If this DOES NOT solve the problem for anyone, please let me know.  I will be curious.

    Best,

    Brett

    bnieland
    Wednesday, July 16, 2008 12:37 PM
  •  

    Okay...I've figured out my issue. I'm not for sure why uninstalling and reinstalling worked for people.  Unless, they somehow messed up the web.config in the C:\windows\Microsoft.NET\Framework\v2.05027\Config\ directory.

     

    Background: The assembly causing me trouble was built in house and I did not have the source code.

    Required: You need the Visual Studio SDK for ildasm.exe

     

    Steps:

     

    1.) Disassemble the .dll with the command ildasm.exe AssemblyName.dll /out:AssemblyName.il  

    2.) Open the newly created AssemblyName.il with a text editor and search for "permissionset"

    3.) Find and delete the following lines:

     

     

      .permissionset reqmin
                 = {[mscorlib]System.Security.Permissions.PermissionSetAttribute = {property string 'Name' = string('nobody')},
                    [mscorlib]System.Security.Permissions.SecurityPermissionAttribute = {property bool 'Execution' = bool(true)}}

    4.) Save and rebuild the assembly with the following command: ilasm.exe AssemblyName.il /dll

    5.) Throw the new dll in your bin directory or if it's strong named and needed in the GAC you can put it there.

     

     

    Hope that helps.


    Sunday, April 26, 2009 10:37 AM
  • If it's of any help, if I right-click | View in Browser, rather than building or debugging, I get the following stack trace:

    [ArgumentException: Unable to generate permission set; input XML may be malformed.]
       System.Security.PermissionSet.CreateSerialized(Object[] attrs, Boolean serialize, Byte[]& nonCasBlob, PermissionSet& casPset, HostProtectionResource fullTrustOnlyResources) +2747750

    [FileLoadException: Could not load file or assembly 'uSwitch.Web.UI.Lego, Version=1.0.2405.17351, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))]
       System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +0
       System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +211
       System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +141
       System.Reflection.Assembly.Load(String assemblyString) +25
       System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +32

    [ConfigurationErrorsException: Could not load file or assembly 'uSwitch.Web.UI.Lego, Version=1.0.2405.17351, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))]
       System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective) +580
       System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory() +203
       System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai) +45
       System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig) +178
       System.Web.Compilation.WebDirectoryBatchCompiler..ctor(VirtualDirectory vdir) +199
       System.Web.Compilation.BuildManager.BatchCompileWebDirectoryInternal(VirtualDirectory vdir, Boolean ignoreErrors) +37
       System.Web.Compilation.BuildManager.BatchCompileWebDirectory(VirtualDirectory vdir, VirtualPath virtualDir, Boolean ignoreErrors) +445
       System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) +77
       System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +596
       System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) +76
       System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +86
       System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert) +42
       System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +32
       System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +62
       System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) +294
       System.Web.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +139
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +146


    Sunday, April 26, 2009 10:38 AM
  • I have the same problem and delete temporary files not solve.

    when I take out one dll of the site give the same error with other.

    I don't know what to do, the problem only occurs in the server that is windows 2003, I can't uninstall .net because other sites are running in the same server

    in local machine works file.

    I need help

    thanks,

    SC

    Sérgio Carvalho
    Saturday, September 05, 2009 1:55 PM
  • Clearing the temp folder solvved it for me. Thanks for the time saver.
    • Proposed as answer by mfreder Thursday, December 03, 2009 3:45 AM
    Thursday, October 15, 2009 9:43 PM
  • Worked for me.  Using Windows 7, I had to clear C:\Users\<name>\AppData\Local\Temp\Temporary ASP.NET Files
    Thursday, December 03, 2009 3:46 AM
  • I have Win 7 too and that did the trick.  Funny thing was I started getting the warning in VS 2008 after my computer crashed when running the debugger.  I guess something that temp directory was hung up.  I was running my project off an external drive and when I moved it to my C drive and opened the solution I was not getting the warning error in VS.  I then knew it was not my project that was acting up but something with VS 2008 or in this case .NET Framework.  Of course my web app never stopped working it was just annoying to see that stupid dependency warning, but all is better now that it is gone.  Thanks for the post!
    Friday, January 08, 2010 10:29 PM
  • Thankyou!  Saved me hours :-)
    Tuesday, January 19, 2010 4:30 PM
  • Clean the temp files like mwshouse said worked for me: I have Visual Studio 2008 working in an MVC project. The Domain Model in other project....and a reference of the domian model project in the MVC project........ Thanks :)
    Thursday, March 04, 2010 5:55 AM
  • I had a similar issue in my VS2008 ASP.NET MVC project.  I cleaned and rebuilt the solution many times to no avail.   Running would always result in crazy assembly load errors.   Everything was working normally until I encountered a Blue Screen of Death when trying to run the VStudio 2008 performance analyzer on my MVC project.   Upon rebooting, my web.config was full of nothing but nulls (0).   Thanks to source control, i was able to fix the web.config issue.   I had to delete my temp asp.net files to fix the other issue.

     

     

    Wednesday, March 24, 2010 10:21 PM
  • solved for me only when I cleaned this folder:
    C: \Users\USERNAME\AppData\Local\Temp\Temporary ASP.NET Files\
    Wednesday, April 07, 2010 5:24 PM
  • solved for me only when I cleaned this folder:
    C: \Users\USERNAME\AppData\Local\Temp\Temporary ASP.NET Files\


    I could solve this problem by clearing from this folder. I guess this is the Temporary ASP.NET files folder in Windows 7 and Vista. Glad that it worked.

    Thank you,

    Z

    Wednesday, May 05, 2010 4:46 AM
  • Thanks mwshouse

    it's working fine without uninstall any thing

    very thanks man

    Wednesday, June 16, 2010 3:35 PM
  • I got same problem too and solved by cleaning this folder C:\Users\[username]\AppData\Local\Temp\Temporary ASP.NET Files on Windows 7 by the way :)

    Regards.

    Fatih.

    Thursday, August 19, 2010 8:58 AM
  • In Visual Studio 2010 on Win7 64bit I had to clean c:\windows\microsoft.net\framework\v4.0.30319\Temporary ASP.NET Files

    This error started happening to me after VS2010 crashed like other above.

    Monday, September 13, 2010 3:24 AM
  • Solved for me clean the content of folder C:\Documents and Settings\All Users\Dados de aplicativos\Microsoft Visual Studio\10.0\TraceDebugging\ (Location of Intellitrace Recordings)

     

    Sunday, December 12, 2010 6:03 PM
  • In VS 2010, after referencing Enterprise Library 5.0 dll's for exception handling and logging, every view's page directive was squiggled with the message:

    ...[view name path]: ASP.NET runtime error: Could not load file or assembly 'Microsoft.Practices.EnterpriseLibrary.Common, Version=5.0.414.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.  The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))

    I had referenced the Microsoft.Practices.EnterpriseLibrary.Common dll specifically in the C:\Program Files\Microsoft Enterprise Library 5.0 ... folder to resolve some reference problems.   Eventually I removed this reference because it proved to be unneeded.

    But on every page I continued to see the error above, and intellisense was inoperative on those pages, so view model properties were not available.

    Removed contents of:

    C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files

    with no immediate effect.  Then removed contents of:

    C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files

    and intellisense for ViewModel was restored.

    Monday, January 31, 2011 4:50 PM
  • In Visual Studio 2010 on Win7 64bit I had to clean c:\windows\microsoft.net\framework\v4.0.30319\Temporary ASP.NET Files

    This error started happening to me after VS2010 crashed like other above.


    Thanks,

     

    This also saved my lots of time.

    I have cleaned my C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files directory specially "root" folder, and it worked.

     

    Thanks once again.

    Saturday, February 05, 2011 12:36 PM
  • Worked for me too! :)

    I deleted every folder in  C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET 

    Wednesday, May 25, 2011 6:34 PM