locked
TF244011: Change in the PWA URL resulted in TFS -Project server integration breaking:

    Question

  • Hi,

    We have set up project server 2010 in one server and TFS 2010 in another server and both products are integrated using integration feature apck.Then work items in TFS and tasks in project server were synchronizing successfully.

    After that I have made the application secure and also made the url user freindly (earlier url was using the servename ).

    After that the synchronization is not working.
    we used the command GetRegisteredPWA and got the result as"No PWA instance are registered".
    But when checked GetMappedCollection, got the result as <collection> is mapped to PWA<the new URL>.

    When I tried to register the new URL with TFS.. got the below message
    ".....................TF244011: The following PWA instance is not currently registered: <new PWA URL>. If this PWA was previously registered under a different URL, you can re-register it by using /RegisterPWA and by specifying the /previousPwa argument."

    Then I used the RegisterPWa command using previousPWA and force arguments and got the below message.
    "...................TF244011: The following PWA instance is not currently registered: <previous URL>"

    Please help me to resume the integration.
    Can I uninstall and re- install the feature pack? Will it help?
    Note: I have only one enterprise project and Team project and We are in the process of setting up the deployment

     

    Thanks,


    Thanks, Lovely

    Monday, March 19, 2012 4:27 PM

Answers

  • Thanks Abhijeet.

    We have contacted Microsoft support team and resolved the issue. We have done below steps.

    The Root and intermediate Certificate  needs to be installed in the Trusted Root Certification Authorities Store on TFS and Project .

    MaMake sure you have .cer files for the authority certificates – both Root and intermediate.

    1.        Open SharePoint Central Administration Select Security
    2.        In General Security click on Manage Trust.
    3.        Click on New, and in the Trust Relationship window Provide a name and select the saved certificate files (both Root and intermediate.)
    4.        Select OK,

    After completeing this , the certificate invalid error resolved but we got below error. That was due loopback issue .

    We have done below steps to resolve this loopback issue (We are using windows server 2008 )

    Before doing below steps exported the registry and kept back up.

    1. Click Start, type regedit.exe in the Start Search box, and then press ENTER.
    2. Expand the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    1. Right-click Parameters, click New, and then click DWORD (32-bit) Value.
    2. In the Value name box, type DisableStrictNameChecking, and then press ENTER.
    3. Double-click the DisableStrictNameChecking registry value and type 1 in the Value data box, and then click OK.
    4. Close Registry Editor.
    5. Expand the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    1. Right-click MSV1_0, point to New, and then click Multi-String Value.
    2. Type BackConnectionHostNames, and then press ENTER.
    3. Right-click BackConnectionHostNames, and then click Modify.
    4. In the Value data box, type the host name or the host names for the sites that are on the local computer, and then click OK.

    Quit Registry Editor, and then restart the IISAdmin service

    That worked well !!!


    Thanks, Lovely

    • Proposed as answer by Abhijeet Mohite Wednesday, April 25, 2012 7:01 AM
    • Marked as answer by Rose 25 Wednesday, April 25, 2012 7:02 AM
    Wednesday, April 25, 2012 5:20 AM

All replies

  • No need of re installing feature pack.

    This is what you can try:

    1. Un-map all the enterprise projects which you have mapped with team project using the /force switch

    2. Un-map the collection

    3. Un register PWA

    4. Register PWA

    5. Map PWA to collection

    6. Map project

    Additionally you can also get exact error using /getsyncmessages


    Abhijeet M. Mohite

    Tuesday, March 20, 2012 6:31 AM
  • Thanks for the response.

    Earlier I had deleted the enterprise project after unmapping the work item types. So now when i try to unmap pwa from collection i got some error.

    Then i tried Un register PWA and unregistered successfully.

    Then I tried to register the modifeid PWA URL which is https.Then I got below error:

    "TF244069: An error occurred while checking the provisioning status of the reporting database schema for a PWA instance.Project Server returned the following error: "Server was unable to process request. ---> The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> The remote certificate is invalid according to the validation procedure.".

    Please help me to proceed


    Thanks, Lovely

    Tuesday, March 20, 2012 9:48 AM
  • Tuesday, March 20, 2012 10:20 AM
  • I am still having the issue.
    I am able to register PWA witht the URL <a href="http:///PWA">http://<servername>/PWA. Then I have unregistered PWA and waited before doing the below steps.
    When I am trying to register the same PWA using the URL http:<Domain>/PWA , I am getting below error:
    "TF244069: An error occurred while checking the provisioning status of the reporting database schema for a PWA instance.
    Project Server returned the following error: "Server was unable to process request. ---> The request failed with HTTP status 401: Unauthorized."."

    But I am able to access the http:<Domain>/PWA using the TFS service account and the login used to do the registering.

    Also when I am registering the same PWA using https:<Domain>/PWA, I am getting below error:

    "TF244069: An error occurred while checking the provisioning status of the reporting database schema for a PWA instance.Project Server returned the following error: "Server was unable to process request. ---> The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> The remote certificate is invalid according to the validation procedure."."

    Please help me to proceed the registering https:<domain>/PWA with TFS.


    Thanks, Lovely

    Monday, March 26, 2012 4:15 PM
  • If you register the PWA using http://<servername>/PWA, does the integration works as expected?

    i.e. Do the tasks flow between TFS and Project Server as expected when you register using http://<servername>/PWA


    Abhijeet M. Mohite

    Tuesday, March 27, 2012 6:16 AM
  • yes. It is working as expected.

    Thanks, Lovely

    Tuesday, March 27, 2012 7:15 AM
  • URL's are generally for user friendly names which they can remember easily.

    Even if you use SERVER NAME or DOMAIN NAME for integration, in the background the task exchange between Project Server and TFS Server will work as it is.

    I would say you register using SERVER NAME and use the integration piece, there is no harm in it.

    User can continue accessing the applications using the secure URLs which you have set up and in the background the data exchange will keep on happening on its own.

    Meanwhile to give it a try:

    1. Configure Alternate Access Mappings correctly in SharePoint Central Administration Console for your PWA instance

    2. Add the PWA URL in the trusted zone on the machine from where you are running the configuration commands

    3. If possible, import the SSL Certificates (if you have used on Project Server), to TFS Server


    Abhijeet M. Mohite

    Tuesday, March 27, 2012 8:33 AM
  • Thanks Abhijeet.

    We have contacted Microsoft support team and resolved the issue. We have done below steps.

    The Root and intermediate Certificate  needs to be installed in the Trusted Root Certification Authorities Store on TFS and Project .

    MaMake sure you have .cer files for the authority certificates – both Root and intermediate.

    1.        Open SharePoint Central Administration Select Security
    2.        In General Security click on Manage Trust.
    3.        Click on New, and in the Trust Relationship window Provide a name and select the saved certificate files (both Root and intermediate.)
    4.        Select OK,

    After completeing this , the certificate invalid error resolved but we got below error. That was due loopback issue .

    We have done below steps to resolve this loopback issue (We are using windows server 2008 )

    Before doing below steps exported the registry and kept back up.

    1. Click Start, type regedit.exe in the Start Search box, and then press ENTER.
    2. Expand the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    1. Right-click Parameters, click New, and then click DWORD (32-bit) Value.
    2. In the Value name box, type DisableStrictNameChecking, and then press ENTER.
    3. Double-click the DisableStrictNameChecking registry value and type 1 in the Value data box, and then click OK.
    4. Close Registry Editor.
    5. Expand the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    1. Right-click MSV1_0, point to New, and then click Multi-String Value.
    2. Type BackConnectionHostNames, and then press ENTER.
    3. Right-click BackConnectionHostNames, and then click Modify.
    4. In the Value data box, type the host name or the host names for the sites that are on the local computer, and then click OK.

    Quit Registry Editor, and then restart the IISAdmin service

    That worked well !!!


    Thanks, Lovely

    • Proposed as answer by Abhijeet Mohite Wednesday, April 25, 2012 7:01 AM
    • Marked as answer by Rose 25 Wednesday, April 25, 2012 7:02 AM
    Wednesday, April 25, 2012 5:20 AM