none
Drill down issues with ssrs in integrated mode

    Question

  • The "jump to report" drilldown option is not working right.  These same reports drill fine on another report server (non-integrated).  It looks like the "path" specified in the url is messed up, it's trying to go to site/subsite/report instead of just subsite/report.  The site that has the report library is not the root site in the site collection.

    I've tried looking around for a setting for that path but I don't see it.  Seems like the report would know its own path..

    Thanks in advance for your help,

     

    Ken

    SSRS 2005, MOSS 2007

    Wednesday, September 08, 2010 9:12 PM

All replies

  • Issue is apparently that jump to report links need the ".rdl" on the end of the report name.  Unfortunately, based on my reading, when you deploy to a non-integrated mode ssrs instance, the .rdl will break the link.  So I'm stuck going through all my reports and manually fixing them each time I want to deploy to a different environment.  *sigh*
    Thursday, September 09, 2010 2:28 PM
  • Issue is apparently that jump to report links need the ".rdl" on the end of the report name.  Unfortunately, based on my reading, when you deploy to a non-integrated mode ssrs instance, the .rdl will break the link.  So I'm stuck going through all my reports and manually fixing them each time I want to deploy to a different environment.  *sigh*

    Does anyone know if there is a workaround for this? I just ran into this same issue. I am using a conditional statement to determine which report to drill to based on the textbox's column.

    =iif((Fields!Type.Value =

    "Total") OR (Fields!Type.Value = "Variance - (F)/U"),"DivisionSpendingReport","DivisionSpendingReportDetail")

    Works fine in Visual Studio. Once deployed to SharePoint though, the drill through returns an error that says report can't be found. So I added the .rdl to the conditional statement in the report Design.

    =iif((Fields!Type.Value =

    "Total") OR (Fields!Type.Value = "Variance - (F)/U"),"DivisionSpendingReport.rdl","DivisionSpendingReportDetail.rdl")

    It now works in SharePoint but not in Visual Studio...

    Do I need to keep adding and removing the ".rdl" in order to make any changes to this report???!!!

    Friday, February 17, 2012 10:38 PM