none
Freeze Panes Grayed Out

    Question

  • Hello,

    I've reviewed the various links related to the disabled freeze panes function and still cannot determine why I am unable to freeze panes.

     

    I'm running Excel 2007 on Win 7 and cannot seem to get "freeze panes" to work or become enabled.

     

    I've gone through and made sure that neither my workbook, nor my worksheet is protected.  The document is also password free.  I have also added myself as a user and unlocked the entire workbook under "allow users to edit ranges".

     

    One unusual thing I have noticed however, is that when i select "allow users to edit ranges" then go into "protect sheet", I must enter a password to unprotect the sheet.  I have never set, nor do i know, what this "password to unprotect sheet" is.

    That said, everything I see on the "Review" menu bar indicates that the sheet and document are unprotected (because only the buttons to "protect" sheet and workbook are active).

     

    I dont know programming language or code.  Can someone please help me active Freeze Panes functionality?

     

    Thanks!

    Monday, April 26, 2010 7:55 PM

Answers

  • I had this same issue.  The solution was actually too easy.  On the View tab in Excel 2007 make sure your page layout is in normal view.  As soon as I switched over to Normal freeze panes became available again.
    • Edited by Suzzb Wednesday, July 07, 2010 3:00 PM incorrect word correction
    • Proposed as answer by danishaniModerator Sunday, March 04, 2012 11:19 PM
    • Marked as answer by danishaniModerator Thursday, March 08, 2012 6:26 AM
    Wednesday, July 07, 2010 2:59 PM

All replies

  • I had this same issue.  The solution was actually too easy.  On the View tab in Excel 2007 make sure your page layout is in normal view.  As soon as I switched over to Normal freeze panes became available again.
    • Edited by Suzzb Wednesday, July 07, 2010 3:00 PM incorrect word correction
    • Proposed as answer by danishaniModerator Sunday, March 04, 2012 11:19 PM
    • Marked as answer by danishaniModerator Thursday, March 08, 2012 6:26 AM
    Wednesday, July 07, 2010 2:59 PM
  • Same for me.. worked as soon as i switched to normal view.. Thanks for that simple fix!!!
    Tuesday, August 10, 2010 3:21 AM
  • Hi Flutter Lilly,

    You have FREEZE PANES option in Window Menu in the Menu bar, just before Help Menu item.

    If you donot have freeze panes option, you can as well customise your tool bar / menu bar.

    Just right click your mouse by placing it on the menu bar, you get a customise dialog box, it has three tabs, select the first tab, you get all the menus names listed in the left pane of the dialog box, by clicking on one of the options displayed (eg: if you Click File option, File menu options are displayed in the right pane) select the window option, displays the corresponding options in the right pane... just click on the Freeze Pane Option, drag and drop on the windows menu in the main/builtin menu bar.

    Now close the CUSTOMISE dialog box.

    Freeze panes option is now available.  This option acts as a toggle option (ie., when no FREEZE exists, it says Freeze Window, when the window is already freezed, then the same option displays as UNFREEZE)

    I believe, this will solve your problem.

    with regards
    Repath Athyala
    www.Repath.WordPress.Com

    Wednesday, August 11, 2010 5:41 AM
  • What if my worksheet is protected?  I have vb code on This workbook module of the file so when someone opens this protected file they can freeze panes (userinterfaceonly:=True).  It works fine in excel 2003, but when we open the same file in excel 2007, freeze panes is grayed out.  is there a change to excel 2007 and vba in how to enable the user interface of a protected worksheet?
    Monday, October 18, 2010 10:52 PM
  • I had this same issue.  The solution was actually too easy.  On the View tab in Excel 2007 make sure your page layout is in normal view.  As soon as I switched over to Normal freeze panes became available again.

    After I composed the right question to ask about activating Freeze Frame, I found your correct answer: switch to NORMAL view. Thanks for the help.
    Tuesday, August 23, 2011 2:40 PM
  • I am in "Normal" view, have no protection and the Freeze panes is STILL grayed out.  Why makes this stuff so hard?  Do any customers ever use this software before it is released?

    Saturday, March 31, 2012 10:03 PM
  • I have the same problem. My view is in noremal, but my freeze panes is grayed out. I am having this issue on one workbook only. Any other Excel files I open are OK.
    Tuesday, May 08, 2012 2:33 PM
  • Other solution: Check if you have splitted the screen? If so, you can't freeze the panes also.
    Saturday, November 02, 2013 8:05 PM
  • I have the same issue.  No protection, in Normal view, and Freeze Panes is greyed out, as well as Split and new window.  Not sure what to check next...
    Monday, November 25, 2013 11:28 PM
  • I had same issue, here is what solved it for me, you might want to try it:

    - if you look into the scroll bar at the right side, at the very top there is a small button than enables you to split the worksheet horizontaly.

    - same thing on the botton slide bar, that splits the worksheet vertically.

    - use these to split the sheet, then drag them again to unsplit. (play with them)

    - Freeze pane button becomes active again

    Tuesday, December 17, 2013 12:38 AM
  • I had same issue, here is what solved it for me, you might want to try it:

    - if you look into the scroll bar at the right side, at the very top there is a small button than enables you to split the worksheet horizontaly.

    - same thing on the botton slide bar, that splits the worksheet vertically.

    - use these to split the sheet, then drag them again to unsplit. (play with them)

    - Freeze pane button becomes active again

    Tuesday, December 17, 2013 12:39 AM