locked
"DEM server did not return tile" / HTTP 500 when using the Bing Maps REST Services

    Question

  • Hello,

    I'm trying to use the Bing Map REST services to retrieve elevation of a given geolocation but I get an HTTP 500 status, with the message "DEM server did not return tile".

    I'm doing an HTTP (POST or GET) request to http://dev.virtualearth.net/REST/v1/Elevation/List?key=myKey&points=49.120624,2.569942

    I get the following response:

    Response: status: 500 Internal Server Error Date: Wed, 26 Jun 2013 09:13:58 GMT Via: 1.1 frontfw1:3128 (squid), 1.0 TMG2SRV X-Cache-Lookup: MISS from frontfw1:3128 Server: Microsoft-IIS/8.0 X-AspNet-Version: 4.0.30319 X-Powered-By: ASP.NET, ASP.NET X-BM-Srv: PRAM001262, ecn.t2.tiles.virtualearth.net X-Cache: MISS from frontfw1 Content-Type: application/json X-MS-BM-WS-INFO: 0 Cache-Control: no-cache Proxy-Connection: Keep-Alive Connection: Keep-Alive Content-Length: 610 X-BM-TraceID: 9c46d7168c264097b1e60e7b36271e0b

    {
    "authenticationResultCode": "ValidCredentials",
    "brandLogoUri": "http:\/\/dev.virtualearth.net\/Branding\/logo_powered_by.png",
    "copyright": "Copyright © 2013 Microsoft and its suppliers. All rights reserved. This API cannot be accessed and the content and any results may not be used, reproduced or transmitted in any manner without express written permission from Microsoft Corporation.",
    "errorDetails": ["1202022333012"],
    "resourceSets": [],
    "statusCode": 500,
    "statusDescription": "DEM server did not return tile.",
    "traceId": "ab61654ed6204d86916244563934fc87|PRAM001261|02.00.150.1300|ecn.t2.tiles.virtualearth.net"
    }

    Any idea?

    Thanks,

    Alex.


    • Edited by _ Alex Wednesday, June 26, 2013 9:23 AM
    Wednesday, June 26, 2013 9:22 AM

All replies

  • I'm able to reproduce this and have escalated this to our development team for investigation.

    http://rbrundritt.wordpress.com

    Wednesday, June 26, 2013 6:07 PM
    Owner
  • Hello,

    Do you have a status update on this issue?

    Thanks,

    Alex.


    Friday, July 05, 2013 3:04 PM
  • Hello,

    The issue is still happening, for example near Paris/France :

    http://dev.virtualearth.net/REST/v1/Elevation/List?key=myKey&points=49.0020859335074,2.26114260032984

    Do you have ETA for a bug-fix? 

    Thanks,

    Alex.

    • Edited by _ Alex Tuesday, August 27, 2013 11:02 AM
    Tuesday, August 27, 2013 10:33 AM
  • Hello Ricky,

    I just want to inform you the problem is still there (its been 10 months).

    Alex.


    • Edited by _ Alex Saturday, April 26, 2014 3:22 PM
    Saturday, April 26, 2014 3:21 PM