none
Skriptfehler - Warnhinweis abstellen

    Question

  • Hallo

    ich automatisiere den IE mit C# (um mir Infos über alle Tatortfolgen in eine DB zu ziehen, aber das tut nichts zur Sache...)
    Gelegentlich poppt ein Warnhinweis auf:

    "In dem Skript auf dieser Seite ist ein Fehler aufgetreten.
    "Zeile...
    "Zeichen...
    "Fehler....
    "Code
    "URL...
    "Möchten Sie, dass Scripts auf dieser Seite weiterhin ausgehführt werden?"

    Dieser Warnhinweis stört meine ganze Programmausführung, weshalb ich in gerne ausschalten möchte.
    Wie geht das? Ich möchte den Hinweis unterbinden u. Skript-Ausführung nach Fehlern (aber nur dann) abstellen

    Wo stell ich das ein? Ich habe es in den IE-Settings wohl übersehen.
    Verwende den IE8 auf Windows 7 x64

    Christoph

     

    • Edited by Chris Basedau Dev Wednesday, October 06, 2010 9:33 PM Fehlerbeschreibung genauer
    Wednesday, October 06, 2010 9:10 PM

Answers

  • Für Leute die das gleiche Problem haben sollten, die simple Lösung lautet:

    this.webBrowserCtrl.ScriptErrorsSuppressed = true;

    Tuesday, October 12, 2010 8:26 PM

All replies

  • Also unter

    Syssteuerung - Inetoptionen - Erweitert - Skriptfehler anzeigen
    hab ich KEIN Häkchen.
    Skriptfehler-Meldung krieg ich trotzdem angezeigt, allerdings nicht im "normalen IE"
    sondern in der Webbrowser-Komponente die man in WindowsForms einbindet.
    Muss mich wohl in der .NET-Gruppe mal umhören danke fürs mitlesen jedenfalls...

     

    Christoph

    Wednesday, October 06, 2010 10:02 PM
  • Für Leute die das gleiche Problem haben sollten, die simple Lösung lautet:

    this.webBrowserCtrl.ScriptErrorsSuppressed = true;

    Tuesday, October 12, 2010 8:26 PM