none
BizTalk deployment Error

    Question

  • Hi I am following in Visual 2008 When I try to deploy my solution for BIzTalk2009 application.I am running VS studio as a administrator.

    Failed to add resource(s). Change requests failed for some resources. BizTalkAssemblyResourceManager failed to complete end type change request. Assembly "C:\Users\AppData\Local\Temp\BT\PID3724\BizTalkAssembly\054c18ab6b455edd519cec659644d6e6\KHS.834Membership.BizTalk.EDIPipeLine.dll" does not appear to be a BizTalk assembly, and cannot be deployed to the Configuration database. If this assembly is referenced by other BizTalk assemblies, it needs to be installed into the global assembly cache (GAC) of each BizTalk server. 

     

    any Idea

    Thanks

    Thursday, October 20, 2011 10:54 PM

Answers

  • another error I am getting is

    Error 26 Access to the path 'C:\Users\AppData\Local\Temp\BT\PID1708\BizTalkAssembly\63870f24efcb5f96ec86716f1f89f7a8\KHS.834Membership.BizTalk.Orchestrations.dll' is denied.  0 0 

    I am not sure if they are related.

    Friday, October 21, 2011 3:31 PM

All replies

  • It looks like you are creating a Custom Pipeline in BizTalk project. Please ensure that the BizTalk Application name under Project --> Properties --> Deployment section points to your BizTalk Application where this Pipeline is intended to use. After deployment is successful, check if this dll is GACed.

     

    HTH.


    Don't forget to mark the post as answer or vote as helpful if it does, Regards - Sathish Krishnan
    Friday, October 21, 2011 2:56 AM
  • Check this for deploying pipeline components and this one on developing custom pipeline components.
    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Friday, October 21, 2011 4:26 AM
  • You could use BizTalk assembly viewer to view the assembly. Make sure your BizTalk EDI Application is running up.

     


    Thanks, Raja MCTS BizTalk Server 2010 If this answers your question please mark it accordingly
    Friday, October 21, 2011 6:18 AM
  • Its not just my pipeline giving even the Orchestration project giving same error

    Error 64 Failed to add resource(s). Change requests failed for some resources. BizTalkAssemblyResourceManager failed to complete end type change request. Assembly "C:\Users\AppData\Local\Temp\BT\PID3724\BizTalkAssembly\63870f24efcb5f96ec704df4b0b0e533\KHS.834Membership.BizTalk.Orchestrations.dll" does not appear to be a BizTalk assembly, and cannot be deployed to the Configuration database. If this assembly is referenced by other BizTalk assemblies, it needs to be installed into the global assembly cache (GAC) of each BizTalk server. 

    Friday, October 21, 2011 2:11 PM
  • Hi,

    How are you trying to deploy? If it's a project created in VS using the BizTalk Project template you should not get this error. Have you copied this project or created it in VS. 

     


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    • Edited by DPS Bali Friday, October 21, 2011 2:18 PM
    Friday, October 21, 2011 2:15 PM
  • Thanks for your reply.

     

    I am deploying this project in Visual Studio. it’s an old project and I did some changes and  trying to deploy again.

     

    Harbir

    Friday, October 21, 2011 2:24 PM
  • Hi 

    Can you check the AssemblyInfo.cs , you should have the following in that file. If these are not there add them and try deploying.

    using Microsoft.XLANGs.BaseTypes;
    using Microsoft.BizTalk.XLANGs.BTXEngine;
    


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    • Edited by DPS Bali Friday, October 21, 2011 2:48 PM
    Friday, October 21, 2011 2:47 PM
  • Hi Harbir,

    I came across the same exact issue u were facing today morning

    I did the following and it worked for me...Hope it works for u

    1) Rejoin your domain account to Administratords Group

    2) Deleted all the dlls and pdb files.

    3) Closed the solution

    4) Build and Deploy it again


    Racha Rams

    Racha Rams
    Friday, October 21, 2011 3:15 PM
  • another error I am getting is

    Error 26 Access to the path 'C:\Users\AppData\Local\Temp\BT\PID1708\BizTalkAssembly\63870f24efcb5f96ec86716f1f89f7a8\KHS.834Membership.BizTalk.Orchestrations.dll' is denied.  0 0 

    I am not sure if they are related.

    Friday, October 21, 2011 3:31 PM
  • Hey Habir,

    Both are interdependent and they occurred for me  in a cyclic fashion...For me it worked with the Prev solution mentioned...


    Racha Rams
    Friday, October 21, 2011 3:49 PM
  • Hi Racha

    I tried your solution but still same issue.

     

    Friday, October 21, 2011 4:19 PM
  • Try to clean your Visual Studio solution, close all Visual Studio solutions opened, open your current solution and Build & Deploy it again.
    Don't forget to mark the post as answer or vote as helpful if it does, Regards - Sathish Krishnan
    Friday, October 21, 2011 5:47 PM
  • Check this out, this post helped me solved the access denied issue.

     

     


    Senior .Net/Biztalk Developer
    Orlando, Florida Area Hospital & Health Care
    Please Indicate "Mark as Answer" if a Post has Answered the Question

    Saturday, October 22, 2011 1:00 AM
  • Awesome Jorge! Saved my day. Thanks.

    Hans Monnig

    Ohio

    Thursday, December 08, 2011 6:53 PM