none
Project using Bing Maps and referencing a Portable Library

    Question

  • Hello, i m develooping  a Windows Store application and also Windows Phone, so  for that i use a PCL project for some code and constants that are shared between the applications.

    The problem i found is that  when i m using th Bing Maps for Windows Store, i have to change the project to compile in x86 to run on my machine, but the PCL always compile in AnyCPU and i can't run the app because it's referecning the PCL.

    Is there any solution for this? seems kind a big issue since PCL are the way to go for multiple platforms projects. 

    Thanks in advance. 

    regards 

    Rui marinho

    Thursday, February 13, 2014 11:02 AM

Answers

  • This doesn't sound correct. The PCL can stay set as AnyCPU. You will need to set the cpu type for the Win8 app but this app will be able to use the PCL without any issue. I've done this several times without any issues. Here is one project I put together that does exactly this: http://mapstoolbox.codeplex.com/

    http://rbrundritt.wordpress.com

    Thursday, February 13, 2014 11:53 AM
  • I managed to get this working, after soem trial and error but still don't fully understand if this is messed up out of the box or if i manage to screw it up.

    basicly what's missing is a x86 platorm for the PCL , i had  to go to configuration manage and add new profile for x86, i don t understand why this wasn't created already, don't forget to un-tick  the box (create new platform). 

    now i can run the project. 




    Rui Marinho

    Thursday, February 13, 2014 12:46 PM

All replies

  • This doesn't sound correct. The PCL can stay set as AnyCPU. You will need to set the cpu type for the Win8 app but this app will be able to use the PCL without any issue. I've done this several times without any issues. Here is one project I put together that does exactly this: http://mapstoolbox.codeplex.com/

    http://rbrundritt.wordpress.com

    Thursday, February 13, 2014 11:53 AM
  • yeah could be, maybe  i m making something wrong, but i don't understand what.

    My settings on  the configuration manager

    This is the error i get:

    Error 4 The OutputPath property is not set for project 'SmartSales.Core.csproj'.  Please check to make sure that you have specified a valid combination of Configuration and Platform for this project.  Configuration='Debug'  Platform='x86'.  This error may also appear if some other project is trying to follow a project-to-project reference to this project, this project has been unloaded or is not included in the solution, and the referencing project does not build using the same or an equivalent Configuration or Platform. SmartSales.WINRT




    Rui Marinho

    Thursday, February 13, 2014 12:02 PM
  • I managed to get this working, after soem trial and error but still don't fully understand if this is messed up out of the box or if i manage to screw it up.

    basicly what's missing is a x86 platorm for the PCL , i had  to go to configuration manage and add new profile for x86, i don t understand why this wasn't created already, don't forget to un-tick  the box (create new platform). 

    now i can run the project. 




    Rui Marinho

    Thursday, February 13, 2014 12:46 PM