locked
Unrecognized database format

    Question

  •  

    Hi,

    My main OS is Win XP x64, as such I cannot connect to any access db. However, I have win XP home on my virtual PC with VB 2008 express. I have an access 2007 db, with file extension .accb. I have transfered that db to my virtual PC and I am designing a simple interface for the db, however, when I try to assign that db as a data source for my Vb program, I get the following error: Unrecognized database format. any help would be greatly appreciated.

    Thanks,

    Stuart

    Friday, August 22, 2008 12:48 AM

Answers

  • Sounds like the ACE provider for Access 12.0 is not installed. It's generally installed when Office 2007 is installed. If Office 2007 is not installed then you need to download and install the Office 2007 Data Connectivity Components.

     

    Once the ACE provider is installed it should show up in the dropdown for the Provider property.

    Wednesday, August 27, 2008 2:44 AM

All replies

  • Let's see your connection string

     

    Friday, August 22, 2008 12:51 AM
  • Hi, I was not using a connection string per say, at least I do not think so, just the path to the DB on my virtual PC: C:\Documents and Settings\Administrator\My Documents\Visual Studio 2008\xxx.accdb. That's the path I used in the DB connection wizard, when I click on test connection, or ok, it comes back with the unrecognized database format error.

    thanks,

    Stuart

     

    Friday, August 22, 2008 6:24 PM
  • Right click on the connection in the Database Explorer and select Modify Connection. Click on the Advanced button in the Modify Connection dialog box and make sure that the Provider property is set to Microsoft.ACE.OLEDB.12.0 (if you're using an .accdb file).

     

    Monday, August 25, 2008 5:34 PM
  • Thank you Paul for your answer, but I do not have a connection string yet. I am trying to add a new data source to my form with the Data Source Connection Wizard. It asks what type of db it is and I choose Microsoft Access. then in the Add connection dialog box, I input the name of my db xxx.accdb. It finds the Db, but when I click on ok, it comes back with the unrecognized database error. There is an advanced button on the add connection dialog, but the provider property is grayed out and says Microsoft Jet 4.0. I can not change it. If I already had a connection string I am sure your suggestion would work, but what do I do in this case where I an just trying to add the data source? I as yet do not have a data source added. Is there any setting that I am missing, ie references, etc?

     

    Wednesday, August 27, 2008 2:18 AM
  • Sounds like the ACE provider for Access 12.0 is not installed. It's generally installed when Office 2007 is installed. If Office 2007 is not installed then you need to download and install the Office 2007 Data Connectivity Components.

     

    Once the ACE provider is installed it should show up in the dropdown for the Provider property.

    Wednesday, August 27, 2008 2:44 AM
  • Thanks again Paul. That was the problem, I installed Office 2007 on my virtual PC and connected to the database.

    Wednesday, August 27, 2008 3:29 PM