none
SSRS Report Display Question in Reportviewer

    Question

  • I created a report using a list to group data by system names in order to filter data. Based on filtered data, I populate the chart associated to the group. If I run this report in report builder, everything looks good as in following image.

    However, if I put this report in reportviewer 10.0 and render in IE10 and above, all the chart are not displaying correct. Somehow a very big space is added after every chart. I don't have problems with displaying any charts not in list, or any list only contains text data.

    I have been researching this issue for two days, and could not find any solution. Please help. Thank you!

    Friday, January 10, 2014 11:29 PM

All replies

  • Hi Sichen,

    Based on my test, I cannot reproduce the same issue in my test environment.

    In SSRS, if we are use list to display tablix, the location of the tablix in the list would affect the structure of this tablix in the report. For example, if there are lager gap between tablix bottom line and list bottom line, when we preview the report, we will get big space between each charts. Please make sure it is proper gap in your report design.

    The render mistake in IE 10 may be due to the IE compatibility issue. Please try to configure the IE 10 to run in Compatibility View mode to check if the report render correctly.
    Reference: http://social.msdn.microsoft.com/Forums/en-US/01c7db3e-8610-4bdd-957c-8eceba44907e/ie-10-ssrs-reports-no-longer-allows-drop-down-functionality

    If the issue is persist, could you please post your dataset with sample data and the screenshot about your report design? It is benefit for us to do further analysis.

    Regards,
    Alisa Tang

    If you have any feedback on our support, please click here.


    Alisa Tang
    TechNet Community Support

    Monday, January 13, 2014 8:44 AM
    Moderator
  • Thank you for your reply Alisa!

    I was trying to upload some screenshots in this post, but the server wouldnt let me do until my email address is verified. Could you let me know how to do that, so I can show you what I have?

    It seems that the reporting server is forcing report to be rendered in IE5 Quirks mode if I go to http://reportserver/reports directly. Therefore, we changed the render mode to IE5 Quirks mode in developer tool in our ASP., we do see all the reports renders correctly. However, this document mode skews our other page layout.

    Any suggestions will be greatly appreciated!


    Monday, January 13, 2014 4:54 PM
  • Hi Sichen,

    Thank you for your reply.

    You can use SkyDrive to share the screenshots to us.

    As you mentioned, by default, reporting services is render report in IE5 Quirks mode. It is because of SSRS HTML reports depend on IE5 Quirks mode. Based on my test, report manager Web page default document mode is IE5 Quirks, and for others Web page it is Standards mode. It will not affect other page.

    Regards,
    Alisa Tang

    If you have any feedback on our support, please click here.


    Alisa Tang
    TechNet Community Support

    Wednesday, January 15, 2014 8:06 AM
    Moderator