locked
checkbox and msflexgrid

    Question

  • The first column of my grid has the checkboxes in there where can can check and uncheck the checkbox.  But when the grid showing up for the first time, it does not show the checkboxes in the first column.  It's only when you check the cell that the checkboxes showing up.  Is there a property for something that I forgot to set?

    Thanks for your help.

    Friday, June 06, 2008 7:32 PM

Answers

  • Hi,

    You say that this first time the check boxes don't show in the first column, where do they show up?
    What exacly do you mean by 'It's only when you check the cell that that the checkboxes showing up'? You have a cell with no checkboxes but when you click it it shows up?
    Do you add the first column (with the checkboxes) from code or using the designer?

    Ralf
    • Marked as answer by Bruno Yu Thursday, June 12, 2008 7:39 AM
    Saturday, June 07, 2008 1:45 PM
  • Hi xml,

    That's an odd one.  What method or subroutine are you adding the checkbox to.  It appears that you are calling the adding to the datasource after the initial paint, or you could be just putting it in formload, but after the painting of the gridview.

    I'm pretty sure that's why Ralf was asking what he did.  It's the only answer, because, for it to "appear", you are changing the underlying structure after the initial paint.  Step through the loading of the form in the debugger and you will most likely see that this is the case.

    I hope you find this helpful,

    John.
    • Marked as answer by Bruno Yu Thursday, June 12, 2008 7:38 AM
    Monday, June 09, 2008 1:04 AM

All replies

  • Hi,

    You say that this first time the check boxes don't show in the first column, where do they show up?
    What exacly do you mean by 'It's only when you check the cell that that the checkboxes showing up'? You have a cell with no checkboxes but when you click it it shows up?
    Do you add the first column (with the checkboxes) from code or using the designer?

    Ralf
    • Marked as answer by Bruno Yu Thursday, June 12, 2008 7:39 AM
    Saturday, June 07, 2008 1:45 PM
  • first time meaning when i click the button to show the grid.  If i dont click the button the grid will be hidden.  and then when i click the button it will show the grid.  So every time when i start the program and go to that button showing the grid the first column contain checkbox is showing up with blank inside the cell no checkboxes.  But when i start clicking the cell after cell of first column then checkbox appears one by one. Then at that point I can either check or uncheck the box.  If I close the grid and click the button to show the grid again, this time the grid shows the column with all the checkboxes present.  I add the checkboxes in code.  It's only when u restart the program and try to show the grid that's when those checkboxes in the cell not there.

    I hope this explains a little bit clearer.
      
    Sunday, June 08, 2008 4:55 PM
  • Hi xml,

    That's an odd one.  What method or subroutine are you adding the checkbox to.  It appears that you are calling the adding to the datasource after the initial paint, or you could be just putting it in formload, but after the painting of the gridview.

    I'm pretty sure that's why Ralf was asking what he did.  It's the only answer, because, for it to "appear", you are changing the underlying structure after the initial paint.  Step through the loading of the form in the debugger and you will most likely see that this is the case.

    I hope you find this helpful,

    John.
    • Marked as answer by Bruno Yu Thursday, June 12, 2008 7:38 AM
    Monday, June 09, 2008 1:04 AM
  • Hi XmlDoc,

    Do you use VB.NET in this scenario? Please first tell us what control and VS version you are using. It looks like that you use VB6 currently.

    Best regards,
    Riquel

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, June 10, 2008 9:52 AM