none
Error al ejecutar el instalador de mi aplicacion

    Question

  • Hola de nuevo.

    El problema es el siguiente:

    Al momento de "Publicar" mi aplicacion (Click en el item "Publicar" del menú "Generar"), bien , mi aplicacion se genera , hasta aqui no me muestra error pero luego que le doy click al ejecutable para que se instale me sale un msgbox que dice:
    "No se puede iniciar la aplicacion. Pongase en contacto con el proveedor."
    este cuadro tiene "aceptar" y "Detalles" , al dar click en "Detalles" sale un archivo "Log" (el archivo se llama CA451291.log el cual se visualiza por medio del "Bloc de notas"). El mensaje que esta escrito en este "log" es el siguiente (Lo que esta en azul es lo que esta escrito en el "log"):


    INFORMACIÓN DE VERSIÓN DE LA PLATAFORMA
     Windows    : 5.1.2600.131072 (Win32NT)
     Common Language Runtime  : 2.0.50727.832
     System.Deployment.dll   : 2.0.50727.832 (QFE.050727-8300)
     mscorwks.dll    : 2.0.50727.832 (QFE.050727-8300)
     dfdll.dll    : 2.0.50727.42 (RTM.050727-4200)
     dfshim.dll    : 2.0.50727.42 (RTM.050727-4200)

    ORÍGENES
     Dirección URL de la implementación   :
    file:///C:/Documents%20and%20Settings/user/Escritorio/ejecutable_SAS/SAS_2008.application

    RESUMEN DEL ERROR
     Abajo se muestra un resumen de los errores; los detalles de estos errores se incluyen en el registro.
     * La activación de C:\Documents and Settings\user\Escritorio\ejecutable_SAS\SAS_2008.application dio como resultado una excepción. Se detectaron los siguientes mensajes de error:
      + El ensamblaje referido no está instalado en su sistema. (Excepción de HRESULT: 0x800736B3)

    RESUMEN DE ERRORES DE TRANSACCIÓN DEL ALMACÉN DE COMPONENTES
     No se detectó ningún error de transacción.

    ADVERTENCIAS
     No se generó ninguna advertencia durante esta operación.

    ESTADO DE PROGRESO DE LA OPERACIÓN
     * [10/12/2008 8:46:30] : Se ha iniciado la activación de C:\Documents and Settings\user\Escritorio\ejecutable_SAS\SAS_2008.application.

    DETALLES DEL ERROR
     Se detectaron los siguientes errores durante esta operación.
     * [10/12/2008 8:46:31] System.Runtime.InteropServices.COMException
      - El ensamblaje referido no está instalado en su sistema. (Excepción de HRESULT: 0x800736B3)
      - Origen: System.Deployment
      - Seguimiento de la pila:
       en System.Deployment.Internal.Isolation.IStore.GetAssemblyInformation(UInt32 Flags, IDefinitionIdentity DefinitionIdentity, Guid& riid)
       en System.Deployment.Internal.Isolation.Store.GetAssemblyManifest(UInt32 Flags, IDefinitionIdentity DefinitionIdentity)
       en System.Deployment.Application.ComponentStore.GetSubscriptionStateInternal(DefinitionIdentity subId)
       en System.Deployment.Application.SubscriptionStore.GetSubscriptionStateInternal(SubscriptionState subState)
       en System.Deployment.Application.SubscriptionStore.CheckAndReferenceApplication(SubscriptionState subState, DefinitionAppId appId, Int64 transactionId)
       en System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       en System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
       en System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut)
       en System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

    DETALLES DE TRANSACCIÓN DEL ALMACÉN DE COMPONENTES
     No hay información disponible sobre la transacción.

     

    ¿Alguien me puede ayudar a resolver este error?)
    Nota:
    La aplicacion me funcionaba bien, publicaba bien , generaba bien, instalaba bien, etc. pero una vez que "restaure mi sistema" (Tengo windows XP) por causa de un virus (hace unos dias) entonces fue cuando ya no pude instalar el ejecutable, y e lugar de eso, sale este error que aqui les comento.

     

    Restaurar el sistema es "cargar" una configuracion de Windows de algun dia anterior. Lo hice por medio de "Ayuda y soporte tecnico"

     

     

    Saludos.

    Wednesday, December 10, 2008 2:03 PM

Answers

  •  

    Bueno, pude solucionar este problema.

     

    Me gustaria escribir la solución:

     

    ---> Lo que hice fue abrir un nuevo proyecto en blanco y luego agregarle los formularios, clases, modulos, archivos necesarios, etc...

    Agregué absolutamente lo necesario para que mi aplicación funcionara de manera normal (pensaba que de alguna manera algun achivo de mi de soporte de mi programa esta dañado, tambien pensaba que el archivo responsable en generar la clave en el registro de mi windows habia sido afectado).

     

    De esta manera ya no se presentaba ningún error, aunque me queda el misterio de cual pudo haber sido el error.

     

    Saludos.

     

    Gracias a todos por tomarse la molestia en leer este mensaje.

     

    Friday, December 12, 2008 3:15 PM

All replies

  •  

    Bueno, pude solucionar este problema.

     

    Me gustaria escribir la solución:

     

    ---> Lo que hice fue abrir un nuevo proyecto en blanco y luego agregarle los formularios, clases, modulos, archivos necesarios, etc...

    Agregué absolutamente lo necesario para que mi aplicación funcionara de manera normal (pensaba que de alguna manera algun achivo de mi de soporte de mi programa esta dañado, tambien pensaba que el archivo responsable en generar la clave en el registro de mi windows habia sido afectado).

     

    De esta manera ya no se presentaba ningún error, aunque me queda el misterio de cual pudo haber sido el error.

     

    Saludos.

     

    Gracias a todos por tomarse la molestia en leer este mensaje.

     

    Friday, December 12, 2008 3:15 PM
  • Gracias, a mi me ha pasado lo mismo y voy a intentar solucionarlo de la misma manera, hice un restaurar sistema y se estropeó todo, creo que fué a raiz de querer instalar un programa (killsoft htmledit) desde internet que utiliza clickonce y ni siquiera se pudo instalar, ademas me estropeo la instalación de mi (otro) aplicativo.


    Hi, I just begin with Sql Server 2005
    Wednesday, February 25, 2009 9:16 AM
  • Yo lo pude solucionar renombrando la carpeta donde se había instalado en un inicio, en mi caso la carpeta estaba en: C:\Documents and Settings\XXX\Configuración local\Apps\2.0
    En alguna otra ocasión hemos tenido problemas con instalaciones de clickonce y la solución es eliminar la carpeta, pero por precaución solo la renombre y funcionó.
    Espero que le funcione a alguien.

    PD: Para encontrar la carpeta realicé la búsqueda del archivo ejecutable con la opción de mostrar todos los archivos y carpetas ocultos.
    Tuesday, January 07, 2014 7:38 PM