none
There are currently no logon servers available to service this request. Windows 7 Professional Service Pack 1

    Question

  • When the user tries to login into their laptop whether cabled into our domain network or not, they receive a message "there are currently no logon servers available to service this request".  but if cabled into the network and they wait 5 minutes, they are able to sign in without issue but it takes 2 to 3 minutes to load the page.  I signed into the laptop with my domain admin account and received the same message as the user, but when we tried cabled in (5 minutes later), i was able to sign in without issue.  The troubleshooting steps:

    1.  Updated the network driver today (still receiving same result)

    2.  Re-added the computer to the domain today (still receiving same result)

    3.  the event viewer is showing the 5719 NETLOGON message and also 1129 (but the user has been receiving this for a number of months)

    4.  The only thing we haven't tried is creating a new user profile but the only reason I don't see that working is because if its happening with my domain admin account it can't be a profile issue. 

    Any ideas of what could be causing this and is there a fix for it?  I do see there is a hotfix but wasn't sure if we should run it or not. 

    Wednesday, July 25, 2012 10:08 PM

All replies

  • Hi,

    About Event ID 5719, you can  refer these articles:

    Event ID 5719 is logged when you start a computer

    http://support.microsoft.com/kb/938449

    A “Netlogon event ID 5719” event message is logged when you start a Windows based computer

    http://support.microsoft.com/kb/247922

    Furthermore, I suggest to try the following to narrow down the issue:

    1 Temporarily remove all the security software (firewall, anti-virus, anti-spyware, etc.) on the Windows Vista client and check if it works.

    2 Regarding the error message received, please refer to the following Knowledge Base and try the solution in it:

    Error message when you try to log on to a Windows Server 2008-based RODC: "There are currently no logon servers available to service the logon request"

    http://support.microsoft.com/kb/949048

    Hope that helps.

    Regards,

    Leo   Huang

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Leo Huang

    TechNet Community Support

    Thursday, July 26, 2012 6:05 AM
    Moderator
  • Hi,

    How’s everything going? Please feel free to give me any update.

    Thank you for your cooperation.

    Regards,

    Leo   Huang

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Leo Huang

    TechNet Community Support

    Tuesday, July 31, 2012 1:18 AM
    Moderator
  • The issue still is occurring.  I updated the broadcom driver.  I applied the hotfix and re-added the machine to the domain 3 times and still seems to be having the same issue.  The only thing i haven't tried is creating a new profile for the user.  If he's cabled into our network and we both sign into the laptop there's no issues except it sits on the "welcome" for about 30 seconds and then populates the desktops.  but when he shuts down and reboots the laptop and we both try to sign in (his domain user account and my domain admin) we'll get the error message.  Not sure where else to go with this.  I went into the registry of the user's laptop and compared them to mine and everything was the same.  Any other ideas of what would be causing this? 
    Tuesday, July 31, 2012 3:12 PM
  • Hi,

    Thank you for your update.

    If the issue persists, you can check Always wait for the network at computer startup and logon policy is disable under Computer Configuration/Administrative Templates/System/Logon in the Group Policy.

    Regards,

    Leo   Huang

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Leo Huang

    TechNet Community Support

    Wednesday, August 01, 2012 5:46 AM
    Moderator
  • I don't want to change group policy since we have other windows 7 users that are not having this issue.  I just reimaged the user's laptop and its still occurring.  The one thing I do notice is when the user brings the laptop home and signs in he will get he message but when the user is cabled into the network, the user is able to connect.   


    • Edited by AmyR1 Tuesday, August 07, 2012 2:18 PM
    Tuesday, August 07, 2012 2:16 PM
  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue.

    Regards,

    Leo   Huang

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Leo Huang

    TechNet Community Support

    Thursday, August 09, 2012 8:58 AM
    Moderator
  • Does anyone have an update on this?
    Monday, August 20, 2012 10:10 PM
  • Unfortunately, I don't have any answers. I am replying to show that we have the exact same problem in our organization. This is a typical scenario:
     
    1. The user gets to work in the morning, logs in, does some work, then logs out and takes the laptop with him to visit a customer.
     2. At the customer's office the user opens his laptop and tries to log in: "There are currently no logon servers available..."
     3. He tries reboot, no result.
     4. He tries switching off the wifi on the computer (via wifi-button), reboot, no result.
     It always ends with the user heading back HQ and logging in.
     
    This defeats the whole purpose of having a laptop. You can carry it with you, no problem, but you can't actually use it.
     
    The scenario doesn't happen VERY often, but when it happens it is usually at a very bad time..
     
    I had a discussion with our policy-manager and asked if he thought we should increase the "Number of previous logons to cache" in policy, but he disagreed because he meant this was pr user, and since all our users have their own laptop, there are no laptops with more than two users. Microsoft best-practice is to have the cache set to 2, so this is what we have - Number of previous logons to cache:2


    Kthxbai



    • Edited by Stoltenberg Tuesday, October 16, 2012 9:40 AM
    Tuesday, October 16, 2012 9:28 AM
  • I need to bump this thread.


    Kthxbai

    Monday, October 22, 2012 8:21 AM
  • Windows 7 is booting too fast on new computers.

    Windows get's to the logon screen before the network binding process is finished.

    In addition to Leo's advice:

    "If the issue persists, you can check Always wait for the network at computer startup and logon policy is disable under Computer Configuration/Administrative Templates/System/Logon in the Group Policy."

    http://techdom.nl/microsoft/disabling-domain-logon-wait-time-when-no-domain-controller-available/

    Computer Configuration > Administrative Templates > System > User Profiles > Set Maximum wait time for the network if a user has a roaming user profile or remote home directory.

    Monday, October 22, 2012 1:29 PM
  • So if a user reports this problem and we have default policy setting, we should ask the user to wait 30 seconds, then try again?
    Also our users do not have roaming profiles. They get a new profile if they log on to a computer for the first time.
     
    For us this has been a real pain because when a user takes the computer to another location where we have no network, and the computer says "You can't log on because the domain is not available" The natural reaction has been: "Well of course, I am not at the office, but I still need to use the computer. It is a laptop, and I should be able to use it wherever, right?" And we have had no good answers or solution for our users..

    • Edited by Stoltenberg Tuesday, October 23, 2012 11:58 AM
    Tuesday, October 23, 2012 11:56 AM
  • You need to work on this with your network team.

    http://support.microsoft.com/kb/247922

    CAUSE
    This behavior can occur when your server is connected to a switch that has the spanning tree "portfast" setting disabled.

    WORKAROUND
    To work around this behavior, enable the spanning tree "portfast" setting on the switch. For information about the proper use of the spanning tree "portfast" setting, consult the documentation provided with the switch.

    For us this has been a real pain because when a user takes the computer to another location where we have no network, and the computer says "You can't log on because the domain is not available" The natural reaction has been: "Well of course, I am not at the office, but I still need to use the computer. It is a laptop, and I should be able to use it wherever, right?" And we have had no good answers or solution for our users..

    http://technet.microsoft.com/en-us/library/cc755473(v=ws.10).aspx

    Interactive logon: Number of previous logons to cache (in case domain controller is not available)

    Description

    Determines the number of users who can have cached credentials on the computer.

    All previous users' logon information is cached locally so that, in the event that a domain controller is unavailable during subsequent logon attempts, they are able to log on . If a domain controller is unavailable and a user's logon information is cached, the user is prompted with a message that reads as follows:

    Windows cannot connect to a server to confirm your logon settings. You have been logged on using previously stored account information. If you changed your account information since you last logged on to this computer, those changes will not be reflected in this session.

    If a domain controller is unavailable and a user's logon information is not cached, the user is prompted with this message:

    The system cannot log you on now because the domain <DOMAIN_NAME> is not available.

    In this policy setting, a value of 0 disables logon caching. Any value above 50 only caches 50 logon attempts.

    Default: 10


    • Edited by Brano Lukic Tuesday, October 23, 2012 1:30 PM
    Tuesday, October 23, 2012 1:17 PM
  • You mention this http://support.microsoft.com/kb/247922 - This does not apply, because we have no means of changing a customer's network. And some times the users bring the laptop to places where there are no networks. So there must be a setting locally on the computer that we can change/fix..

    As previously stated, I have already asked our policy manager about this setting,"Number of previous logons to cache". He doubts this can be cause of the problem and refers to Microsoft best practice which is said to be 2.


    Kthxbai


    • Edited by Stoltenberg Tuesday, October 23, 2012 1:40 PM
    Tuesday, October 23, 2012 1:33 PM
  • That is a local setting that you would enforce through group policy.

    By enabling this setting it will enable your users to logon to the computers even when there is no network, providing that they have logged in to that computer before successfully.

    If you want to do it through registry

    http://support.microsoft.com/kb/172931

    Cached logon information is controlled by the following key:
       HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\Winlogon\ 
    
       ValueName: CachedLogonsCount
       Data Type: REG_SZ
       Values: 0 - 50
    			
    Tuesday, October 23, 2012 1:56 PM
  • I'm having the same problem. I think it's related to the wireless security settings.

    phil bartling

    Thursday, May 09, 2013 4:45 PM
  • Is there any update on this one? I have several Win7 Laptops that need to work 'offline' (i.e. not connected to any network) which gets "there are currently no logon servers available to service the logon request" upon logging on. Sometimes it does work though, which is really frustrating.

    Event ID 1129 in System Event Log.

    Wednesday, July 31, 2013 5:24 AM
  • I'm having the same problem at our organization and, so far, have not seen any concrete solution that seems to work.  Is there any update on this thread?
    Tuesday, September 17, 2013 7:35 PM
  • You may need to edit group policy as stated in this article:

    Domain member: Disable machine account password changes

    http://technet.microsoft.com/en-us/library/cc785826(v=ws.10).aspx

    Thursday, September 26, 2013 7:05 PM
  • One thing that doesn't seem to be addressed is a possible DNS issue.  I've had many occasions, in complex routed networks that span multiple subnets, where I've had to specify the domain controller as the primary DNS server in order for the logins to work smoothly.  Some systems wouldn't ever see an issue and then others in the same environment would require the DNS server to be specified as the domain controller.  
    Saturday, September 28, 2013 9:33 PM
  • You must raies the domain functional level
    Tuesday, December 10, 2013 2:36 PM
  • Try this when you log in:

    Put a DC server name before user name then backslash and the user name:

    (You can also try that with ip address instead of DC server name - just to be sure if there is no DNS problems)

    DCServerName\UserName

    Thursday, December 12, 2013 3:08 AM
  • I am having this very same issue.  Have you had a solution to this at this time?
    Wednesday, January 29, 2014 10:20 PM
  • I see people keep ending up on this page looking for a solution to this. I've been having the same problem lately and could find no fix, however I did discover one possible cause.

    The woman it was happening to has a hyphenated surname, and as our organisations usernames are forename.surname this made her username an impressive 23 characters long. No matter what I tried I couldn't get her domain account to cache locally on her laptop.

    I set her 'User logon name (pre-Windows 2000)' field within AD to just her first name (9 letters), which would allow her to use either her full name or just her first name to log on to the network. Using just her first name the account logs on and caches fine.

    My guess... there is a limit to the username length in the cache. Hopefully this could be a simple fix to many peoples problems.


    Wednesday, February 12, 2014 3:56 PM
  • I have couple all-in-one Win8 Desktop connecting Domain with Wifi access point router and running good. One day my boss took one of them, un-joined the Domain and play around with Skype via outside Wifi Network. After used, I re-joined the workstation to domain (did not notice whether there was a warning of being logged on with CACHED CREDENTIAL or not). No user could logon the workstation.

    When log on with Cached Credential, I can ping everywhere within our domain and logged on DC via MSTSC. Other workstation which connecting to the same wifi access point router can ping in. However, other workstations with direct wiring to DC that could not ping this workstation.

    Previously I have the similar problem, just disabled the Wifi and direct connect with Cat5 can fix the problem. This DELL XPS does not have Cat5 port for my trick. 

    Any advice?

    Wednesday, March 19, 2014 2:10 AM