none
anonymous access and sign in

    Question

  • hi,

    When I created my publishing site, I allowed for anonymous access. But, when I go to my web site, I am prompted for a login. I don't know how to set it up so that this does not happen.

    I only want to display the 'sign in' link for users that aren't defined as Designers or owners of the site,etc.  Do I need to create another user group?

    Another issue I have is that I don't have a 'sign in' link, so I need to have that too.  My second question related to the 'sign in' link is that I would like to have that link located in my navigation menu. Is that possible?  

     

    thank you very much.


    mgallotti
    Thursday, January 13, 2011 6:05 PM

Answers

All replies

  • Hey mgallotti,

    How did you set up the anonymous access?  Did you follow the same steps outlined in this blog- http://weblogs.asp.net/bsimser/archive/2006/09/25/Enabling-anonymous-access-in-SharePoint-2007.aspx.

    Any details you can provide will be very helpful.

    Thanks!

    Tom


    Tom Molskow - SharePoint Architect - Linked-In - SharePoint Gypsy
    • Marked as answer by Peng Lei Monday, January 24, 2011 4:33 AM
    Thursday, January 13, 2011 10:04 PM
  • HI,

     

    I believe that I enabled it via Central Administration.

    thanks.


    mgallotti
    Friday, January 14, 2011 1:30 AM
  • Hey mgallotti,

    OK, well that's halfway there, in addition you need to follow the steps below:

    • Return to your sites home page and navigate to the site settings page. In MOSS, this is under Site ActionsSite Settings Modify All Site Settings. In WSS it’s under Site ActionsSite Settings.
    • Under the “Users and Permissions” section click on “Advanced permissions”
    • On the “Settings” drop down menu (on the toolbar) select “Anonymous Access”
    • Select the option you want anonymous users to have (full access or documents and lists only)

    Thanks!

    Tom


    Tom Molskow - SharePoint Architect - Linked-In - SharePoint Gypsy
    • Edited by Mike Walsh FIN Wednesday, January 19, 2011 7:15 AM LMK again
    Friday, January 14, 2011 1:58 PM
  • hi Tom,

     

    I have anonymous users set to view everything.  ( I don't have much content really, except for a few pages that are 'public').  But, I will need to have some document libraries that are supposed to be viewed by certain people.  Then, I also will have a calendar that shows events- I'm thinking that this might also be for people who are allowed to view private meetings,etc.
    Not sure how to approach this. 

     

     


    mgallotti
    Wednesday, January 19, 2011 12:59 AM
  • Hey mgallotti,

    Just for clarity, you did double checked the configurations I provided and the anonymous access is still not working - is that correct?

    You can always set each document library or list to have its own unique permissions; you just need to go to the list or library's security settings, break inheritance, and then grant permissions only to the people or groups you want to have access.

    Events are essentially the same except you set the item level permissions instead of the list\library level permissions.

    Thanks!

    Tom

     

     


    Tom Molskow - SharePoint Architect - Linked-In - SharePoint Gypsy
    Wednesday, January 19, 2011 8:00 PM
  • Hi Tom,

     

    I double-checked to make sure I have anonymous to view everything and I still am prompted for a user name and login.  I have not published this site yet - as it's not completed.  Could that be why anonymous does not work?

     

    thanks!


    mgallotti
    Wednesday, January 19, 2011 10:01 PM
  • Hey mhoran,

    If you can roll it back it certainly wouldn't hurt to try.

    Thanks!

    Tom


    Tom Molskow - SharePoint Architect - Linked-In - SharePoint Gypsy
    Thursday, January 20, 2011 12:50 AM
  • hi Tom,

     

    It still asks for a user's login information.  Maybe I need to do something with IIS?  I thought it would already be set up, but maybe it's not.   I'll see what I can find. 

     

    thanks, Tom.

     

     


    mgallotti
    Thursday, January 20, 2011 7:04 PM
  • It happens sometime, when you refer some images/logo in master page, where the permission inheritence is broken.

    Download this tool : http://www.fiddler2.com/fiddler2/

    Its a web debugger tool, It runs with your browser to understand what's going on behind the scenes.

    Then you browse the site in browser, watch the fiddler logs, you would see exactly which piece of your page is prompting the authentication.

     


    Cheers, ~Uday, http://www.mstechblogs.com/sharepoint

     

    Thursday, January 20, 2011 8:18 PM
  • Hey mgallotti,

    Uday has a good idea but I have a way to resolve it without using Fiddler (which is often not allowed in secure environments). 

    Please post the URL from the access denied message you get.

    Then download this free sharepoint tool - SharePoint Explorer - http://download.mondosoft.com/Ontolica/SharePointExplorer_V1_5_1_For_WSS3.zip

    Then I will show you how to use this tool to resolve the problem.

    Thanks!

    Tom

     

     


    Tom Molskow - SharePoint Architect - Linked-In - SharePoint Gypsy
    • Marked as answer by Peng Lei Monday, January 24, 2011 4:33 AM
    Thursday, January 20, 2011 9:49 PM
  • hi Tom,

     

    I will download the tool, but may not need it right now because I can see my page without logging in. Except for the fact that I now cannot see my global navigation bar!  ( I posted a question about this in another post a little earlier )..  

    Thank you very much for all your help.


    mgallotti
    Friday, January 21, 2011 6:03 PM