locked
Request Failed: Unable to connect to remote server

    Question

  • I've seen several people post this error, but none of the suggested solutions have resolved my issue. This seems very simple to me, so I'm sure I am missing something very basic. I am very new to using Visual Studio for testing, so please bare with me.

    I have a local ASP.NET 2.0 application that strictly uses Windows security. I have recorded a very basic web test that navigates to one page within my application and that is all. When I run the test, I get a "Request Failed: Unable to connect to remote server" error. I have verified that the proxy setting is blank. I've recorded several other tests against .aspx pages and .htm pages with the same results.

    I am using the following version of Visual Studio.

    Microsoft Visual Studio 2005
    Version 8.0.50727.42  (RTM.050727-4200)

    Microsoft .NET Framework
    Version 2.0.50727

    Installed Edition: Enterprise - 77718-007-4000003-41135

    Saturday, February 11, 2006 7:38 PM

Answers

  • Are you running some sort of firewall/proxy client such as MS ISA Firewall Client?

    Josh

    Friday, February 17, 2006 6:54 PM

All replies

  • This error usually occurs when you are trying to hit a page that needs the proxy property to be set.  I see you said that it is blank.  Are your internet settings in Internet Explorer using a proxy?
    Monday, February 13, 2006 3:15 AM
    Moderator
  • No. I do not use a proxy. My IE settings are set to "Automatically Detect Settings". The page I am trying to hit a from a web app on my local machine.
    Monday, February 13, 2006 3:44 AM
  • Is your test going against a web site deployed to IIS or to a website using the development web server,cassini?
    Monday, February 13, 2006 1:33 PM
    Moderator
  • I am testing against a published web application on my local machine. Published to IIS.
    Monday, February 13, 2006 1:56 PM
  • David,

    Can you disable proxy detection and verify you can hit the page(s) in IE?

    Josh

    Monday, February 13, 2006 2:59 PM
  • I assume when you say disable proxy detection, you mean uncheck "Automatically Detect Settings" under IE settings. If so, I get the same results when automatically detecting settings just as I do when leaving the box unchecked. In both cases, I can hit the local app or any other Internet site when just using IE; however, when I attempt to run a web test against the local app, I get the same failure.

    Monday, February 13, 2006 3:39 PM
  • Is this error from just running a webtest in playback or is this from running this webtest in a loadtest?
    Tuesday, February 14, 2006 10:22 PM
    Moderator
  • For now, it is playback only.
    Wednesday, February 15, 2006 3:35 PM
  • Are you running some sort of firewall/proxy client such as MS ISA Firewall Client?

    Josh

    Friday, February 17, 2006 6:54 PM
  • I was dealing with this error for days and had done everything that was supposed in several fora. Without success. Finally (just before re-installing my machine completely) I solved it by removing old Visual Studio parts (beta's) and an inactive(!) firewall program.

    Waldweben

    Wednesday, March 22, 2006 9:43 PM
  •  

    I seem to get this error from playing back through a website. Even when I am trying to run a webtest I get unable to connect to remote server.
    Tuesday, November 06, 2007 12:18 PM