locked
fatal error C1083: Cannot open include file: 'allegro.h': No such file or directory

    Question

  •  

    ok now put both the include file and the lib file in virtual studio but no matter what i do this same error always comes up i am at my wits end. please help
    Thursday, February 28, 2008 10:35 PM

All replies

  • Hi,

     

    Does the “include files” directory you added is that one “allegro.h” reside in?

     

    Thanks!

     

    Monday, March 03, 2008 10:41 AM
  •  

    yes did a search to find the allego.h file
    Monday, March 03, 2008 3:42 PM
  • Put them where in VS? Put them how in VS?

     

    If added to the include file search path in the IDE options,

    what is the exact string you added? (Copy and paste it

    here, don't type it in.)

     

    - Wayne

     

     

     

    Monday, March 03, 2008 4:27 PM
  •  

    C:\\Documents and Settings\\cnh5678\\Desktop\\allegro\\allegro-4.9.2\\include
    Monday, March 03, 2008 6:16 PM
  • Where did you put this path?

     

    If in the IDE Tools/Options/Projects and Solutions/VC++ Directories,

    "Show directories for/Include files" (phew) -  then try it without the

    double backslashes, just use one:

    C:\Documents and Settings\cnh5678\Desktop\allegro\allegro-4.9.2\include

     

    You may also have to surround it with quotes:

    "C:\Documents and Settings\cnh5678\Desktop\allegro\allegro-4.9.2\include"

     

    Double backslashes are needed in *source code*, as the backslash is used

    as the escape (ESC) character. They are not normally needed in path

    statements.

     

    - Wayne

     

    Monday, March 03, 2008 6:49 PM
  • tried that and it didnt work gah this is annoing

    Monday, March 03, 2008 6:52 PM
  •  

    If all else fails, try putting the header file in the same directory

    where your source code file is which #includes the header.

    If it still fails, clean your spectacles and look hard at the

    spelling. You may have transposed a couple of letters in the

    filename, added or omitted double letters, etc.

     

    - Wayne

     

    Wednesday, March 05, 2008 2:40 PM
  • now it findes allegro.h but now it cant find another file in the include folder base.h which is in the same folder as allegro.h sorry about being such a hassle

     

    Wednesday, March 05, 2008 4:17 PM
  • Right Click "Allegro.h", click "Open Document". Then edit the #include "allegro/base.h" to #include "base.h". After this, there will be another problem, but i'm working on it =)

    Also, don't forget to copy Base.h to your project.
    Monday, December 22, 2008 7:47 PM