locked
CodedUI test status under 'Active Runs' shows 'Stopping' even tough test has stopped on Agent

    Question

  • I am running  Coded UI tests remotely (from the Visual Studio on my desktop via the COntroller) on a Visual Studio Agent machine on which the agent has been configured as a interactive process.

    In one instance a Coded UI test running on the agent failed for some reason and status under 'Test Runs' (on the Visual Studio on my desktop) -> ' Active Runs' kept on saying  ' Running' . So I right clicked the test under 'Active Runs', and then clicked 'Stop Test Run'. The 'Status' of the test under active runs showed 'Stopping' and it continues to show 'Stopping' even tough the actual coded UI script has stoped playing on the agent.

    I tried right clicking the particular test under 'Active Runs' and clicked 'Delete Test Run'/ 'Stop Test' many number of times , logged off the agent machine and logged back in and reconfigured the agent as a interactive process, rebooted the agent machine but the status of this test still shows 'Stopping'. I can launch other coded UI tests on the agent, queue tests but the one test still shows 'Stopping' status under 'Active runs'- how do I get rid of this.??

    Also is there a temp directory on the agent machine which stores the coded ui test run status/logs or some footprint of the coded UI test run irrespective of whether the test passed/failed/paused.

    Thanks

    - Mrunal


    Mrunal
    • Moved by Vishnu [MSFT]Microsoft employee Friday, December 30, 2011 10:23 AM Remote Execution (From:Visual Studio UI Automation Testing (includes CodedUI))
    Thursday, December 29, 2011 5:09 PM

All replies

  • Hello Mrunal,

    If you just run that Coded UI test locally (do not run it on the test agent machine), will you get the same issue? In addition, what is tested in your Coded UI test? Is it a desktop application or web pages in the browser? If your Coded UI tests that start a browser, the service account for the test agent is used to start that browser. This service account must be the same as the user account that is the active user on this machine. If is not the user account, the browser will not start.

    For another thing you should also be aware is that the computer that is running an agent on which you want to run Coded UI tests can’t be locked or have an active screen saver.

    Please refer to this article for the further information:

    http://msdn.microsoft.com/en-us/library/ee291332.aspx

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us
    Monday, January 02, 2012 3:36 AM
    Moderator
  • Vicky Thank - below are the answers to your questions: 

    If you just run that Coded UI test locally (do not run it on the test agent machine), will you get the same issue?
    -->NO

    what is tested in your Coded UI test? Is it a desktop application or web pages in the browser?
    --> Web application and service account (i.e the one used to run the agent as a interactive process) is the active user on the machine. Browser always starts.

    -->Computer that is running the agent for Coded UI Tests is not locked and screen saver is disabled.

    I still do nothave any resolution to the original issue - see my original post

     

     

     


    Mrunal

     

    • Edited by MD_VS2010 Tuesday, January 03, 2012 8:32 PM
    Tuesday, January 03, 2012 8:32 PM
  • To get rid of "Stopping..." issue, try restarting the test agent.

    Thanks,

    Anuj


    http://www.anujchaudhary.com
    Wednesday, January 04, 2012 6:12 AM
  • Hi Anuj,

    I already tried resrating the agent and also these actions  - logged off the agent machine and logged back in and reconfigured the agent as a interactive process, rebooted the agent machine  - still it is showing in stopping state

    Also please see this question from my first post - is there a temp directory on the agent machine which stores the coded ui test run status/logs or some footprint of the coded UI test run irrespective of whether the test passed/failed/paused.

    Thanks

    - Mrunal

     

     

     

     


    Mrunal
    Wednesday, January 04, 2012 2:23 PM
  • The temp directory is on the contoller and agent machines at %localappdata%\VSEQT

    You can also try deleting the test run using tcm run /delete http://msdn.microsoft.com/en-us/library/ff942469.aspx

    Thanks,

    Anuj


    http://www.anujchaudhary.com
    Wednesday, January 04, 2012 5:52 PM
  • Hi Anuj,

    Will try the TCM option.

    Thanks,

     

     

     

     

     


    Mrunal
    Friday, January 06, 2012 4:38 PM