locked
You must first install Microsoft .NET Framework 2.0SP1 before...

    Question

  • Hi,

    I am trying to install Orcas on a XP SP2 machine. However, it fails. After checking the error logs, I found out that the error is due to the .NET 3.5 redistributable. I then tried to download the dotnetfx35setup.exe and to install it, but no success so far.

    The error I get is:
    Product: Microsoft .NET Framework 3.5 (Pre-Release Version) -- You must first install Microsoft .NET Framework 2.0SP1 before installing or repairing this product.

    I have .NET 1.0, .NET 1.1 and .NET 3.0 on this machine (I develop WPF and have the WPF development environment installed). Where can I find the .NET 2.0 SP1??

    Greetings,
    Laurent
    Monday, June 11, 2007 6:30 PM

Answers

  • Hi,

    Sorry, I meant to post the solution to that here, but I forgot.

    I blogged about the steps I took, and that solved my problem, thanks to the help of Aaron Stebner, who works for Microsoft.

    See the steps here:
    http://geekswithblogs.net/lbugnion/archive/2007/06/15/Road-to-Silverlight-Aaron-Stebner-is-a-great-person.aspx

    In short, you must uninstall all the versions of the .NET framework, then run a tool (the link is my blog entry), and then reinstall .NET 3.5. Since .NET 3.5 contains .NET 2.0 and .NET 3.0, there is no need to reinstall there. You must, however, reinstall .NET 1.1 separately.

    HTH,
    Laurent
    Sunday, June 17, 2007 8:18 PM

All replies

  • Hey, I put a comment on your blog too...but just in case you didn't see it there, have you upgraded VS2005 to SP1? I believe that will resolve your issue. I'm running VS2005 and Orcas side by side since beta1 and it installed without issue for me.

    For extreme levels of beta testing, try this on for size. I've got Windows Server 2008 Beta 3 running with "Orcas", "Orcas TFS", Blend 2 CTP, Silverlight 1.1 preview, and Acropolis CTP. I'm currently using this setup as a remote app from my XP Professional box.

    Anyone have me beat there?

     

    Monday, June 11, 2007 9:17 PM
  • Hi Mike,

    Yes, unfortunately I do have VS2005 SP1 installed, but probably something went corrupt. I see two solutions:

    - Wait until I get Vista and reinstall everything from scratch (that would be next month)
    - Reinstall VS2005 SP1 and try again with Orcas. Maybe I'll start with this.

    Technically, the setup you describe is alpha, since Silverlight 1.1 is still in this stage! Impressive :-)

    Laurent
    Tuesday, June 12, 2007 7:45 AM
  • It's never that easy is it? Here's another thread on the topic...it might be VSTO causing the grief. Someone else mentioned in the thread that the installer might not work in directories with spaces "Documents and Settings" strikes again.
    Tuesday, June 12, 2007 5:39 PM
  • Hi Mike,

    Great, let me see the other thread and I'll try it and write about it on my blog. Additionally, Aaron Stebner contacted me and offered his help, so I have good hopes that it will work eventually.

    Thanks a bunch!
    Laurent
    Wednesday, June 13, 2007 7:37 PM
  • I have the same problem, when try to install NET Framework 3.5 shows error "you must first install microsoft .net framework 2.0sp1 before installing or repairing this product". Computer have XP SP2 and frameworks 1.0, 1.1, 2.0, 3.0 . This is test computer, there is no Visual Studio installed. I try to repair framework 2.0 but it not helps, also I tried to unninstall it but this can't be done because "the uninstall cannot continue because it might affect other applications that are installed. For more information, see http\\support.microsoft.com/...".

     

     

    Sunday, June 17, 2007 5:54 PM
  • Hi,

    Sorry, I meant to post the solution to that here, but I forgot.

    I blogged about the steps I took, and that solved my problem, thanks to the help of Aaron Stebner, who works for Microsoft.

    See the steps here:
    http://geekswithblogs.net/lbugnion/archive/2007/06/15/Road-to-Silverlight-Aaron-Stebner-is-a-great-person.aspx

    In short, you must uninstall all the versions of the .NET framework, then run a tool (the link is my blog entry), and then reinstall .NET 3.5. Since .NET 3.5 contains .NET 2.0 and .NET 3.0, there is no need to reinstall there. You must, however, reinstall .NET 1.1 separately.

    HTH,
    Laurent
    Sunday, June 17, 2007 8:18 PM
  • I am tyring to download this tool from the specified site but it is showing me as server unreachable. It would be really great help if you can please send me the tool on haroon.wangde@barclayscapital.com asap.  Thanks in advance.
    Monday, July 09, 2007 7:23 AM
  • In fact when you install .NET 3.5 Beta, the installer will patch your .NET 2.0 and .NET 3.0 to SP1 automatically if successful.

    What you met is that the installer failed to patch your .NET 2.0 installation. Do not know how to correct this issue. I have installed .NET 3.5 Beta on a lot of machines but never see this issue.
    Friday, October 12, 2007 6:12 AM