none
Telephony Callpickup

    Question

  • Hello,

     

     I was wondering if it's possible to change the way the Agent Desktop accepts incoming calls? I've managed to integrate our Cisco CME but the Agent Desktop automatically accepts the call, we want to have the ability for the agent to choose to accept the call. Is it possible to change this default behavour?

     

    Thanks

    Friday, October 19, 2007 10:04 PM

Answers

  • The telephony events that you have registered with the telephony server are received by the desktop. It's upto you that you react to the call or not. Also, if the agent's device is not set to automatically take the calls then the call will not be connected. But if you pick up the call, then you will receive the connected events. Here, you could query the device state and opt to not react to the 'connected' events. You can have a visual indicator on the desktop, to have the agent manually react to that particular call. I hope that gives you some pointers..

    Friday, October 26, 2007 6:47 PM

All replies

  • The telephony events that you have registered with the telephony server are received by the desktop. It's upto you that you react to the call or not. Also, if the agent's device is not set to automatically take the calls then the call will not be connected. But if you pick up the call, then you will receive the connected events. Here, you could query the device state and opt to not react to the 'connected' events. You can have a visual indicator on the desktop, to have the agent manually react to that particular call. I hope that gives you some pointers..

    Friday, October 26, 2007 6:47 PM
  • Hi Shaun,

     

     Could you plz let me know how u integrated ur Cisco CME with Agent Desktop. Have you changed any code...

     I am tring to integrate a softphones with Agent Desktop(other than one provided by CCF).

     This informatio would be a great help for me.

     Thanks in Advance.

     

    Monday, April 14, 2008 9:42 AM
  • Ms Mitchell,

     

        We are trying to integrate the Softphone which comes with CCF and have failed miserably!

    We do not get any errors whatsoever, and when we try to dial using softphone, it says 'Ringing' but does not show up on the Agent Desktop (or anywhere else for that matter!)

     

    Could you kindly let us know how we could do this or is it easier to integrate with the Cisco CME?

     

    Many thanks for your time.

    Cyrene Jacob

    Monday, July 21, 2008 6:31 AM
  • Hi Jacob,

     

    I faced the similar problem while testing with that soft phone.

    I solved it.

     

    You need to do some changes for this to work...

     Go to control panel, open Phone and Modem Options,

     under general tab change the country/region value to United States and Area Code to 0 (Zero).

     

    I made above changes...

    Hope this will be helpful to you .

     

     

     

    Tuesday, July 22, 2008 4:09 AM
  • Kaaru,

       Thank you so much for the suggestion. Unfortunately, this did not work for me.

    The default is United States with Area Code 0!

     

    I still do not know what else is missing!

    Thanks and regards,

    Cyrene Jacob

    Tuesday, July 29, 2008 6:19 AM