none
SSRS bookmarks confused when deployed

    Question

  • Tablix A has bookmark value of TableOfContents and tablix B has a textbox in a group with the bookmark action.  In SQL Data Tools the bookmarks work just fine. However after publishing to a native mode server the the bookmark jumps down toward the end of the report instead of to the top where Tablix A resides?

    The browser is IE9 and this misbehaviour occurs in native mode SSRS 2012 and in sharepoint 2010 mode.

    Wednesday, June 19, 2013 6:57 AM

Answers

  • Hi Colin,

    I have tested it on my enviroment, the bookmark work weel both on native mode SSRS 2012 and in sharepoint 2010 mode. I think the root cause should exist in the report itself or incorrect design steps. So please must make sure you give the right expression for the bookmark property. Please follow this link to see whether some steps you have Omitted http://msdn.microsoft.com/en-us/library/dd239378.aspx

    If the issue still exist, you's better post your report design steps and your XML file for us supply further troubleshooting. If the datasource is not available, please give some sample datasource and dataset by the following E-mail address? Then, I can try to reproduce the issue again and for further analysis.
    E-mail:sqltnsp@microsoft.com 

    Thanks for your understanding.

    Regards,
    Charlie Liao

    If you have any feedback on our support, please click here.


    Charlie Liao
    TechNet Community Support

    Thursday, June 20, 2013 3:20 AM