locked
Visual studio 2010: reference dlls disappear in object browser during build and fails with namespace not availabla

    Question

  • Visual studio 2010: Referenced dlls disappear in object browser during build and fails with namespace not available, eventhough I see the dlls in references.

    Using Framework3.5

    Not sure if this happens if the project was created with VS 2009 and opened in 2010

    I notice that the referenced dll that were loaded had strong name as true. The dlls which disappear during build has strong name as 'false,

    If this is a cause, Can you pls let me know for any workaround?

    Thanks!

    Friday, November 12, 2010 7:00 PM

Answers

  • Hello,

    You can first try the following steps to see if they help:

    a)     Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b)     Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )

    c)     Try creating a new project. Sometimes corrupted project settings can cause problems.

    If they all not help, you may post your issue on corresponding language forum to see if you can get any help as this forum here is for the testing tools of visual studio.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, November 18, 2010 3:17 AM

All replies

  • One thing I noticed when I create the Solution (explorer)with visualstudio 8 and added the projects, and build doesn't complain or give errors.

    The issue appears only if solution explorer is created with 2010, dlls cannot get loaded eventhough it appears in references. 

    Monday, November 15, 2010 7:19 PM
  • Hello,

    You can first try the following steps to see if they help:

    a)     Try to run devenv /ResetSettings (in command prompt) to eliminate the related potential settings problem.

    b)     Try disabling Add-ins (e.g. “Tools” | “Add-in Manager”) or run “devenv.exe /SafeMode”.This can eliminate the possibility that third party Add-ins or packages are causing problems. (For more detailed VS command line switches information, see: http://msdn2.microsoft.com/en-us/library/xee0c8y7.aspx )

    c)     Try creating a new project. Sometimes corrupted project settings can cause problems.

    If they all not help, you may post your issue on corresponding language forum to see if you can get any help as this forum here is for the testing tools of visual studio.

    Thanks.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, November 18, 2010 3:17 AM
  • I was having this same issue and finally figured it out.

    You need to change your target framework from ".NET Framework 4 Client Profile" to ".NET Framework 4"

    Here's a more in depth explanation I typed up after finally getting there:
    http://www.robfine.com/aspnet/ReferenceRemovedBuildVisualStudio2010

    Good luck!

    • Proposed as answer by John Hennesey Tuesday, February 01, 2011 2:12 PM
    Thursday, January 20, 2011 9:59 PM
  • Thanks Rob, fixed my issues!
    "The improbable we do, the impossible just takes a little longer." (Steven Parker)
    Monday, May 23, 2011 8:59 PM
  • grrr....
    Friday, March 23, 2012 8:30 PM